Bug 141201 - in kmail search windows when double clicking in a message doesnt open it
Summary: in kmail search windows when double clicking in a message doesnt open it
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: search (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 92546 124950 143189 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-04 23:49 UTC by
Modified: 2009-07-29 15:02 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 2007-02-04 23:49:28 UTC
Version:           1.9.6 (using KDE 3.5.6, compiled sources)
Compiler:          Target: x86_64-mandriva-linux-gnu
OS:                Linux (x86_64) release 2.6.17-8mdv

in kmail search windows when double clicking in a message doesnt open it.
However i see that it apepars in kmail main window, but is should open the message window when double clicking in earch window...
Comment 1 Philip Rodrigues 2007-02-05 21:13:40 UTC
I'd tend to agree - since the search dialog (potentially) hides the main window, this suggestion might make sense.
Comment 2 Allen Winter 2007-03-10 01:17:04 UTC
In KDE 3.5.7 and above you will have a RMB menu on each search message
where you can do all the normal stuff... replay, forward, etc.

You can also drag-n-drop the messages.

However, double-clicking the message does not open it in the separate message window.  Which I think is a good idea.

So I am copying Volker on this, since he did a lot of work in this area recently.
Comment 3 Bram Schoenmakers 2007-03-10 01:22:11 UTC
*** Bug 124950 has been marked as a duplicate of this bug. ***
Comment 4 Bram Schoenmakers 2007-03-10 20:42:20 UTC
*** Bug 92546 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2007-03-18 21:35:36 UTC
*** Bug 143189 has been marked as a duplicate of this bug. ***
Comment 6 Unknown 2008-02-26 17:09:01 UTC
Is this still being worked on? Will such a functionality perhaps be included in KDE4 KMail?
Comment 7 Maciej Pilichowski 2008-05-07 17:57:06 UTC
I vote against this feature (at least as it is expressed here) -- but I would opt that KMail would switch the dialogs, then if you want to open the message you would double click again or hit enter again.

Why this way -- because this wish is too much. Just imagine you make a split screen, with switching behaviour (on enter/doubleclick) you will get efficient environment, you can get everything you want. But with forced popup with message in order to do some basic navigation you have to close it each time -- extra effort, and unwanted (at least by me).
Comment 8 Maciej Pilichowski 2008-05-07 18:36:14 UTC
Duplicate of:
https://bugs.kde.org/show_bug.cgi?id=69492
?
Comment 9 dag 2008-12-17 15:51:05 UTC
I do argue that if you do a search for a message, you really want to see it if/when doubleclicking on it. At least I would like an option to open it. Now just tried 4.1.82 and it shows the headers in the message window, but not the contents??
Comment 10 Maciej Pilichowski 2008-12-17 15:59:47 UTC
Everybody here agrees on that -- that seeing is important. But we (at least I) differ what would be the best solution for seeing it.

Btw. wouldn't quite another approach be even better -- something like folder filter. So you search-filter messages, and browse in exactly the same manner you are used to. Just thinking out loud.
Comment 11 Unknown 2009-04-19 10:01:30 UTC
With KDE 4.2.2, the situation with the regard to this problem got worse: In KDE3, at some point it started correctly opening messages when I double-click them in the search view - they appeared as new window. Now in KDE4, when I double-click, it opens them in the preview part of the main KMail window, which is behind the search window. So first of all you don't see anything happen as the search window hides the message, and even if you know it will be there you have to constantly switch between search window and main window.
Comment 12 Allen Winter 2009-07-29 15:02:48 UTC
I fixed this for the KDE 4.3.0 release.