Bug 140543 - crash on index (re)generation
Summary: crash on index (re)generation
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: index (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 143411 146290 146404 147779 149682 150927 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-24 11:44 UTC by Mircea Bardac
Modified: 2010-01-05 01:05 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
This e-mail crashes KMail (2.16 KB, text/plain)
2007-05-13 19:03 UTC, Sasa Kara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mircea Bardac 2007-01-24 11:44:10 UTC
Version:           Kmail coming with KDE 3.5.6 (using KDE Devel)
Installed from:    Compiled sources

KMail in KDE 3.5.6

My system froze once (unknown reason) and I had to reset - this bug might be related to the other bugs mentioning loss of data on system restart/crashing.

After the restart, Kontact (kmail) kept crashing, making me unable to read my mails. I suspected a problem with the index and deleted all of them. After more digging and starting Kontact with some mail folders moved.. I managed to track the misbehaving folder.

I also reproduced the crash by creating a new user, starting kontact, creating a dir witht the same name, stopping contact, moving the old dir contents in the newly created dir, restarting Kontact.

The buggy folder can be found here: http://mircea.bardac.net/temp/jdev.tar.gz

The backtrace of the crash is the following (not sure if it helps much):

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found) [ x many times ]
[Thread debugging using libthread_db enabled]
[New Thread -1250563824 (LWP 21935)]
(no debugging symbols found) [ x many times ]
[KCrash handler]
#9  0xb4be8ac2 in KMFolderMaildir::readFileHeaderIntern ()
   from /opt/kde/lib/libkmailprivate.so
#10 0xb4bfaff7 in KMFolderMaildir::createIndexFromContents ()
   from /opt/kde/lib/libkmailprivate.so
#11 0xb4afc20d in KMFolderMaildir::open () from /opt/kde/lib/libkmailprivate.so
#12 0xb4aa5852 in KMFolderIndex::fillMessageDict ()
   from /opt/kde/lib/libkmailprivate.so
#13 0xb4afec7b in FolderStorage::invalidateFolder ()
   from /opt/kde/lib/libkmailprivate.so
#14 0xb4b00a74 in FolderStorage::readFolderIdsFile ()
   from /opt/kde/lib/libkmailprivate.so
#15 0xb4b00aa1 in FolderStorage::registerWithMessageDict ()
   from /opt/kde/lib/libkmailprivate.so
#16 0xb4b5cdac in KMFolder::KMFolder () from /opt/kde/lib/libkmailprivate.so
#17 0xb4b5ed3a in KMFolderDir::reload () from /opt/kde/lib/libkmailprivate.so
#18 0xb4b5e6e1 in KMFolderDir::reload () from /opt/kde/lib/libkmailprivate.so
#19 0xb4b5e6e1 in KMFolderDir::reload () from /opt/kde/lib/libkmailprivate.so
#20 0xb4b5f046 in KMFolderMgr::setBasePath ()
   from /opt/kde/lib/libkmailprivate.so
#21 0xb4b5f31a in KMFolderMgr::KMFolderMgr ()
   from /opt/kde/lib/libkmailprivate.so
#22 0xb4bb0069 in KMKernel::init () from /opt/kde/lib/libkmailprivate.so
#23 0xb4cc8dfb in KMailPart::KMailPart ()
   from /opt/kde/lib/kde3/libkmailpart.so
#24 0xb4cc9d01 in KParts::GenericFactory<KMailPart>::createPartObject ()
   from /opt/kde/lib/kde3/libkmailpart.so
#25 0xb75e97ef in KParts::Factory::createPart ()
   from /opt/kde/lib/libkparts.so.2
#26 0xb7d99feb in Kontact::Core::createPart ()
   from /opt/kde/lib/libkpinterfaces.so.1
#27 0xb7d9a3f7 in Kontact::Plugin::loadPart ()
   from /opt/kde/lib/libkpinterfaces.so.1
#28 0xb51dcf95 in KMailPlugin::createPart ()
   from /opt/kde/lib/kde3/libkontact_kmailplugin.so
#29 0xb7d985e2 in Kontact::Plugin::part ()
   from /opt/kde/lib/libkpinterfaces.so.1
#30 0x0805d76f in ?? ()
#31 0x081b0710 in ?? ()
#32 0x00000000 in ?? ()
Comment 1 Martin Koller 2007-03-04 18:01:34 UTC
I can not reproduce it with the zip file you provided (but I had to delete the .jdev.index file so that kmail rebuilds the index).
Can you reproduce always with the described steps ?
I see that you have kmail compiled from source, but without debugging info.
Can you recompile it with --enable-debug and provide another backtrace, please.
Comment 2 Tommi Tervo 2007-03-24 08:20:34 UTC
*** Bug 143411 has been marked as a duplicate of this bug. ***
Comment 3 Sasa Kara 2007-05-13 19:03:47 UTC
Created attachment 20560 [details]
This e-mail crashes KMail

Please try to create a new mail folder from KMail. Then exit KMail, copy the
attached file to <folder>/new, delete the <folder>.index, <folder>.index.ids,
<folder>.index.sorted.
Then start KMail again. It will crash.

Tested with version 1.9.6 (newest from Fedora 6).
Comment 4 Thomas McGuire 2007-06-05 22:06:22 UTC
*** Bug 146290 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2007-06-05 22:06:40 UTC
*** Bug 146404 has been marked as a duplicate of this bug. ***
Comment 6 Martin Koller 2007-06-22 19:38:41 UTC
@comment #3: It does not crash for me with latest kmail from SVN from today.
Comment 7 Tommi Tervo 2007-07-11 10:39:50 UTC
*** Bug 147779 has been marked as a duplicate of this bug. ***
Comment 8 JC Cardot 2007-08-18 18:33:58 UTC
Same thing here, same version.
Fixed by finding mails with the line
Content-type: text/plain; charset=
and changing it to (for example):
Content-type: text/plain; charset=UTF-8
Comment 9 Bram Schoenmakers 2007-09-09 11:49:28 UTC
*** Bug 149682 has been marked as a duplicate of this bug. ***
Comment 10 Tommi Tervo 2007-10-17 13:39:18 UTC
*** Bug 150927 has been marked as a duplicate of this bug. ***
Comment 11 Björn Ruberg 2010-01-03 00:44:06 UTC
Is this still a problem in recent kmail versions? (kde 4.3 or above?)
Comment 12 Mircea Bardac 2010-01-03 01:10:11 UTC
Unfortunately my current setup does not allow me to retest this (and a change won't happen anytime soon). Also, it appears I no longer have the archive available online at the address in the original issue.

It might be fixed if the solution provided by JC Cardot (#8) is already present in KDE 4.3. The e-mail sample provided by Sasa Kara (#3) matches the bug characteristics mentioned in #8.

I believe it could be pretty safe to assume that, if the solution in #8 is already implemented, this bug is no longer present and the bug report can be closed as FIXED or WORKSFORME.