Bug 143411 - KMail crashes on startup
Summary: KMail crashes on startup
Status: RESOLVED DUPLICATE of bug 140543
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-24 08:10 UTC by Sasa Kara
Modified: 2007-03-24 08:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sasa Kara 2007-03-24 08:10:58 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Fedora RPMs
OS:                Linux

KMail crashes after opening the main window before the mail folder is loaded.
The problem persists after removing all .index[.ids[.sorted]] files, but only some of them are recreated (the crash occurs before all of them are created). I also tried to remove some of the more recent mail, but it didn't help either.

Backtrace is:

[KCrash handler]
#6  0x4eab31a0 in KMFolderMaildir::readFileHeaderIntern ()
   from /usr/lib/libkmailprivate.so
#7  0x4eab3cd6 in KMFolderMaildir::createIndexFromContents ()
   from /usr/lib/libkmailprivate.so
#8  0x4eaafa8c in KMFolderMaildir::open () from /usr/lib/libkmailprivate.so
#9  0x4e9e6fc7 in KMFolder::open () from /usr/lib/libkmailprivate.so
#10 0x4e9babb2 in KMHeaders::setFolder () from /usr/lib/libkmailprivate.so
#11 0x4eb5aa95 in KMMainWidget::folderSelected ()
   from /usr/lib/libkmailprivate.so
#12 0x4eb605a7 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#13 0x4c3b1b51 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x4e99226e in KMFolderTree::folderSelected ()
   from /usr/lib/libkmailprivate.so
#15 0x4e993a42 in KMFolderTree::doFolderSelected ()
   from /usr/lib/libkmailprivate.so
#16 0x4e993ae5 in KMFolderTree::showFolder () from /usr/lib/libkmailprivate.so
#17 0x4eb4cf84 in KMMainWidget::slotShowStartupFolder ()
   from /usr/lib/libkmailprivate.so
#18 0x4eb60fa3 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#19 0x4c3b1bea in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x4c73dace in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x4c3d03b7 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x4c3d8ff3 in QSingleShotTimer::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x4c348e6b in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x4c34a2e9 in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x4caee56e in KApplication::notify () from /usr/lib/libkdecore.so.4
#26 0x4c33cc72 in QEventLoop::activateTimers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x4c2f11df in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x4c3623f0 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x4c3622a6 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#30 0x4c34897f in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x0804a04e in ?? ()
#32 0x48648f2c in __libc_start_main () from /lib/libc.so.6
#33 0x08049db1 in ?? ()
Comment 1 Tommi Tervo 2007-03-24 08:20:33 UTC

*** This bug has been marked as a duplicate of 140543 ***