Bug 149682 - kmail crash at when starts
Summary: kmail crash at when starts
Status: RESOLVED DUPLICATE of bug 140543
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-09 00:43 UTC by Uwe Eikmeier
Modified: 2007-10-07 15:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Eikmeier 2007-09-09 00:43:46 UTC
Version:           1.9.6 (using KDE KDE 3.5.6)
Installed from:    Fedora RPMs
Compiler:          gcc-Version 4.1.1 20070105 
OS:                Linux

kmail crashes right at the beginning.

I am using Fedora Core 6 with kdepim.i386                             
6:3.5.6-0.2.fc6 = kmail 1.9.6

Starting kmail in a terminal I receive:

./kmail
QGArray::at: Absolute index 0 out of range
[uwe@uwe bin]$ KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kmail path = <unknown> pid = 21062


,----[ /home/uwe/kmail_error_2.txt ]
| (no debugging symbols found)
| Using host libthread_db library "/lib/libthread_db.so.1".
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| [Thread debugging using libthread_db enabled]
| [New Thread -1208617264 (LWP 21062)]
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| (no debugging symbols found)
| [KCrash handler]
| #6  0x42a7b1a0 in KMFolderMaildir::readFileHeaderIntern ()
|    from /usr/lib/libkmailprivate.so
| #7  0x42a7bcd6 in KMFolderMaildir::createIndexFromContents ()
|    from /usr/lib/libkmailprivate.so
| #8  0x42a77a8c in KMFolderMaildir::open () from
| #/usr/lib/libkmailprivate.so
| #9  0x42b2b4e2 in KMFolderIndex::fillMessageDict ()
|    from /usr/lib/libkmailprivate.so
| #10 0x429d006e in FolderStorage::invalidateFolder ()
|    from /usr/lib/libkmailprivate.so
| #11 0x429d0115 in FolderStorage::readFolderIdsFile ()
|    from /usr/lib/libkmailprivate.so
| #12 0x429d0141 in FolderStorage::registerWithMessageDict ()
|    from /usr/lib/libkmailprivate.so
| #13 0x429b192b in KMFolder::KMFolder () from /usr/lib/libkmailprivate.so
| #14 0x429ee391 in KMFolderDir::reload () from /usr/lib/libkmailprivate.so
| #15 0x429eff15 in KMFolderMgr::setBasePath () from
| #/usr/lib/libkmailprivate.so 16 0x429f01ff in KMFolderMgr::KMFolderMgr ()
| #from /usr/lib/libkmailprivate.so 17 0x42a9046a in KMKernel::init () from
| #/usr/lib/libkmailprivate.so 18 0x08049fe1 in QObject::checkConnectArgs ()
| #19 0x4f74ef2c in __libc_start_main () from /lib/libc.so.6
| #20 0x08049db1 in QObject::checkConnectArgs ()
`----

I already deleted the *.index and *.ids files but that had no significant
effect. kmail reconstructs the .ids and .index files in the first level of the mail
directory and then crashes.
When I delete the kmailrc file in /home/uwe/.kde/share/config, kmail comes up and I can configure it but I can't access my mails. 
There is enouph harddiskdrive space left
Comment 1 Bram Schoenmakers 2007-09-09 11:49:28 UTC

*** This bug has been marked as a duplicate of 140543 ***
Comment 2 Js Lebacq 2007-10-07 15:19:12 UTC
I use unison to synchronize my mail folders between my computers, and sometimes I have that problem. After a lot of investigations, I realize that it's a filesystem problem for me : for example, in the inbox/cur/ directory I see 7820 files, but the directory say it contain 7822 files, ie. I have ghost files. If I solve that problem of ghost files, kmail can startup again.