Bug 134708 - crash while reading news
Summary: crash while reading news
Status: RESOLVED DUPLICATE of bug 133332
Alias: None
Product: knode
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 146891 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-26 21:39 UTC by Peter Huyoff
Modified: 2009-01-20 21:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Huyoff 2006-09-26 21:39:08 UTC
Version:            (using KDE KDE 3.5.4)
Installed from:    SuSE RPMs
OS:                Linux

Sometimes knode crashes while reading news. I can't reproduce a reason for the crash, it occures from time to time and on different machines (all under SUSE Linux, Versions are 9.3, 10.0 and 10,1). Now i've stored a crash-log, maybe it's  helpful to find the reason why:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1242474832 (LWP 4184)]
[New Thread -1250616416 (LWP 4228)]
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb6f7818e in __lll_mutex_lock_wait () from /lib/libc.so.6
#2  0xb6f16d81 in _L_mutex_lock_4119 () from /lib/libc.so.6
#3  0x08065d40 in ?? ()
#4  0xbfd83a98 in ?? ()
#5  0xb70a7ff4 in ?? () from /usr/lib/libstdc++.so.6
#6  0x08255fe8 in ?? ()
#7  0x08065d40 in ?? ()
#8  0xbfd83aa8 in ?? ()
#9  0xb7080e51 in operator delete () from /usr/lib/libstdc++.so.6
#10 0xb7080e51 in operator delete () from /usr/lib/libstdc++.so.6
#11 0xb7080ead in operator delete[] () from /usr/lib/libstdc++.so.6
#12 0xb7618fcd in QStringData::deleteSelf ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb739be6b in __tcf_2 () from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb6eda26d in exit () from /lib/libc.so.6
#15 0xb727bbd2 in qt_xio_errhandler () from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb78c0cfd in KApplication::xioErrhandler ()
   from /opt/kde3/lib/libkdecore.so.4
#17 0xb78c0d49 in kde_xio_errhandler () from /opt/kde3/lib/libkdecore.so.4
#18 0xb62f966d in _XIOError () from /usr/lib/libX11.so.6
#19 0xb62faed7 in _XFlushInt () from /usr/lib/libX11.so.6
#20 0xb62d7961 in XFlush () from /usr/lib/libX11.so.6
#21 0xb727dbf3 in QApplication::restoreOverrideCursor ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb7f9580b in KNMainWidget::setCursorBusy ()
   from /opt/kde3/lib/libknodecommon.so
#23 0xb7f307e3 in KNGroup::reorganize () from /opt/kde3/lib/libknodecommon.so
#24 0xb7f30a1f in KNGroup::updateThreadInfo ()
   from /opt/kde3/lib/libknodecommon.so
#25 0xb7f4ede9 in KNArticleManager::setAllNotNew ()
   from /opt/kde3/lib/libknodecommon.so
#26 0xb7f99e18 in KNMainWidget::slotCollectionSelected ()
   from /opt/kde3/lib/libknodecommon.so
#27 0xb7f9b53a in KNMainWidget::qt_invoke ()
   from /opt/kde3/lib/libknodecommon.so
#28 0xb7349f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb7696801 in QListView::selectionChanged ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb7fa691f in KNCollectionView::setActive ()
   from /opt/kde3/lib/libknodecommon.so
#31 0xb7fa69f6 in KNCollectionView::nextGroup ()
   from /opt/kde3/lib/libknodecommon.so
#32 0xb7f9538a in KNMainWidget::slotNavNextUnreadThread ()
   from /opt/kde3/lib/libknodecommon.so
#33 0xb7f98289 in KNMainWidget::slotArtSetThreadRead ()
   from /opt/kde3/lib/libknodecommon.so
#34 0xb7f9ba43 in KNMainWidget::qt_invoke ()
   from /opt/kde3/lib/libknodecommon.so
#35 0xb7349f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb734ab7d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb7b62c29 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#38 0xb7ba5112 in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#39 0xb7c69cbf in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#40 0xb7349f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0xb734ab7d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0xb78c1579 in KAccelPrivate::menuItemActivated ()
   from /opt/kde3/lib/libkdecore.so.4
#43 0xb7911877 in KAccelPrivate::emitActivatedSignal ()
   from /opt/kde3/lib/libkdecore.so.4
#44 0xb796d2b9 in KAccelPrivate::eventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#45 0xb734981c in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0xb734988b in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0xb73828cc in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0xb743d9c2 in QMainWindow::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0xb72eaf07 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0xb72ec262 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0xb798ede3 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#52 0xb791d962 in KAccelEventHandler::x11Event ()
   from /opt/kde3/lib/libkdecore.so.4
#53 0xb798d1eb in KApplication::x11EventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#54 0xb7279df4 in qt_x11EventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#55 0xb7289773 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#56 0xb729a62a in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#57 0xb7301d28 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#58 0xb7301bbe in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#59 0xb72eaabf in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#60 0x0804fbca in main ()
Comment 1 Lubos Lunak 2008-07-21 16:22:42 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 2 Olivier Trichet 2009-01-20 21:48:25 UTC
*** Bug 146891 has been marked as a duplicate of this bug. ***
Comment 3 Olivier Trichet 2009-01-20 21:52:13 UTC

*** This bug has been marked as a duplicate of bug 133332 ***