Bug 133332 - Crash after clicking in KNode folder list in fast succession
Summary: Crash after clicking in KNode folder list in fast succession
Status: RESOLVED WORKSFORME
Alias: None
Product: knode
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Daniel Molkentin
URL:
Keywords:
: 134708 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-08-31 13:41 UTC by Stefan Borggraefe
Modified: 2009-01-20 21:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Borggraefe 2006-08-31 13:41:51 UTC
Version:           1.2.3 (using KDE KDE 3.5.4)
Installed from:    Debian testing/unstable Packages
OS:                Linux

I'm using KNode embedded in Kontact. After some fast clicks in the folder list Kontact crashed with the following backtrace. I couldn't reproduce the crash for a second time.

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1477584576 (LWP 5312)]
[New Thread -1519580240 (LWP 5396)]
[New Thread -1509258320 (LWP 5395)]
[New Thread -1500865616 (LWP 5394)]
[New Thread -1492472912 (LWP 5393)]
[New Thread -1484080208 (LWP 5392)]
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0x45ef45ab in read () from /lib/tls/i686/cmov/libc.so.6
#2  0x4a21243e in _kde_IceTransGetConnectionNumber ()
   from /usr/lib/libDCOP.so.4
#3  0x4a2120ff in _kde_IceTransRead () from /usr/lib/libDCOP.so.4
#4  0x4a20bfdf in _kde_IceRead () from /usr/lib/libDCOP.so.4
#5  0x4a2106ef in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
#6  0x4a1fc376 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#7  0x4a1fc6a7 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#8  0x4a2010f5 in DCOPClient::call () from /usr/lib/libDCOP.so.4
#9  0x4a201158 in DCOPClient::call () from /usr/lib/libDCOP.so.4
#10 0x4a201365 in DCOPClient::disconnectDCOPSignal ()
   from /usr/lib/libDCOP.so.4
#11 0x4a201ca1 in DCOPObject::~DCOPObject () from /usr/lib/libDCOP.so.4
#12 0xa355f6e3 in ~SpeechClient (this=0x96cdda0)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/akregator/src/speechclient.cpp:73
#13 0xa355fd42 in __tcf_30 () at /usr/include/kde/kstaticdeleter.h:126
#14 0x45e633b0 in exit () from /lib/tls/i686/cmov/libc.so.6
#15 0x4b608e66 in QApplication::x11_initialize_style ()
   from /usr/lib/libqt-mt.so.3
#16 0x4a5f0e8d in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#17 0x4a5f0ed9 in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#18 0x4a08d90d in _XIOError () from /usr/lib/libX11.so.6
#19 0x4a08f1e6 in _XSend () from /usr/lib/libX11.so.6
#20 0x4a06bb01 in XFlush () from /usr/lib/libX11.so.6
#21 0x4b607d8f in QApplication::restoreOverrideCursor ()
   from /usr/lib/libqt-mt.so.3
#22 0xa575acb9 in KNMainWidget::setCursorBusy (this=0x86b8298, b=false)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/knode/knmainwidget.cpp:371
#23 0xa57fdb43 in KNGroup::reorganize (this=0x8726db0)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/knode/kngroup.cpp:969
#24 0xa57fdd8c in KNGroup::updateThreadInfo (this=0x8726db0)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/knode/kngroup.cpp:1009
#25 0xa57fdf16 in KNArticleManager::setAllNotNew (this=0x8731b80)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/knode/knarticlemanager.cpp:749
#26 0xa58118f6 in KNMainWidget::slotCollectionSelected (this=0x86b8298, 
    i=0x8709ef0)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/knode/knmainwidget.cpp:1071
#27 0xa581416a in KNMainWidget::qt_invoke (this=0x86b8298, _id=49, 
    _o=0xaf9c6bc8) at ./knmainwidget.moc:289
#28 0x4b6e9127 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#29 0x4ba8a156 in QListView::selectionChanged () from /usr/lib/libqt-mt.so.3
#30 0x4b7e1e11 in QListView::setCurrentItem () from /usr/lib/libqt-mt.so.3
#31 0x4b7e5c9a in QListView::contentsMousePressEventEx ()
   from /usr/lib/libqt-mt.so.3
#32 0x4b7e63a0 in QListView::contentsMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#33 0x4a8b5c1a in KListView::contentsMousePressEvent ()
   from /usr/lib/libkdeui.so.4
#34 0x4b29ca67 in KFolderTree::contentsMousePressEvent (this=0x8723c50, 
    e=0xaf9c6eec)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/libkdepim/kfoldertree.cpp:351
#35 0x4b81d321 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#36 0x4b81e78c in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#37 0x4b7e680e in QListView::eventFilter () from /usr/lib/libqt-mt.so.3
#38 0xa576ab7f in KNCollectionView::eventFilter (this=0x8723c50, o=0x87167e8, 
    e=0xaf9c7484)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/knode/kncollectionview.cpp:439
#39 0x4b6e86da in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#40 0x4b6e8758 in QObject::event () from /usr/lib/libqt-mt.so.3
#41 0x4b71f9ea in QWidget::event () from /usr/lib/libqt-mt.so.3
#42 0x4b68108a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#43 0x4b68322d in QApplication::notify () from /usr/lib/libqt-mt.so.3
#44 0x4a6c160e in KApplication::notify () from /usr/lib/libkdecore.so.4
#45 0x4b6149e5 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#46 0x4b61367f in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#47 0x4b611c00 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#48 0x4b628252 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#49 0x4b69b5dd in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#50 0x4b69b3fe in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#51 0x4b682c23 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#52 0x0805ac3f in main (argc=33554690, argv=0xaf9c7c54)
    at /home/sid-user/kdepim/kdepim-3.5.4/build-tree/kdepim-3.5.4/kontact/src/main.cpp:161
#53 0x45e4cea8 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#54 0x080582b1 in _start () at ../sysdeps/i386/elf/start.S:119
Comment 1 Will Stephenson 2006-10-28 19:35:21 UTC
KNode problem?
Comment 2 Lubos Lunak 2008-07-21 16:22:43 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 3 Olivier Trichet 2009-01-20 21:52:13 UTC
*** Bug 134708 has been marked as a duplicate of this bug. ***
Comment 4 Olivier Trichet 2009-01-20 21:52:58 UTC
Seems to have been fixed