Bug 146891 - crash when updating Messages
Summary: crash when updating Messages
Status: RESOLVED DUPLICATE of bug 134708
Alias: None
Product: knode
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-17 11:28 UTC by EM
Modified: 2009-01-20 21:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description EM 2007-06-17 11:28:34 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages

When I've activated update of all groups on all servers, I got a crash.
Below the report:
===
(no debugging symbols found)
Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1244346672 (LWP 6990)]
[New Thread -1250702448 (LWP 6991)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xb7f2c410 in ?? ()
#0  0xb7f2c410 in ?? ()
#1  0xbfe29c4c in ?? ()
#2  0x00000008 in ?? ()
#3  0x08061c10 in ?? ()
#4  0xb7c0f35b in read () from /lib/i686/cmov/libc.so.6
#5  0xb74da43e in _kde_IceTransGetConnectionNumber ()
   from /usr/lib/libDCOP.so.4
#6  0xb74da0ff in _kde_IceTransRead () from /usr/lib/libDCOP.so.4
#7  0xb74d3fdf in _kde_IceRead () from /usr/lib/libDCOP.so.4
#8  0xb74d86ef in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
#9  0xb74c4376 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#10 0xb74c46a7 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#11 0xb74c90f5 in DCOPClient::call () from /usr/lib/libDCOP.so.4
#12 0xb74c9158 in DCOPClient::call () from /usr/lib/libDCOP.so.4
#13 0xb74c9365 in DCOPClient::disconnectDCOPSignal ()
   from /usr/lib/libDCOP.so.4
#14 0xb74c9ca1 in DCOPObject::~DCOPObject () from /usr/lib/libDCOP.so.4
#15 0xb5e5a7c3 in KRES::ManagerImpl::~ManagerImpl ()
   from /usr/lib/libkresources.so.1
#16 0xb6b5b287 in KRES::Manager<KABC::Resource>::~Manager ()
   from /usr/lib/libkabc.so.1
#17 0xb6b06104 in KABC::AddressBook::~AddressBook ()
   from /usr/lib/libkabc.so.1
#18 0xb6b2fe38 in KABC::StdAddressBook::~StdAddressBook ()
   from /usr/lib/libkabc.so.1
#19 0xb6b04462 in KABC::AddressBook::ConstIterator::ConstIterator ()
   from /usr/lib/libkabc.so.1
#20 0xb7b7ac39 in __cxa_finalize () from /lib/i686/cmov/libc.so.6
#21 0xb6af8563 in ?? () from /usr/lib/libkabc.so.1
#22 0xb6b72c04 in ?? () from /usr/lib/libkabc.so.1
#23 0xb6b714f4 in ?? () from /usr/lib/libkabc.so.1
#24 0xbfe2a1c8 in ?? ()
#25 0xb6b6a6ec in _fini () from /usr/lib/libkabc.so.1
#26 0xb6b6a6ec in _fini () from /usr/lib/libkabc.so.1
#27 0xb7f3bc9e in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#28 0xb7b7a949 in exit () from /lib/i686/cmov/libc.so.6
#29 0xb6ef89b6 in QApplication::x11_initialize_style ()
   from /usr/lib/libqt-mt.so.3
#30 0xb788517d in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#31 0xb78851c9 in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#32 0xb5f9f33d in _XIOError () from /usr/lib/libX11.so.6
#33 0xb5fa0bf6 in _XSend () from /usr/lib/libX11.so.6
#34 0xb5f7d501 in XFlush () from /usr/lib/libX11.so.6
#35 0xb6ef78df in QApplication::restoreOverrideCursor ()
   from /usr/lib/libqt-mt.so.3
#36 0xb7e2bda9 in KNMainWidget::setCursorBusy ()
   from /usr/lib/libknodecommon.so
#37 0xb7ea5d33 in KNGroup::reorganize () from /usr/lib/libknodecommon.so
#38 0xb7ea5f7c in KNGroup::updateThreadInfo () from /usr/lib/libknodecommon.so
#39 0xb7ea6106 in KNArticleManager::setAllNotNew ()
   from /usr/lib/libknodecommon.so
#40 0xb7ee3486 in KNMainWidget::slotCollectionSelected ()
   from /usr/lib/libknodecommon.so
#41 0xb7ee618a in KNMainWidget::qt_invoke () from /usr/lib/libknodecommon.so
#42 0xb6fd8e1b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#43 0xb7379f26 in QListView::selectionChanged () from /usr/lib/libqt-mt.so.3
#44 0xb70d1b0d in QListView::setCurrentItem () from /usr/lib/libqt-mt.so.3
#45 0xb70d5996 in QListView::contentsMousePressEventEx ()
   from /usr/lib/libqt-mt.so.3
#46 0xb70d609c in QListView::contentsMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#47 0xb761af1f in KListView::contentsMousePressEvent ()
   from /usr/lib/libkdeui.so.4
#48 0xb7a77df7 in KFolderTree::contentsMousePressEvent ()
   from /usr/lib/libkdepim.so.1
#49 0xb710d005 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#50 0xb710e470 in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#51 0xb70d650a in QListView::eventFilter () from /usr/lib/libqt-mt.so.3
#52 0xb7e39bef in KNCollectionView::eventFilter ()
   from /usr/lib/libknodecommon.so
#53 0xb6fd83ce in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#54 0xb6fd844c in QObject::event () from /usr/lib/libqt-mt.so.3
#55 0xb700f6de in QWidget::event () from /usr/lib/libqt-mt.so.3
#56 0xb6f70cf2 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#57 0xb6f72e95 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#58 0xb796fe0e in KApplication::notify () from /usr/lib/libkdecore.so.4
#59 0xb6f04535 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#60 0xb6f031cf in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#61 0xb6f01750 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#62 0xb6f17da2 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#63 0xb6f8b245 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#64 0xb6f8b066 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#65 0xb6f7288b in QApplication::exec () from /usr/lib/libqt-mt.so.3
#66 0x0804ed18 in ?? ()
#67 0xbfe2b4dc in ?? ()
#68 0xbfe2b5f4 in ?? ()
#69 0x00000001 in ?? ()
#70 0x00000000 in ?? ()
===
Comment 1 Lubos Lunak 2008-07-21 16:23:00 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 2 Olivier Trichet 2009-01-20 21:48:25 UTC

*** This bug has been marked as a duplicate of bug 134708 ***