Bug 132659 - "Missing signature" - Flickr API changed and upload of images is no longer possible
Summary: "Missing signature" - Flickr API changed and upload of images is no longer po...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-WebService-Flickr (show other bugs)
Version: 5.6.0
Platform: Gentoo Packages Linux
: NOR normal with 106 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-19 22:26 UTC by Goran Zec
Modified: 2018-12-24 03:34 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.1.0


Attachments
Typos stopping flickr export API (715 bytes, patch)
2006-09-14 22:19 UTC, Debajyoti Bera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Zec 2006-08-19 22:26:48 UTC
Version:           0.1.0_rc2 (using KDE KDE 3.5.3)
Installed from:    Gentoo Packages
OS:                Linux

As you can see <a href="http://www.flickr.com/forums/bugs/26298/">here</a>, Flickr API changed and upload of images is no longer possible with any version of kipi plugins. It consistently gives the error "missing signature".
Comment 1 caulier.gilles 2006-08-24 16:20:15 UTC
*** Bug 132922 has been marked as a duplicate of this bug. ***
Comment 2 Zack Weinberg 2006-08-25 06:26:25 UTC
I see this too with kipi-plugins 0.1.2 (Debian unstable KDE packages).
Comment 3 Sebastian Turzański 2006-08-25 10:37:18 UTC
still marked as UNCONFIRMED ?
Comment 4 caulier.gilles 2006-08-25 10:53:59 UTC
yes i confirm the bug...

Gilles Caulier
Comment 5 glaurent 2006-08-25 22:30:37 UTC
Seen it too. That prompted me to eventually install kflickr and its companion send2kflickr, which is a kipi plugin allowing any kipi-enabled app to communicate with kflickr. kflickr being way better than the current flickr export, I'd integrate it along with send2kflickr as a replacement.
Comment 6 Zack Weinberg 2006-08-25 22:40:32 UTC
Does send2kflickr read tags and descriptions from digikam?  I spent a very annoying hour last night copying them from digikam into kflickr.
Comment 7 caulier.gilles 2006-08-25 22:51:28 UTC
No, because this feature need to be tested in kipiinterface of digiKam.

but the code exist, and require some indeep tests.

Gilles
Comment 8 Debajyoti Bera 2006-09-14 22:19:10 UTC
Created attachment 17772 [details]
Typos stopping flickr export API

There were some simple typos which was causing the bug. This patch fixes them.
I was also able to upload photos to my flickr account using digikam after
applying the patch.
Comment 9 caulier.gilles 2006-09-14 22:39:45 UTC
Thanks for the patch!

Jain, Angelo are you in this room to apply this patch against svn trunk ?

Gilles
Comment 10 Murillo Bernardes 2006-09-14 22:52:17 UTC
Thanks for the patch, it works perfectly!
Comment 11 caulier.gilles 2006-09-15 09:05:03 UTC
SVN commit 584531 by cgilles:

kipi plugins from trunk : flickr Export : patch from Debajyoti Bera about new flickr API compliant
BUG:132659


 M  +2 -1      flickrtalker.cpp  


--- trunk/extragear/libs/kipi-plugins/flickrexport/flickrtalker.cpp #584530:584531
@@ -297,7 +297,7 @@
 
 		QString isfriend=(info.is_friend==1)?"1":"0";
 		form.addPair("is_friend",isfriend);
-		headers.append("api_key="+ isfriend);
+		headers.append("is_friend="+ isfriend);
 
 		QString tags=info.tags.join(" ");
 		if(tags.length()>0){	
@@ -317,6 +317,7 @@
 		}
 
 		QString md5=getApiSig(m_secret,headers);
+		form.addPair("api_sig", md5);
 		headers.append("api_sig="+ md5);
 		QString queryStr=headers.join("&");
 		QString postUrl=url+queryStr;
Comment 12 Vardhman 2006-09-15 09:34:56 UTC
Thanks for the patch Bera, and thanks for applying it Gilles, I have
actually moved to a new place and new machine, I was just trying to accquire
SSH access to the SVN with my new public key. Hopefully I will be more
regular now!

On 15 Sep 2006 07:05:05 -0000, Gilles Caulier <caulier.gilles@free.fr>
wrote:
[bugs.kde.org quoted mail]



Thanks for the patch Bera, and thanks for applying it Gilles, I have actually moved to a new place and new machine, I was just trying to accquire SSH access to the SVN with my new public key. Hopefully I will be more regular now!
<br><br><div><span class="gmail_quote">On 15 Sep 2006 07:05:05 -0000, <b class="gmail_sendername">Gilles Caulier</b> &lt;<a href="mailto:caulier.gilles@free.fr">caulier.gilles@free.fr</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
------- You are receiving this mail because: -------<br>You are the assignee for the bug, or are watching the assignee.<br><br><a href="http://bugs.kde.org/show_bug.cgi?id=132659">http://bugs.kde.org/show_bug.cgi?id=132659
</a><br>caulier.gilles free fr changed:<br><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; What&nbsp;&nbsp;&nbsp;&nbsp;|Removed&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; |Added<br>----------------------------------------------------------------------------<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Status|NEW&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; |RESOLVED
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Resolution|&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;|FIXED<br><br><br><br>------- Additional Comments From caulier.gilles free fr&nbsp;&nbsp;2006-09-15 09:05 -------<br>SVN commit 584531 by cgilles:<br><br>kipi plugins from trunk : flickr Export : patch from Debajyoti Bera about new flickr API compliant
<br>BUG:132659<br><br><br> M&nbsp;&nbsp;+2 -1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;flickrtalker.cpp<br><br><br>--- trunk/extragear/libs/kipi-plugins/flickrexport/flickrtalker.cpp #584530:584531<br> @ -297,7 +297,7&nbsp;&nbsp;@<br><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;QString isfriend=(info.is_friend==1
)?&quot;1&quot;:&quot;0&quot;;<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;form.addPair(&quot;is_friend&quot;,isfriend);<br>-&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; headers.append(&quot;api_key=&quot;+ isfriend);<br>+&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; headers.append(&quot;is_friend=&quot;+ isfriend);
<br><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;QString tags=info.tags.join(&quot; &quot;);<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;if(tags.length()&gt;0){<br> @ -317,6 +317,7&nbsp;&nbsp;@<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;}<br><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;QString md5=getApiSig(m_secret,headers);<br>
+&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; form.addPair(&quot;api_sig&quot;, md5);<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;headers.append(&quot;api_sig=&quot;+ md5);<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;QString queryStr=headers.join(&quot;&amp;&quot;);<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;QString postUrl=url+queryStr;
<br>_______________________________________________<br>Kde-imaging mailing list<br><a href="mailto:Kde-imaging@kde.org">Kde-imaging@kde.org</a><br><a href="https://mail.kde.org/mailman/listinfo/kde-imaging">https://mail.kde.org/mailman/listinfo/kde-imaging
</a><br></blockquote></div><br><br clear="all"><br>-- <br>Blogs: <a href="http://vardhman.blogspot.com">http://vardhman.blogspot.com</a><br>
Comment 13 caulier.gilles 2006-09-15 09:50:13 UTC
tested with my flickr account. Work fine !

Gilles
Comment 14 Eduardo H.R. 2006-09-30 10:03:59 UTC
Thanks for the patch it worked just great!
Comment 15 Lars Biermann 2006-10-23 18:13:44 UTC
Hello,
I have the same bug on my PC (KDE 3.5.1 Level "a", SUSE 10.1, digikam  0.8.2, KIPI version 0.1.4). Exist a patch for my system too?

Lars
Comment 16 Helder Ribeiro 2007-04-19 03:59:55 UTC
I still have this problem, although it seems like it's been solved long ago. When is the fix going to be in a release version? I use kubuntu feisty fawn and apparently the fix hasn't gotten to it yet. Thanks everyone!
Comment 17 Gustavo Narea 2007-07-06 15:05:00 UTC
The problem is still there and this Flickr Exporter is unusable: Everytime I try to upload a photo, I get this error:

Error Occured: Invalid signature
We can not proceed further

I'm using Kubuntu 7.04 (Feisty), KDE 3.5.7, digiKam 0.9.1 and Kipi Library 0.1.5.

Send2Flickr is not an alternative for me, as it doesn't support photo tags.
Comment 18 Soren Harward 2007-09-05 00:06:14 UTC
Also getting the "Error Occured: Invalid signature" error on Gentoo, using kipi-plugins-0.1.4 and libkipi-0.1.5.
Comment 19 Risto H. Kurppa 2007-09-09 10:43:12 UTC
Kubuntu Feisty Fawn and the bug is still there..
Comment 20 Risto H. Kurppa 2007-09-09 10:50:59 UTC
Looks like the reason has been solved here: http://ubuntuforums.org/showthread.php?t=482916
It's about the EXIF comments, I also have a D70 and have my email address with @-char there..
Comment 21 Thomas Sperre 2008-02-24 19:40:44 UTC
There are more than one reason for the  "Error Occured: Invalid signature" error message, and I think this is very confusing as different but maybe related bugs are reported as same.

Anyway, using digikam 0.9.2-final (KDE 3.5.8) on kubuntu 7.10 Gutsy (64  bit), Kipi Library version 0.1.5: I get the error message when file name (not just comment) contains strange (non-ascii) characters as well. 

The bug appears to still be there, and it is quite a nuisance.

Possible duplicate bug report (at least error message is the same): 
Bug 149864: dialog box pops up saying 'Error Occured: Missing signature. We can not proceed further"

I don't think this should be marked as resolved and I think step #1 may be to clear up the error message reporting itself. If a lot of different causes leads to the same error message, the whole community is misled. There is nothing wrong with the signature, I guess..... ?


Comment 22 caulier.gilles 2008-05-22 15:24:28 UTC
*** Bug 149864 has been marked as a duplicate of this bug. ***