Bug 127107 - kmail crashs after click on imap message (with debuginfo)
Summary: kmail crashs after click on imap message (with debuginfo)
Status: RESOLVED NOT A BUG
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.1
Platform: unspecified Linux
: NOR crash with 25 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 133812 135804 136614 138623 138897 142373 144570 145008 145765 149713 150140 162740 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-05-10 22:30 UTC by sts
Modified: 2010-03-17 22:38 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Debuginfo (5.11 KB, text/plain)
2006-05-10 22:31 UTC, sts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sts 2006-05-10 22:30:49 UTC
Version:           1.9.1 (using KDE 3.5.1 Level "a" , SUSE 10.1)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.16.12-3-default

I can't reproduce it but in attachment you can see the debuginfo of this crash.
Comment 1 sts 2006-05-10 22:31:31 UTC
Created attachment 16013 [details]
Debuginfo
Comment 2 Michael Seiwert 2006-11-01 08:01:18 UTC
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1240271184 (LWP 8835)]
[New Thread -1280926816 (LWP 8839)]
[New Thread -1272534112 (LWP 8838)]
[New Thread -1264141408 (LWP 8837)]
[New Thread -1255748704 (LWP 8836)]
[KCrash handler]
#6  0xb6fbd61e in QGDict::look_string () from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0xb5722fc7 in KMHeaders::msgRemoved (this=0x85efaf0, id=325, 
    msgId=@0xbfe86394) at /usr/lib/qt3/include/qdict.h:73
#8  0xb5835379 in KMHeaders::qt_invoke (this=0x85efaf0, _id=113, _o=0xbfe86410)
    at ./kmail/kmheaders.moc:301
#9  0xb6d0ab0d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0xb5632240 in KMFolder::msgRemoved (this=0x84a5dd8, t0=325, t1=@0xbfe86488)
    at ./kmail/kmfolder.moc:254
#11 0xb571a99d in KMFolder::qt_emit (this=0x84a5dd8, _id=9, _o=0xbfe86500)
    at ./kmail/kmfolder.moc:381
#12 0xb6d0ab51 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb5631370 in FolderStorage::msgRemoved (this=0x84a6008, t0=325, 
    t1=@0xbfe86578) at ./kmail/folderstorage.moc:320
#14 0xb578cbdc in FolderStorage::take (this=0x84a6008, idx=325)
    at ./kmail/folderstorage.cpp:441
#15 0xb586ef80 in KMFolderImap::take (this=0x84a6008, idx=325)
    at ./kmail/kmfolderimap.cpp:564
#16 0xb55e9b1e in KMFolder::take (this=0x84a5dd8, idx=325)
    at ./kmail/kmfolder.cpp:372
#17 0xb5857925 in KMFolderMaildir::addMsgInternal (this=0x8518618, 
    aMsg=0x87e2598, index_return=0xbfe86758, stripUid=false)
    at ./kmail/kmfoldermaildir.cpp:453
#18 0xb5858247 in KMFolderMaildir::addMsg (this=0x8518618, aMsg=0x87e2598, 
    index_return=0xbfe86758) at ./kmail/kmfoldermaildir.cpp:365
#19 0xb5639908 in FolderStorage::reallyAddMsg (this=0x8518618, aMsg=0x87e2598)
    at ./kmail/folderstorage.cpp:320
#20 0xb578c7cc in FolderStorage::qt_invoke (this=0x8518618, _id=3, 
    _o=0xbfe86834) at ./kmail/folderstorage.moc:454
#21 0xb578c853 in KMFolderIndex::qt_invoke (this=0x8518618, _id=3, 
    _o=0xbfe86834) at ./kmail/kmfolderindex.moc:87
#22 0xb578c88b in KMFolderMaildir::qt_invoke (this=0x8518618, _id=3, 
    _o=0xbfe86834) at ./kmail/kmfoldermaildir.moc:77
#23 0xb6d0ab0d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb562a6ce in KMail::FolderJob::messageRetrieved (this=0x88c6c40, 
    t0=0x87e2598) at ./kmail/folderjob.moc:129
#25 0xb57b8ea2 in KMail::ImapJob::slotGetMessageResult (this=0x88c6c40, 
    job=0x88caa90) at ./kmail/imapjob.cpp:439
#26 0xb589e0b5 in KMail::ImapJob::qt_invoke (this=0x88c6c40, _id=2, 
    _o=0xbfe86974) at ./kmail/imapjob.moc:126
#27 0xb6d0ab0d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb77ef0ee in KIO::Job::result (this=0x88caa90, t0=0x88caa90)
    at ./kio/kio/jobclasses.moc:162
#29 0xb782dc4d in KIO::Job::emitResult (this=0x88caa90)
    at ./kio/kio/job.cpp:222
#30 0xb784129e in KIO::SimpleJob::slotFinished (this=0x88caa90)
    at ./kio/kio/job.cpp:570
#31 0xb784199d in KIO::TransferJob::slotFinished (this=0x88caa90)
    at ./kio/kio/job.cpp:940
#32 0xb782d87a in KIO::TransferJob::qt_invoke (this=0x88caa90, _id=17, 
    _o=0xbfe86cb8) at ./kio/kio/jobclasses.moc:1071
#33 0xb6d0ab0d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb6d0b76d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb77e83ac in KIO::SlaveInterface::finished (this=0x86aea68)
    at ./kio/kio/slaveinterface.moc:226
#36 0xb78560a5 in KIO::SlaveInterface::dispatch (this=0x86aea68, _cmd=104, 
    rawdata=@0x86aea68) at ./kio/kio/slaveinterface.cpp:243
#37 0xb7853fda in KIO::SlaveInterface::dispatch (this=0x86aea68)
    at ./kio/kio/slaveinterface.cpp:173
#38 0xb77fc8bc in KIO::Slave::gotInput (this=0x86aea68)
    at ./kio/kio/slave.cpp:300
#39 0xb7845250 in KIO::Slave::qt_invoke (this=0x86aea68, _id=4, _o=0xbfe86fe4)
    at ./kio/kio/slave.moc:113
#40 0xb6d0ab0d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0xb6d0b672 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0xb7042aa0 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb6d28d30 in QSocketNotifier::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0xb6cabbf7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0xb6cac9c1 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0xb73558e3 in KApplication::notify (this=0xbfe8748c, receiver=0x86adef0, 
    event=0xbfe87288) at ./kdecore/kapplication.cpp:552
#47 0xb6ca0834 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0xb6c5b5f4 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0xb6cc2a28 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0xb6cc28be in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0xb6cab7af in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#52 0x0805ae52 in main (argc=-1248382936, argv=0xbfe87694)
    at ./kontact/src/main.cpp:177
#53 0xb68ad87c in __libc_start_main () from /lib/libc.so.6
#54 0x08058591 in _start ()
Comment 3 Michael Seiwert 2006-11-01 08:03:11 UTC
Please put the bt into the comments field next time so duplicates could be found easier.
Comment 4 Tommi Tervo 2006-11-01 10:53:01 UTC
http://bugs.kde.org/show_bug.cgi?id=97747
similar bt, but it's closed.
Comment 5 Tommi Tervo 2006-11-01 10:55:08 UTC
*** Bug 133812 has been marked as a duplicate of this bug. ***
Comment 6 Tommi Tervo 2006-11-01 10:57:50 UTC
*** Bug 136614 has been marked as a duplicate of this bug. ***
Comment 7 Philip Rodrigues 2006-12-10 20:49:10 UTC
*** Bug 138623 has been marked as a duplicate of this bug. ***
Comment 8 Tommi Tervo 2007-01-31 12:43:32 UTC
*** Bug 135804 has been marked as a duplicate of this bug. ***
Comment 9 Thomas McGuire 2007-02-10 14:53:34 UTC
*** Bug 138897 has been marked as a duplicate of this bug. ***
Comment 10 Giuseppe Bilotta 2007-02-11 00:36:51 UTC
Since Bug 138897 has been marked as a dupe of this one, and since this bug mention a situation where the backtrace can be reproduced easily, I'll mention that it can be easily triggered by deleting messages in an IMAP account when the "Threaded message list" option is active.
Comment 11 Thomas McGuire 2007-03-01 19:16:19 UTC
*** Bug 142373 has been marked as a duplicate of this bug. ***
Comment 12 Thomas McGuire 2007-04-23 19:32:39 UTC
*** Bug 144570 has been marked as a duplicate of this bug. ***
Comment 13 Tommi Tervo 2007-05-04 14:34:59 UTC
*** Bug 145008 has been marked as a duplicate of this bug. ***
Comment 14 Thomas McGuire 2007-05-22 16:51:39 UTC
*** Bug 145765 has been marked as a duplicate of this bug. ***
Comment 15 Tommi Tervo 2007-09-10 08:04:39 UTC
*** Bug 149713 has been marked as a duplicate of this bug. ***
Comment 16 Tommi Tervo 2007-09-24 10:41:23 UTC
*** Bug 150140 has been marked as a duplicate of this bug. ***
Comment 17 Thomas McGuire 2008-05-05 09:51:53 UTC
See also bug 160983 and bug 159854.
Comment 18 Tommi Tervo 2008-05-28 11:57:49 UTC
*** Bug 162740 has been marked as a duplicate of this bug. ***
Comment 19 Dario Andres 2009-05-18 01:46:57 UTC
Shouldn't this be marked as fixed as the current KMail implementation (KDE4.2+) no longer uses the Qt3Support classes (and therefore QGDict is no used) ?
Regards
Comment 20 Daniel Hahler 2010-03-17 22:38:32 UTC
I've not experienced this myself for a long time and as the previous comment states: the implementation has changed.
Therefore I'm closing this as Resolved/Invalid.
Thanks.