Bug 142373 - Deleting IMAP email causes crash to desktop.
Summary: Deleting IMAP email causes crash to desktop.
Status: RESOLVED DUPLICATE of bug 127107
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-01 17:39 UTC by Jake Nelson
Modified: 2007-03-01 19:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jake Nelson 2007-03-01 17:39:21 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages
OS:                Linux

Steps that caused crash:
Selected IMAP email.
Deleted IMAP message.
Saw the strikethrough on the deleted message
Kontact crashed to desktop.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found) (Duplicates Removed)
[Thread debugging using libthread_db enabled]
[New Thread -1243461936 (LWP 11327)]
[New Thread -1322607728 (LWP 11358)]
[New Thread -1286022256 (LWP 11332)]
[New Thread -1277629552 (LWP 11331)]
[New Thread -1269236848 (LWP 11330)]
[New Thread -1260844144 (LWP 11329)]
(no debugging symbols found)(Duplicates Removed)
[KCrash handler]
#6  0xb7212449 in QGDict::look_string () from /usr/lib/libqt-mt.so.3
#7  0xb511d477 in KMHeaders::msgRemoved () from /usr/lib/libkmailprivate.so
#8  0xb520ce69 in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#9  0xb6f18813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#10 0xb501fc40 in KMFolder::msgRemoved () from /usr/lib/libkmailprivate.so
#11 0xb51124ad in KMFolder::qt_emit () from /usr/lib/libkmailprivate.so
#12 0xb6f187e7 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb501ed80 in FolderStorage::msgRemoved ()
   from /usr/lib/libkmailprivate.so
#14 0xb5184f2c in FolderStorage::take () from /usr/lib/libkmailprivate.so
#15 0xb529dd30 in KMFolderImap::take () from /usr/lib/libkmailprivate.so
#16 0xb4fd4fae in KMFolder::take () from /usr/lib/libkmailprivate.so
#17 0xb523ce95 in KMFolderMaildir::addMsgInternal ()
   from /usr/lib/libkmailprivate.so
#18 0xb523d7b7 in KMFolderMaildir::addMsg () from /usr/lib/libkmailprivate.so
#19 0xb5001063 in FolderStorage::moveMsg () from /usr/lib/libkmailprivate.so
#20 0xb4fd50e5 in KMFolder::moveMsg () from /usr/lib/libkmailprivate.so
#21 0xb50b1ccf in KMMoveCommand::execute () from /usr/lib/libkmailprivate.so
#22 0xb501a1c9 in KMCommand::slotPostTransfer ()
   from /usr/lib/libkmailprivate.so
#23 0xb50b35f6 in KMCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#24 0xb50b39cb in KMMenuCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#25 0xb50b3a57 in KMMoveCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#26 0xb50b3acb in KMDeleteMsgCommand::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#27 0xb6f18813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#28 0xb501a2ee in KMCommand::messagesTransfered ()
   from /usr/lib/libkmailprivate.so
#29 0xb5112ed1 in KMCommand::transferSelectedMsgs ()
   from /usr/lib/libkmailprivate.so
#30 0xb5113037 in KMCommand::slotStart () from /usr/lib/libkmailprivate.so
#31 0xb50b3608 in KMCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#32 0xb50b39cb in KMMenuCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#33 0xb50b3a57 in KMMoveCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#34 0xb50b3acb in KMDeleteMsgCommand::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#35 0xb6f18813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#36 0xb72a491c in QSignal::signal () from /usr/lib/libqt-mt.so.3
#37 0xb6f387a6 in QSignal::activate () from /usr/lib/libqt-mt.so.3
#38 0xb6f401bc in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#39 0xb6eaf9e8 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#40 0xb6eb1817 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#41 0xb75ebd52 in KApplication::notify () from /usr/lib/libkdecore.so.4
#42 0xb6e421e9 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#43 0xb6ea2433 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#44 0xb6e56d25 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#45 0xb6eca0be in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#46 0xb6ec9ece in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#47 0xb6eb1591 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#48 0x08061e25 in ?? ()
#49 0xbfa73bfc in ?? ()
#50 0x00000001 in ?? ()
#51 0x00000001 in ?? ()
#52 0x00000000 in ?? ()
Comment 1 Jake Nelson 2007-03-01 17:41:41 UTC
Happens everytime for me.  If there is a way to get more information about the crash please let me know so I can help find a fix.

Also, I'm running Kubuntu Feisty Fawn.
Comment 2 Jake Nelson 2007-03-01 17:55:26 UTC
Found out how to install the debugging symbols.  Hope this helps:

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1243175216 (LWP 12266)]
[New Thread -1285735536 (LWP 12270)]
[New Thread -1277342832 (LWP 12269)]
[New Thread -1268950128 (LWP 12268)]
[New Thread -1260557424 (LWP 12267)]
[KCrash handler]
#6  0xb7258449 in QGDict::look_string () from /usr/lib/libqt-mt.so.3
#7  0xb5163477 in KMHeaders::msgRemoved (this=0x8457d48, id=23, 
    msgId=@0xbfa1ddc4) at /usr/share/qt3/include/qdict.h:73
#8  0xb5252e69 in KMHeaders::qt_invoke (this=0x8457d48, _id=113, 
    _o=0xbfa1de40) at ./kmheaders.moc:301
#9  0xb6f5e813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#10 0xb5065c40 in KMFolder::msgRemoved (this=0x8435e08, t0=23, t1=@0xbfa1deb8)
    at ./kmfolder.moc:254
#11 0xb51584ad in KMFolder::qt_emit (this=0x8435e08, _id=9, _o=0xbfa1df30)
    at ./kmfolder.moc:381
#12 0xb6f5e7e7 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb5064d80 in FolderStorage::msgRemoved (this=0x8435fd8, t0=23, 
    t1=@0xbfa1dfa8) at ./folderstorage.moc:320
#14 0xb51caf2c in FolderStorage::take (this=0x8435fd8, idx=23)
    at /build/buildd/kdepim-3.5.6/./kmail/folderstorage.cpp:441
#15 0xb52e3d30 in KMFolderImap::take (this=0x8435fd8, idx=23)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfolderimap.cpp:571
#16 0xb501afae in KMFolder::take (this=0x8435e08, idx=23)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfolder.cpp:374
#17 0xb5282e95 in KMFolderMaildir::addMsgInternal (this=0x8438760, 
    aMsg=0x8177178, index_return=0xbfa1e278, stripUid=false)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfoldermaildir.cpp:454
#18 0xb52837b7 in KMFolderMaildir::addMsg (this=0x8438760, aMsg=0x8177178, 
    index_return=0xbfa1e278)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfoldermaildir.cpp:366
#19 0xb5047063 in FolderStorage::moveMsg (this=0x8438760, aMsg=0x8177178, 
    aIndex_ret=0xbfa1e278)
    at /build/buildd/kdepim-3.5.6/./kmail/folderstorage.cpp:590
#20 0xb501b0e5 in KMFolder::moveMsg (this=0x8438440, msg=0x8177178, 
    index_return=0xbfa1e278)
    at /build/buildd/kdepim-3.5.6/./kmail/kmfolder.cpp:419
#21 0xb50f7ccf in KMMoveCommand::execute (this=0x88419b8)
    at /build/buildd/kdepim-3.5.6/./kmail/kmcommands.cpp:2121
#22 0xb50601c9 in KMCommand::slotPostTransfer (this=0x88419b8, 
    result=KMCommand::OK)
    at /build/buildd/kdepim-3.5.6/./kmail/kmcommands.cpp:257
#23 0xb50f95f6 in KMCommand::qt_invoke (this=0x88419b8, _id=5, _o=0xbfa1e3d4)
    at ./kmcommands.moc:148
#24 0xb50f99cb in KMMenuCommand::qt_invoke (this=0x88419b8, _id=5, 
    _o=0xbfa1e3d4) at ./kmcommands.moc:2801
#25 0xb50f9a57 in KMMoveCommand::qt_invoke (this=0x88419b8, _id=5, 
    _o=0xbfa1e3d4) at ./kmcommands.moc:2984
#26 0xb50f9acb in KMDeleteMsgCommand::qt_invoke (this=0x88419b8, _id=5, 
    _o=0xbfa1e3d4) at ./kmcommands.moc:3059
#27 0xb6f5e813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#28 0xb50602ee in KMCommand::messagesTransfered (this=0x88419b8, 
    t0=KMCommand::OK) at ./kmcommands.moc:126
#29 0xb5158ed1 in KMCommand::transferSelectedMsgs (this=0x88419b8)
    at /build/buildd/kdepim-3.5.6/./kmail/kmcommands.cpp:352
#30 0xb5159037 in KMCommand::slotStart (this=0x88419b8)
    at /build/buildd/kdepim-3.5.6/./kmail/kmcommands.cpp:249
#31 0xb50f9608 in KMCommand::qt_invoke (this=0x88419b8, _id=4, _o=0xbfa1e578)
    at ./kmcommands.moc:147
#32 0xb50f99cb in KMMenuCommand::qt_invoke (this=0x88419b8, _id=4, 
    _o=0xbfa1e578) at ./kmcommands.moc:2801
#33 0xb50f9a57 in KMMoveCommand::qt_invoke (this=0x88419b8, _id=4, 
    _o=0xbfa1e578) at ./kmcommands.moc:2984
#34 0xb50f9acb in KMDeleteMsgCommand::qt_invoke (this=0x88419b8, _id=4, 
    _o=0xbfa1e578) at ./kmcommands.moc:3059
#35 0xb6f5e813 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#36 0xb72ea91c in QSignal::signal () from /usr/lib/libqt-mt.so.3
#37 0xb6f7e7a6 in QSignal::activate () from /usr/lib/libqt-mt.so.3
#38 0xb6f861bc in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#39 0xb6ef59e8 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#40 0xb6ef7817 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#41 0xb7631d52 in KApplication::notify (this=0xbfa1ebdc, receiver=0x81a6fe0, 
    event=0xbfa1e8c8)
    at /build/buildd/kdelibs-3.5.6/./kdecore/kapplication.cpp:550
#42 0xb6e881e9 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#43 0xb6ee8433 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#44 0xb6e9cd25 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#45 0xb6f100be in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#46 0xb6f0fece in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#47 0xb6ef7591 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#48 0x08061e25 in main (argc=1, argv=0xbfa1ddd8)
    at /build/buildd/kdepim-3.5.6/./kontact/src/main.cpp:163
#49 0xb76cbebc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#50 0x08059151 in _start ()
Comment 3 Thomas McGuire 2007-03-01 19:16:17 UTC
The backtrace looks very much like the one from bug #127107, so it is likely the same cause. closing as dupllicate.

*** This bug has been marked as a duplicate of 127107 ***