Bug 122599 - search improvement: highlight all occurences
Summary: search improvement: highlight all occurences
Status: RESOLVED DUPLICATE of bug 377487
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 7 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-24 00:26 UTC by JM
Modified: 2021-11-24 14:04 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JM 2006-02-24 00:26:02 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Gentoo Packages

I have several ideas to improve search abilities in Konqueror.

1. Highligh all occurences of pattern (e.g. with yellow). Still mark the current occurence with different color (e.g. red).

2. I have some one-key shortcuts. The key "a" to go back, for instance. But when I use incremental search started with "/", I cannot use "a" in the pattern. When "a" is pressed the shortcut action is performed. It make sense to consider this "a" as a part of pattern until the searching is finished (timeout, ESC). Personally, I consider this as a bug.
Comment 1 Thiago Macieira 2006-02-26 17:24:49 UTC
Please re-file the second issue as a bug.
Comment 2 JM 2006-02-27 08:32:27 UTC
2nd issue added as bug 122782. http://bugs.kde.org/show_bug.cgi?id=122782
Comment 3 Matt Williams 2008-12-28 23:03:10 UTC
As of KDE 4.2 beta 2 this feature is still not implemented though it should be noted that the default katepart search bar does provide this, as does konsole (though with different implementations). Is there any intention for sharing code/features/UI for this across konq/katepart/okular/konsole etc?
Comment 4 Angel Blue01 2009-03-07 23:35:37 UTC
It is very irritating that Kate/Kwrite includes this but Konqueror does not.
Comment 5 Tommi Tervo 2009-03-26 14:19:08 UTC
*** Bug 188164 has been marked as a duplicate of this bug. ***
Comment 6 postix 2021-11-24 14:03:18 UTC

*** This bug has been marked as a duplicate of bug 326087 ***
Comment 7 postix 2021-11-24 14:04:45 UTC

*** This bug has been marked as a duplicate of bug 377487 ***