Bug 118083 - Kontact crashed while using Configure Kmail - Accounts
Summary: Kontact crashed while using Configure Kmail - Accounts
Status: RESOLVED FIXED
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 124085 132025 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-10 19:42 UTC by Zubin Singh Parihar
Modified: 2007-09-14 12:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zubin Singh Parihar 2005-12-10 19:42:39 UTC
Version:           Kontact Version 1.1.2 - In Kontact I was running Kmail --> Configure Kmail - this rpm is actually from kde-redhat.org (using KDE KDE 3.4.3)
Installed from:    Fedora RPMs
Compiler:          gcc version 3.4.4 20050721 (Red Hat 3.4.4-2)
 gcc -v
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.4/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-java-awt=gtk --host=i386-redhat-linux
Thread model: posix
OS:                Linux

Kontact was running for about 2 weeks consecutively.  Today I wanted uncheck "Leave Fetched Messages on Server" (which by the way should have more options like 'leave message on server for 30 days or 7 days etc.).

So I went to 'Mail' on the side icon bar and then clicked on the menu "settings", "configure kmail" and then clicked Accounts.  I clicked on My Account under the "receiving Tab" and then clicked modify.  When the 'Modify Account - Kontact" window came up...I was looking for an option to leave fetched messages on server for a certain time period... eg. leave fetched mail - 7days / 10 days / 30 days etc. 

I decided not to change anything, and then I just pressed 'OK'.  I left it on the Configure - Kontact/kmail window and went to another application.... konqueror and then it just crashed...

What is really funny is that I as I am writing this bug report I recreated the events that I just described to you... and it Crashed again! LOL!


Here is the backtrace that I have just received:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1208456992 (LWP 23509)]
[KCrash handler]
#4  0x06405ef8 in QString::deref () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0x06406151 in QString::operator= () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#6  0x0537de9b in KPIM::ProgressItem::setStatus ()
   from /usr/lib/libkdepim.so.1
#7  0x059710fe in KMAcctExpPop::slotJobFinished ()
   from /usr/lib/libkmailprivate.so
#8  0x05972c2c in KMAcctExpPop::slotResult () from /usr/lib/libkmailprivate.so
#9  0x05972e52 in KMAcctExpPop::qt_invoke () from /usr/lib/libkmailprivate.so
#10 0x0613c6ce in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x04b15469 in KIO::Job::result () from /usr/lib/libkio.so.4
#12 0x04b3fd58 in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#13 0x04b6f11a in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#14 0x04b6f885 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#15 0x04b3f982 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#16 0x0613c6ce in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x0613cda4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x04b13870 in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#19 0x04b600f2 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#20 0x04b3da19 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#21 0x04b3461c in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#22 0x04b3bdbf in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#23 0x0613c6ce in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x0613cc60 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x06470614 in QSocketNotifier::activated ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x061577e5 in QSocketNotifier::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x060dda89 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x060ddc1a in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x0032ccc6 in KApplication::notify () from /usr/lib/libkdecore.so.4
#30 0x060d1f42 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x0608c2de in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x060f3125 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x060f307e in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x060dcc8b in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x0806021c in ?? ()
#36 0xbffb4bd0 in ?? ()
#37 0x00000001 in ?? ()
#38 0x00000001 in ?? ()
#39 0x00000000 in ?? ()



I hope this can be resolved... 

Feel free to contact me for further details...

I am running Fedora core 3, however, I get my KDE rpms from kde-redhat.org via yum.

here is an output of the kde rpm's installed:

$ rpm -qa | grep -i kde

gtk+-devel-1.2.10-33.5.3.kde
ghostscript-devel-7.07-37.0.3.kde
samba-client-3.0.14a-2.1.fc3.kde
wv2-0.2.2-5.0.fc3.kde
qt-3.3.4-17.4.fc3.kde
arts-1.4.3-1.0.fc3.kde
koffice-kword-1.4.2-1.2.fc3.kde
koffice-karbon-1.4.2-1.2.fc3.kde
kdepim-devel-3.4.3-1.0.fc3.kde
kdeadmin-3.4.3-1.0.fc3.kde
k3b-0.12.7-1.0.fc3.kde
desktop-file-utils-0.9-2.0.3.kde
xscreensaver-extras-4.21-1.0.3.kde
digikam-devel-0.7.4-0.2.fc3.kde
digikam-0.7.4-0.2.fc3.kde
qt-MySQL-3.3.4-17.4.fc3.kde
PyQt-examples-3.15-0.1.fc3.kde
kdemultimedia-3.4.3-1.0.fc3.kde
koffice-kpresenter-1.4.2-1.2.fc3.kde
kdevelop-3.2.3-1.0.fc3.kde
kdebindings-devel-3.4.3-1.0.fc3.kde
kdeaddons-atlantikdesigner-3.4.3-1.0.fc3.kde
libmusicbrainz-2.1.2-0.1.fc3.kde
redhat-artwork-0.124-1.0.fc3.kde
samba-common-3.0.14a-2.1.fc3.kde
redhat-menus-3.8-0.1.3.kde
sip-4.3.1-0.1.fc3.kde
PyQt-devel-3.15-0.1.fc3.kde
koffice-core-1.4.2-1.2.fc3.kde
kdeaddons-3.4.3-1.0.fc3.kde
koffice-filters-1.4.2-1.2.fc3.kde
koffice-kivio-1.4.2-1.2.fc3.kde
kdeutils-3.4.3-1.0.fc3.kde
kdeedu-3.4.3-1.0.fc3.kde
kdeutils-devel-3.4.3-1.0.fc3.kde
kdegraphics-devel-3.4.3-1.0.fc3.kde
kdeaccessibility-kttsd-gstreamer-3.4.3-1.0.fc3.kde
kdewebdev-devel-3.4.3-1.0.fc3.kde
libmng-1.0.8-1.0.3.kde
pilot-link-devel-0.11.8-10.0.3.kde
ImageMagick-c++-devel-6.2.3.0-0.1.fc3.kde
ImageMagick-devel-6.2.3.0-0.1.fc3.kde
boost-1.33.0-3.0.fc3.kde
qt-devel-3.3.4-17.4.fc3.kde
openoffice.org-libs-1.1.5-0.1.fc3.kde
qt-designer-3.3.4-17.4.fc3.kde
dbus-qt-0.22-10.FC3.2.1.kde
rdesktop-1.4.1-0.0.fc3.kde
kdebase-3.4.3-1.1.fc3.kde
pilot-link-0.11.8-10.0.3.kde
OpenEXR-1.2.2-2.0.3.kde
samba-3.0.14a-2.1.fc3.kde
openoffice.org-kde-1.1.5-0.1.fc3.kde
PyQt-3.15-0.1.fc3.kde
PyQt-qscintilla-3.15-0.1.fc3.kde
kdepim-3.4.3-1.0.fc3.kde
kdeaccessibility-3.4.3-1.0.fc3.kde
koffice-kspread-1.4.2-1.2.fc3.kde
koffice-kchart-1.4.2-1.2.fc3.kde
kdegames-3.4.3-1.0.fc3.kde
koffice-kformula-1.4.2-1.2.fc3.kde
arts-devel-1.4.3-1.0.fc3.kde
kdetoys-3.4.3-1.0.fc3.kde
koffice-suite-1.4.2-1.2.fc3.kde
baghira-0.7-1.fc3.kde
kdewebdev-3.4.3-1.0.fc3.kde
unixODBC-kde-2.2.9-1
ghostscript-7.07-37.0.3.kde
libmng-devel-1.0.8-1.0.3.kde
lockdev-devel-1.0.1-4.1
ImageMagick-6.2.3.0-0.1.fc3.kde
ImageMagick-c++-6.2.3.0-0.1.fc3.kde
openoffice.org-i18n-1.1.5-0.0.kde
qt-ODBC-3.3.4-17.4.fc3.kde
kdenetwork-3.4.3-1.1.fc3.kde
kdelibs-devel-3.4.3-1.1.fc3.kde
gtk+-1.2.10-33.5.3.kde
libmusicbrainz20-2.0.2-0.0.3.kde
lockdev-1.0.1-4.1
xscreensaver-base-4.21-1.0.3.kde
xscreensaver-gl-extras-4.21-1.0.3.kde
ImageMagick-perl-6.2.3.0-0.1.fc3.kde
qscintilla-1.6-2.fc3.kde
sip-devel-4.3.1-0.1.fc3.kde
kdesdk-3.4.3-1.0.fc3.kde
koffice-kexi-1.4.2-1.2.fc3.kde
kdebindings-3.4.3-1.0.fc3.kde
kdeaccessibility-devel-3.4.3-1.0.fc3.kde
kdeaddons-xmms-3.4.3-1.0.fc3.kde
kdeartwork-3.4.3-1.0.fc3.kde
kdenetwork-devel-3.4.3-1.1.fc3.kde
perl-Crypt-SmbHash-0.12-0.0.3.kde
boost-devel-1.33.0-3.0.fc3.kde
dbus-devel-0.22-10.FC3.2.1.kde
openoffice.org-1.1.5-0.1.fc3.kde
koffice-krita-1.4.2-1.2.fc3.kde
koffice-kugar-1.4.2-1.2.fc3.kde
kdegraphics-3.4.3-1.0.fc3.kde
kdesdk-devel-3.4.3-1.0.fc3.kde
kdebase-devel-3.4.3-1.1.fc3.kde
kdelibs-3.4.3-1.1.fc3.kde



I believe (and hope) this will be the last time I experience this as I am upgrading to KDE 3.5 today via kde-redhat.org using YUM.


Good Luck and thanks for the Great Product!

Zubin Parihar
Comment 1 Andreas Kling 2006-07-31 14:36:37 UTC
*** Bug 124085 has been marked as a duplicate of this bug. ***
Comment 2 Andreas Kling 2006-08-08 07:09:51 UTC
*** Bug 132025 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Kling 2006-09-17 19:50:49 UTC
SVN commit 585670 by kling:

Use a QGuardedPtr for the KPIM::ProgressItem in KMAccount.
Fixes a bazillion crashes when dereferencing deleted items.

BUG: 105701
BUG: 114953
BUG: 114197
BUG: 117475
BUG: 118083
BUG: 128131
BUG: 129007
BUG: 133023
BUG: 133745


 M  +1 -1      kmaccount.h  


--- branches/KDE/3.5/kdepim/kmail/kmaccount.h #585669:585670
@@ -309,7 +309,7 @@
   QValueList<KMMessage*> mReceipts;
   QPtrList<FolderJob>  mJobList;
   bool mHasInbox : 1;
-  ProgressItem *mMailCheckProgressItem;
+  QGuardedPtr<ProgressItem> mMailCheckProgressItem;
 
 private:
     /**