Bug 124085 - kmail locked up when I clicked 'apply' after clicking save my password.
Summary: kmail locked up when I clicked 'apply' after clicking save my password.
Status: RESOLVED DUPLICATE of bug 118083
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.8.2
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-22 17:21 UTC by Bruce Bales
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Bales 2006-03-22 17:21:05 UTC
Version:           1.8.2 (using KDE KDE 3.5.1)
Installed from:    Fedora RPMs
Compiler:          gcc 3.4.4 
OS:                Linux

I have four accounts.  I got tired of re-entering passwords, so I modified the accounts by clicking the "save password" button.  When I clicked the "apply" button everything locked up.
Was able to shut kmail down and restarted with no apparent loss of date or mail.
After some use with no problems, I went to bed and when I came back next morning I had a "Crashed" message. I got the backtrace and saved it.  Don't see where else to put it, so here it is.  Good luck

Using host libthread_db library "/lib/tls/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1208923520 (LWP 30187)]
[KCrash handler]
#4  0x02a4b5e1 in QString::deref () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0x02a4b841 in QString::operator= () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#6  0x035a4f89 in KPIM::ProgressItem::setStatus () from /usr/lib/libkdepim.so.1
#7  0x03d1cad6 in KMAcctExpPop::slotJobFinished ()
   from /usr/lib/libkmailprivate.so
#8  0x03d1db0c in KMAcctExpPop::slotResult () from /usr/lib/libkmailprivate.so
#9  0x03d1e198 in KMAcctExpPop::qt_invoke () from /usr/lib/libkmailprivate.so
#10 0x0278085e in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x031c2d47 in KIO::Job::result () from /usr/lib/libkio.so.4
#12 0x031c2dba in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#13 0x031c52fe in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#14 0x031d4855 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#15 0x031c43e4 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#16 0x0278085e in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x02780f34 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x031b18ec in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#19 0x031b45b2 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#20 0x031b2ea7 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#21 0x031af0b6 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#22 0x031af43f in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#23 0x0278085e in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x02780df0 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x02ab5e74 in QSocketNotifier::activated ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x0279b7b5 in QSocketNotifier::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x027215c9 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x0272175a in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x02c701e8 in KApplication::notify () from /usr/lib/libkdecore.so.4
#30 0x02715ae2 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x026d019e in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x02736c65 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x02736bbe in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x027207cb in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x0804a2fc in ?? ()
#36 0xbfb3ac40 in ?? ()
#37 0xbfb3ab50 in ?? ()
#38 0x00000000 in ?? ()
Comment 1 Andreas Kling 2006-07-31 14:36:34 UTC

*** This bug has been marked as a duplicate of 118083 ***