Bug 111051 - Missing important information about seeds/trackers
Summary: Missing important information about seeds/trackers
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-19 03:58 UTC by Jason Carter
Modified: 2005-08-23 13:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Carter 2005-08-19 03:58:14 UTC
Version:           SVN (using KDE KDE 3.4.2)
Compiler:          gcc 3.3.5-20050130 (Gentoo 3.3.5.20050130-r1, ssp-3.3.5.20050130-1, pie-8.7.7.1) 
OS:                Linux

I think it would be great if you could add the ability to have the following listed/displayed for each torrent with the ability to choose which attributes to show (perhaps with the current set as the default). 

Examples of things I would love to see would be upload/download ratio, upload time until 1.0 ratio, number of seeds, number of peers and seeds currently connected to. Perhaps as Azureus does with the Peers and Seeds categories showing total number of peers and seeds with the connected amount of each in parentheses.

It would also be great if we could have a right click menu item  for each torrent with more detailed information about the torrent, I guess "Properties" would work. Things that I'd like to see would include the tracker(s) for the torrent, list of currently connected peers and seeds with IP lists and so on.
Comment 1 Joris Guisson 2005-08-19 09:45:11 UTC
You can allready see a list of all the connected peers when you start ktorrent in debug mode (ktorrent --debug), together with a lists of chunks which are currently downloading.

We're allready planning to show number of seeders and leechers. Showing the share ratio and time to 1.0 should be pretty easy.

The funny thing about this is that some other guy wants to me to show less information (http://bugs.kde.org/show_bug.cgi?id=110765), you want to show more information.
Comment 2 Jason Carter 2005-08-19 13:05:05 UTC
Glad to hear about the upcoming additions.

Yeah, I already saw the other guy's request for less information. I guess it kind of comes down to what you want to do with KTorrent.. if you're planning on making it a fully featured BitTorrent client for KDE or if you just want it to be something small and simple. I'd prefer the fully featured client, as you can tell. The way I see it, there already is/will be a simple BitTorrent client integrated into KGet already. I'm already really loving what you've done with KTorrent. Think of it this way.. you'll be helping KDE users get rid of the Java/Azureus memory hog combo. ;)
Comment 3 Frank Osterfeld 2005-08-20 10:38:12 UTC
*** Bug 111133 has been marked as a duplicate of this bug. ***
Comment 4 Alexander van Loon 2005-08-20 19:01:35 UTC
I didn't mean that KTorrent should display less information, I meant that KTorrent shouldn't display unnecessary information.

For example, what the peers list (which can now only be seen in debug mode) did was display every peer connected, and give information about client they were using, their IP, and other things. The chunks tab was similar. That is just unnecessary information, it's overkill for the normal user.

However, I do agree with Jason's proposals. Simply displaying "Seeds connected/max: x/x" and "Peers connected/max: x/x" in the Status tab is useful information. Same goes for upload/download ratio and the other proposals. All I said is that it shouldn't be overdone in my point of view, no Azureus style statistics and other bloat :P.
Comment 5 Joris Guisson 2005-08-23 13:08:14 UTC
SVN commit 452433 by guisson:

Changes :
- Added methods to get the number of leechers and seeders to TorrentControl
- Show seeders and leechers in InfoWidget (FEATURE 111051)
- Show share ratio in InfoWidget (FEATURE 111051)
- Fixed 111276
- Each Peer now owns it's PeerDownloader and PeerUploader
- Increased crash safety by not having Peer* members everywhere
- Take into account the fact that we can have multiple torrents who have UDP Trackers

FEATURE: 111051
BUG: 111276



 M  +1 -1      ktorrent.kdevelop  
 M  +9 -9      libtorrent/Makefile.am  
 M  +6 -8      libtorrent/chunkdownload.cpp  
 M  +3 -2      libtorrent/chunkdownload.h  
 M  +7 -13     libtorrent/downloader.cpp  
 M  +0 -1      libtorrent/downloader.h  
 M  +10 -1     libtorrent/httptracker.cpp  
 M  +14 -3     libtorrent/peer.cpp  
 M  +18 -5     libtorrent/peer.h  
 M  +13 -1     libtorrent/peerid.cpp  
 M  +1 -0      libtorrent/peerid.h  
 M  +27 -17    libtorrent/peermanager.cpp  
 M  +17 -3     libtorrent/peermanager.h  
 M  +2 -3      libtorrent/peeruploader.cpp  
 M  +4 -5      libtorrent/peeruploader.h  
 M  +1 -1      libtorrent/piece.cpp  
 M  +1 -1      libtorrent/piece.h  
 M  +2 -2      libtorrent/request.cpp  
 M  +6 -10     libtorrent/request.h  
 M  +0 -2      libtorrent/speedestimater.cpp  
 M  +33 -5     libtorrent/torrentcontrol.cpp  
 M  +14 -0     libtorrent/torrentcontrol.h  
 M  +3 -1      libtorrent/tracker.cpp  
 M  +7 -1      libtorrent/tracker.h  
 M  +80 -180   libtorrent/udptracker.cpp  
 M  +10 -12    libtorrent/udptracker.h  
 A             libtorrent/udptrackersocket.cpp   [License: GPL (v2+)]
 A             libtorrent/udptrackersocket.h   [License: GPL (v2+)]
 M  +17 -49    libtorrent/uploader.cpp  
 M  +3 -23     libtorrent/uploader.h  
 M  +12 -0     src/infowidget.cpp  
 M  +261 -81   src/infowidgetbase.ui  
 M  +4 -12     src/ktorrent.cpp  
 M  +4 -3      src/ktorrentview.cpp