Bug 111133 - Add "Seeds" column to torrent list
Summary: Add "Seeds" column to torrent list
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-20 08:47 UTC by Frank Osterfeld
Modified: 2007-05-06 19:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Adds columns 'seeders' and 'leechers' (1.71 KB, patch)
2007-05-06 14:27 UTC, Sebastian Goth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Osterfeld 2005-08-20 08:47:11 UTC
Instead of displaying only the number of peers, KTorrent could also list the 
number of seeds. Maybe combined in one column in the form "Seeds/Peers", e.g. 
"20/5". Well, that would break sorting. 
 
Btw, great work! The speed my bugs got fixed and my feature requests got 
implemented is really impressive =) Thanks!
Comment 1 Jason Carter 2005-08-20 10:26:58 UTC
http://bugs.kde.org/show_bug.cgi?id=111051
Comment 2 Frank Osterfeld 2005-08-20 10:38:10 UTC

*** This bug has been marked as a duplicate of 111051 ***
Comment 3 Sebastian Goth 2007-05-06 14:25:11 UTC
Was this really a duplicate to 111051?
Since there only the basic ability to view seeders and leechers have been discussed - not the implementation as columns in the lists.

Tried to implement that in the attached patch which is pretty small since all used information is already pulled into TorrentStats.
Comment 4 Sebastian Goth 2007-05-06 14:27:36 UTC
Created attachment 20497 [details]
Adds columns 'seeders' and 'leechers'

The values are displayed kinda 'azureus-like': "4 (5)" meaning "connected to 4
of 5 available"
Comment 5 Joris Guisson 2007-05-06 19:37:19 UTC
Lets reopen to examine this patch
Comment 6 Joris Guisson 2007-05-06 19:40:26 UTC
OK, I see Ivan already committed this patch, so lets close the bug