Bug 110765 - simplify ktorrent interface/remove unnecessary information
Summary: simplify ktorrent interface/remove unnecessary information
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-14 16:52 UTC by Alexander van Loon
Modified: 2005-08-27 12:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander van Loon 2005-08-14 16:52:22 UTC
Version:            (using KDE KDE 3.4.2)

I wonder what the long term vision for KTorrent is, what kind of audience does it aim for? I.e. will KTorrent become a complex bittorrent client with a huge amount of features like Azureus, or will it be more simple?

I think the latter would be a better choice. In the case that it is also the developers intention to keep KTorrent simple, I have some suggestions.

IMO KTorrent's interface (I'm talking about the latest SVN builds here) contains some unnecessary information. In the "Status" tab, the only useful information is "parts of the file which are available". All the other information about the chunks could be removed. Including "Parts of the file which have been downloaded", for most people the only thing which matters is if the file is downloaded or if it is still downloading. But we can already see that in the "Downloaded" column.

I think the same goes for the tabs "Chunks" and "Peers". The information they give the user is not essential.

Then you would only have the tabs "Status" and "Files" left. "Status" could be filled with different information. For example Seeds and Peers (Then the "Peers" column could also be removed, which would save space in the KTorrent window), tracker adress, the status of the tracker, average up/down speeds, and other things which might be useful.

I know my suggestion is quite radical, but why do it the complex way, if it can be made easy? A simple client would be a lot easier to use.
Comment 1 Joris Guisson 2005-08-14 17:47:59 UTC
The ChunkBar is staying, it gives a nice graphical view of the whole download process, and it's more user friendly (the user can see what is downloaded, he/she doesn't have to actually read the information in the list view).

Moving the Peers column to the status page and show some more info (like seeders and leechers), might not be a bad idea. 

Showing the status of the tracker has been implemented I just need to commit it.

The Peers and Chunks tabs, I find them usefull, so I'm not planning on getting rid of them. However showing them only in debug mode is probably a better idea, they're not very usefull for normal users.

Showing average up and download speeds, we might do that. We will see.
Comment 2 Alexander van Loon 2005-08-20 20:08:54 UTC
Thanks for changing it, but I don't understand why you would want to keep the chunk bar. What advantage does it give over the information in the "Downloaded" column? Why would I want to know that chunk number X was just downloaded, how is that interesting information for me? Does it make a difference to know whether the first chunks were just downloaded or the last chunks? I don't see why it is good to give a graphical overview if you can look at the % Complete and Downloaded columns and see how the progress is going. Maybe you could make an option to hide it for those who don't like it.
Comment 3 Joris Guisson 2005-08-21 11:11:08 UTC
Seeing if the bar is filled is a lot easier then reading the information in the downloaded column. You want an easier client, I think the ChunkBar makes it easier. (reading probably requires more brain activity then seeing if the bar is blue)
Comment 4 Hans de Raad 2005-08-23 08:20:40 UTC
First off all i'd like to express my appreciation for this app, ktorrent has rapidly become my favorite torrent leecher, simply for the ease of use and the clean (KDE integrated) UI!

Second, i also have a request on this subject, would it be possible to, instead of using alertboxes, use the status bar for error notifications?
Now when i have a large list of torrents running for a while i often have to wade thru several hundreds of these error messages.
Wouldn't it be an option to just display the error message in the status bar and automatically check (after a configurable period) whether or not the torrent is back online again, then its up to the user to once in a while clean up the list.

Kindest regards,
Hans de Raad
Comment 5 Joris Guisson 2005-08-23 13:17:49 UTC
I was allready planning to show error messages in the status column of each torrent, and give them a nice fat red color (so you won't miss it). 

The statusbar can only show one message at a time, so it isn't a good candidate to show error messages from a potentially large number of torrents.

But this really doesn't belong in this bug report.
Comment 6 Hans de Raad 2005-08-23 19:56:49 UTC
Allways nice to see such sharp and to the point responses on a wishrequest (cause thats what this bugreport actually seems to be, the topic does mention something about cleaning up the UI, which was precisely what i intended).
I could have off course opened some other bug and spammed bugs.kde.org with it.

But anyway its good to see you take all us simple users in account.

Still like the client very much though, and oh, yeah btw, it has been packaged for Mandriva, thru a package request (and a partial build) by me.
The package is being distributed with Mandriva from now on, it has also been adopted into cooker (and yes this is not the place to mention such remarks, sincere apologies in advance for my unforgivable rudeness).

Good luck devving,
Hans de Raad
Comment 7 Joris Guisson 2005-08-23 22:05:13 UTC
It's only normal that I should react to people who have taken the time to file a bug report. 

Comment 8 Hans de Raad 2005-08-24 01:05:30 UTC
Ok, lets try a different approach here then, here you are, a nice wish request (the reason why i added it here was because of the Mandriva bugzilla system in which they seem to prefer bundled requests if they appear to be about a similar topic, and since this one was also still unconfirmed...):

http://bugs.kde.org/show_bug.cgi?id=111394

Sorry for causing any inconvenience,

kind regards,
Hans
Comment 9 Joris Guisson 2005-08-27 12:35:57 UTC
I'm gonna close this bug now, everything which I intended to do for this bug, has been done.