Bug 108974 - KMail is case sensitive in mailto urls, ignores the "to" field.
Summary: KMail is case sensitive in mailto urls, ignores the "to" field.
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.12.90
Platform: unspecified Linux
: NOR normal with 10 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 141886 158400 210876 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-12 09:31 UTC by Jens
Modified: 2009-10-17 19:21 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens 2005-07-12 09:31:42 UTC
Version:           1.8.1 (using KDE 3.4.1 Level "a" , SUSE 9.3 UNSUPPORTED)
Compiler:          gcc version 3.3.5 20050117 (prerelease) (SUSE Linux)
OS:                Linux (i686) release 2.6.11.4-21.7-default

Reproduce:
click on a link within an email, for example:

mailto:jens-bugs.kde.org@spamfreemail.de?Subject=foobar

The "Subject" text is not copied into the Subject field of the new mail window that pops up. I don't know if the same goes also for body etc. tags.


Please have a look.. this should not be too much work to fix
Thank you! :)

Jens
Comment 1 Andreas Gungl 2005-07-12 09:57:35 UTC
Not a bug but a feature...
Comment 2 Jens 2005-07-12 10:13:18 UTC
I beg to differ. See:

"To unsubscribe from this list, please click here:
  mailto:foo-list@bar.tld?Subject=unsubscribe"
Comment 3 Thiago Macieira 2005-07-12 13:39:52 UTC
Works for me, KDE trunk 430645.
Comment 4 Andreas Gungl 2005-07-12 13:48:44 UTC
Hm, funny thing. It works for me in KDE 3.4.1 for ?subject= (but it doesn't work for ?Subject= - note the upper case S).
Comment 5 Thomas McGuire 2007-02-18 21:30:07 UTC
*** Bug 141886 has been marked as a duplicate of this bug. ***
Comment 6 Ropetin Again 2007-06-08 20:48:28 UTC
I'm using 1.9.7 pulled from SVN, and still this problem is present.

To clarify, at least in my case.  If I'm using Konqueror, a mailto: with a subject works no matter how the word subject is cased (subject, Subject, SUBJECT).  However, if I'm using Firefox 2.0, the subject doesn't get passed to Kmail with any variation on case.

I'm running Ubuntu Feisty Fawn with all the latest updates.  Everything is from the Ubuntu packages, apart from Kmail which I built from SVN, just to make sure this hadn't already been fixed.
Comment 7 Jonathan Marten 2008-02-25 18:12:02 UTC
*** Bug 158400 has been marked as a duplicate of this bug. ***
Comment 8 Ingo Klöcker 2008-02-25 22:24:16 UTC
Use 'kmailservice [url]' instead of 'kmail [url]'. This calls whatever mailer is configured as default mailer in KDE.
Comment 9 Rodney Baker 2008-02-26 09:44:01 UTC
Using kmailservice does work. Tested with Opera, Firefox, Epiphany and Konqueror. To make Firefox/Epiphany work, go to Gnome Control Centre, Applications and for the email tab select Custom and type kmailservice %s.

For Opera, kmailservice is sufficient (does not require any other parameters).

Konqueror just works.

I think this can be classed as an acceptable workaround :-).

Comment 10 Techwolf 2008-03-27 18:56:33 UTC
For those that do not have the Gnome Control Center because they are running the kde desktop.
In firefox "about:config", set "network.protocol-handler.app.mailto" to "kmailservice".
Setting it to just "kmail" will not pass the subject/body. Note that "%s" is not required and will not work with it.
Comment 11 Alex Mermod 2008-11-04 09:00:24 UTC
Apparently the "subject=.." works only when no "body=.." is present in the RFC-2368 mailto: link
Comment 12 Thomas McGuire 2009-01-23 16:07:11 UTC
SVN commit 915697 by tmcguire:

Make mailto links which include body and subject work correctly again.
BUG: 108974
BUG: 117293


 M  +9 -18     kmcommands.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915697
Comment 13 Thomas McGuire 2009-01-29 17:45:06 UTC
SVN commit 918210 by tmcguire:

Backport r915697 by tmcguire from trunk to the 4.2 branch:

Make mailto links which include body and subject work correctly again.
CCBUG: 108974
CCBUG: 117293



 M  +9 -18     kmcommands.cpp  
 M  +46 -18    messagelistview/core/sortorder.cpp  
 M  +5 -1      messagelistview/core/sortorder.h  
 M  +1 -1      messagelistview/core/widgetbase.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=918210
Comment 14 Jithin Emmanuel 2009-10-17 05:00:34 UTC
I have the same issue with kde 4.3.2. Subject is not gettting populated.
And I cannot find this application kmailservice
Comment 15 Torgny Nyblom 2009-10-17 15:38:09 UTC
This bug seems to be back in a slightly different way.
Links that have "subject" works while links that have "Subject" does not, and mailto:?to=joe@xyz.com&cc=bob@xyz.com&body=hello does not add "joe@xyz.com" to the "To" field.
Comment 16 Torgny Nyblom 2009-10-17 15:39:18 UTC
*** Bug 210876 has been marked as a duplicate of this bug. ***
Comment 17 Torgny Nyblom 2009-10-17 19:21:21 UTC
SVN commit 1036720 by tnyblom

Make kmail caseinsensitive when processing mailto urls also enable "to" to be specified in the url explisitly.
BUG 108974

M  +6  -3    stringutil.cpp

WebSVN link: http://websvn.kde.org/?view=rev&revision=1036720