Bug 105692 - Information shown in file "Properties" window should be selectable for copying
Summary: Information shown in file "Properties" window should be selectable for copying
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: Properties dialog (show other bugs)
Version: 5.47.0
Platform: unspecified Linux
: NOR wishlist
Target Milestone: ---
Assignee: David Faure
URL:
Keywords: junior-jobs, usability
: 103088 336715 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-05-15 08:08 UTC by William Kendrick
Modified: 2018-08-13 08:23 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Kendrick 2005-05-15 08:08:14 UTC
Version:           3.4.0 (using KDE 3.4.0, Debian Package 4:3.4.0-0pre4 (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-12)
OS:                Linux (i686) release 2.6.8-2-686

When viewing the properties of a file (size, modification and access date, meta info such as bitrate for an MP3 or dimensions for a JPEG), it would be nice if the information could be selected (highlighted) with the mouse, and copied for pasting elsewhere.
Comment 1 William Kendrick 2007-02-01 04:14:04 UTC
Data is still not selectable in KDE 3.5.6.
Comment 2 Christoph Feck 2009-08-27 02:36:19 UTC
Moving from "kio/kfile" component to "kfile" product, helps sorting out duplicates.
Comment 3 Nate Graham 2018-06-15 02:22:59 UTC
*** Bug 103088 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2018-06-15 04:54:24 UTC
Have a patch: https://phabricator.kde.org/D13554
Comment 5 Nate Graham 2018-06-19 22:29:14 UTC
Git commit 025e5e9957ff92c8196f820e9490f337ebfbe317 by Nathaniel Graham.
Committed on 19/06/2018 at 22:29.
Pushed by ngraham into branch 'master'.

[Properties dialog] Make all field values on general tab selectable

Summary:
The {nav Location} field was already selectable; this patch extends that courtesy to all the rest.
FIXED-IN 5.48

Test Plan: {F5913321}

Reviewers: #frameworks, #dolphin, elvisangelaccio

Reviewed By: #dolphin, elvisangelaccio

Subscribers: kde-frameworks-devel

Tags: #frameworks

Differential Revision: https://phabricator.kde.org/D13554

M  +4    -0    src/widgets/kpropertiesdialog.cpp

https://commits.kde.org/kio/025e5e9957ff92c8196f820e9490f337ebfbe317
Comment 6 Nate Graham 2018-08-13 08:23:21 UTC
*** Bug 336715 has been marked as a duplicate of this bug. ***