Bug 462860

Summary: Rectangle capture modes have wrong GUI sizing and positioning with fractional scaling
Product: [Applications] Spectacle Reporter: ryu.ketsueki
Component: GeneralAssignee: Boudhayan Gupta <me>
Status: CLOSED FIXED    
Severity: normal CC: a.aannestad, amantia, anthonyn562013, apricus, bizyaev, gus, i, ihipop, indecisiveautomator, kde, kde, kekcuha, kinneyanick, lynn, m.lincetto, matthewjhdec1991, meinardadrian, mg.solariz, nate, noahadvs, openmail+kde, otheraccount360, peter.laszlo.szabo, quarckster, rondo.sp, sannythebest95, sauersandro149, theattish, ye.jingchen, zeeko
Priority: HI Keywords: multiscreen, wayland
Version: 23.04.3   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In: 24.02.0
Attachments: The actual effect
A photo showing what is happening
Spectacle scaling problem 800x600 at 150%
800x600@150%, 3840x2160@200% for ndavis
2880x1800@200%,2560x1440@115%

Description ryu.ketsueki 2022-12-10 17:39:16 UTC
Created attachment 154483 [details]
The actual effect

Is a bit hard to describe accurately so I am attaching a photo I took with my phone. To reproduce this, you have to be on Wayland session, although I think it also happens with certain X11 workarounds to achieve a similar effect. To do that, you change the scaling factor away from 100%. In my case, it is on 70%.

From what I understood here, the actual desktop is under that "photo" and you can actually snap a retangular region there and will be accurate, meaning that the smaller photo is only a bit misleading in this context. The way I expect this to be is that this small photo actually takes the whole screen instead of only part of it
Comment 1 Nate Graham 2023-01-03 20:48:56 UTC
Spectacle was largely rewritten for the 23.04 release, so the code governing this has changes sufficiently that it's possible the issue has been fixed, or worsened.

I can't reproduce the issue with a multimonitor multi-scale setup on Wayland, so it does seem to be fixed, hopefully. Feel free to re-open this bug report if you find that it's not fixed for you once you upgrade to the 23.04 version in a few months.
Comment 2 ryu.ketsueki 2023-01-06 17:27:30 UTC
This happened with the rewrite. It was actually after I read about the rewrite that I wanted to test it. I would have replied if it still happens on my end but spectacle is crashing on my end and I can't get a backtrace for some reson. DrKonqi doesn't launch with the crash and trying to backtrace with gdb also doesn't return anything. Guess I'll have to wait until the next KDE Gear is released
Comment 3 ryu.ketsueki 2023-01-20 15:39:04 UTC
Created attachment 155457 [details]
A photo showing what is happening

I can confirm it is still happening in my case and it is the rewrite. Granted, it is the KDE Unstable Repos for Tumbleweed so I didn't compile it myself but the package version is as follows:

22.11.70git.20230119T021936~7d04f7c-ku.38.1

I think that means it was compiled and packaged yesterday (January 19th, 2023) with the 7d04f7c commit (I think). Same result as before.
Comment 4 Nate Graham 2023-01-20 21:55:56 UTC
OK, thanks!
Comment 5 ryu.ketsueki 2023-04-09 21:15:11 UTC
Has there been any progress in figuring out or fixing this? I'm on the version 23.03.90 of Spectacle through KDE Repos for openSUSE and situation looks exactly the same?
Comment 6 Noah Davis 2023-04-11 14:55:01 UTC
(In reply to ryu.ketsueki from comment #5)
> Has there been any progress in figuring out or fixing this? I'm on the
> version 23.03.90 of Spectacle through KDE Repos for openSUSE and situation
> looks exactly the same?

I couldn't reproduce this.
Comment 7 Noah Davis 2023-04-11 14:56:08 UTC
I tried to test this on a setup using 2 monitors. One 1920x1080@1x screen, one 3840x2160@2x screen.
Comment 8 ryu.ketsueki 2023-04-11 19:37:05 UTC
(In reply to Noah Davis from comment #7)
> I tried to test this on a setup using 2 monitors. One 1920x1080@1x screen,
> one 3840x2160@2x screen.

Try setting to 70% on Wayland. It's my current setting
Comment 9 Noah Davis 2023-04-11 22:28:24 UTC
(In reply to ryu.ketsueki from comment #8)
> (In reply to Noah Davis from comment #7)
> > I tried to test this on a setup using 2 monitors. One 1920x1080@1x screen,
> > one 3840x2160@2x screen.
> 
> Try setting to 70% on Wayland. It's my current setting

OK, it seem that the fractional scale factors are the cause, not the screen layout.
Comment 10 Noah Davis 2023-04-11 22:34:39 UTC
(In reply to Noah Davis from comment #9)
> OK, it seem that the fractional scale factors are the cause, not the screen
> layout.

Also not scaling different from 100% in general. Integer scale factors work fine.
Comment 11 Noah Davis 2023-04-11 22:38:52 UTC
*** Bug 467855 has been marked as a duplicate of this bug. ***
Comment 12 ryu.ketsueki 2023-04-13 12:52:55 UTC
(In reply to Noah Davis from comment #9)
> OK, it seem that the fractional scale factors are the cause, not the screen
> layout.

That makes sense. I use KWin Wayland fractional scaling on my laptop because the elements are too big on a 1366x768 resolution display. It's one of the reasons I moved away from X11. Hopefully this can be fixed before next release
Comment 13 Alexander Yavorsky 2023-04-17 11:39:47 UTC
Faced the same issue: X window system and two monitors with fractional (125%) scale.
Comment 14 Noah Davis 2023-04-17 11:45:09 UTC
This should be fixed in commit a85343658e25cc64d09d00b485c5855be9c7c57a now, which should be in the 23.04 release version.
Comment 15 Noah Davis 2023-04-17 11:51:50 UTC
Actually, I just remembered it's only partly fixed. I may have mistakenly thought 2 separate issues were one.

This issue: There is a smaller image overlaid on top of the real image that shouldn't be there.

The other issue that was actually fixed: Exports from multi-monitor setups with scaling had weird gaps between screens and wrong selected areas.
Comment 16 Noah Davis 2023-04-17 11:56:12 UTC
(In reply to Noah Davis from comment #15)
> This issue: There is a smaller image overlaid on top of the real image that
> shouldn't be there.

I think I need to wake up. I misspoke, It's actually that the image isn't sized/positioned correctly, as Ryu and I said previously.
Comment 17 Bug Janitor Service 2023-04-17 12:17:43 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/spectacle/-/merge_requests/228
Comment 18 Noah Davis 2023-04-17 13:50:03 UTC
Git commit d0886c85445fad227b256152a549cb33bd97b776 by Noah Davis.
Committed on 17/04/2023 at 12:18.
Pushed by ndavis into branch 'master'.

Fix wrong image position in rectangle capture mode with scaling

M  +1    -1    src/Gui/Annotations/AnnotationDocument.cpp

https://invent.kde.org/graphics/spectacle/commit/d0886c85445fad227b256152a549cb33bd97b776
Comment 19 Noah Davis 2023-04-21 23:46:16 UTC
*** Bug 468785 has been marked as a duplicate of this bug. ***
Comment 20 Noah Davis 2023-04-24 16:53:47 UTC
*** Bug 468912 has been marked as a duplicate of this bug. ***
Comment 21 ryu.ketsueki 2023-04-24 20:29:43 UTC
Yeah, this fix didn't come with 23.04.0, apparently. But I also couldn't test the fix itself to see if it is truly fixed on my end.
Comment 22 Nate Graham 2023-04-25 15:35:34 UTC
Right, the "Version fixed in" field says "23.04.1"
Comment 23 Noah Davis 2023-04-26 18:13:37 UTC
*** Bug 469021 has been marked as a duplicate of this bug. ***
Comment 24 Noah Davis 2023-05-02 15:15:54 UTC
*** Bug 469262 has been marked as a duplicate of this bug. ***
Comment 25 Hexagon 2023-05-11 20:16:55 UTC
Thanks for the fix. Unfortunately the fix seems to not work for my monitor configuration. In my case the problem is still identical.
- I am using spectacle 23.04.1-1 from the Archlinux repository. 
- My left monitor is 2560x1440px with a scaling factor of 150%
- My center monitor is 3840x2160px with a scaling factor of 200%
- The artifact can be seen on the center monitor as screenshotted in a duplicate bug report of me: https://bugs.kde.org/show_bug.cgi?id=468912
Comment 26 indecisiveautomator 2023-05-11 20:45:26 UTC
The issue is also still affecting me with Spectacle 23.04.1.

My left-most display is 150% scaled, my other three displays are all unscaled 1080p displays. The issue I am experiencing is slightly different to the attachment on this issue, Bug 468785 has a screenshot (horizontal alignment is correct but vertical alignment is not).

In my case as well, I have my displays with three along the bottom and one at the top in the center. This has caused numerous issues with Plasma (pretty much all of which have since been fixed fwiw) so I am mentioning it in case this may also be relevant.
Comment 27 ryu.ketsueki 2023-05-12 13:03:03 UTC
(In reply to indecisiveautomator from comment #26)
> The issue is also still affecting me with Spectacle 23.04.1.
> 
> My left-most display is 150% scaled, my other three displays are all
> unscaled 1080p displays. The issue I am experiencing is slightly different
> to the attachment on this issue, Bug 468785 has a screenshot (horizontal
> alignment is correct but vertical alignment is not).
> 
> In my case as well, I have my displays with three along the bottom and one
> at the top in the center. This has caused numerous issues with Plasma
> (pretty much all of which have since been fixed fwiw) so I am mentioning it
> in case this may also be relevant.

Can confirm. Issue still occurs with me. Just updated to 23.04.1 and the problem still remains.
Comment 28 Noah Davis 2023-05-16 04:26:27 UTC
(In reply to Hexagon from comment #25)
> Thanks for the fix. Unfortunately the fix seems to not work for my monitor
> configuration. In my case the problem is still identical.
> - I am using spectacle 23.04.1-1 from the Archlinux repository. 
> - My left monitor is 2560x1440px with a scaling factor of 150%
> - My center monitor is 3840x2160px with a scaling factor of 200%
> - The artifact can be seen on the center monitor as screenshotted in a
> duplicate bug report of me: https://bugs.kde.org/show_bug.cgi?id=468912

I can't test your exact configuration since one of my screens only goes up to 1920x1080. Can you try setting the left screen to 1920x1080 at 150%? I was unable to reproduce the bug using 1920x1080 at 150% and 3840x2160 at 200%.
Comment 29 ryu.ketsueki 2023-05-16 09:36:42 UTC
(In reply to Noah Davis from comment #28)
> I can't test your exact configuration since one of my screens only goes up
> to 1920x1080. Can you try setting the left screen to 1920x1080 at 150%? I
> was unable to reproduce the bug using 1920x1080 at 150% and 3840x2160 at
> 200%.

By the way, scaling up is not the only thing that causes this bug. Scaling down also does it, at least for my case. The way I did it was that I have a 1366x768 display on my laptop. It's the max resolution possible with it. Things look too large here so I set the scaling to 70%. It works and the elements are smaller. In fact, they look closer to how they would be if this were a 1920x1080 display. But then I get that Spectacle bug.

Also no NVIDIA graphics here either. It's only an Intel UHD Graphics 620.
Comment 30 Hexagon 2023-05-16 14:49:59 UTC
(In reply to Noah Davis from comment #28)
> (In reply to Hexagon from comment #25)
> > Thanks for the fix. Unfortunately the fix seems to not work for my monitor
> > configuration. In my case the problem is still identical.
> > - I am using spectacle 23.04.1-1 from the Archlinux repository. 
> > - My left monitor is 2560x1440px with a scaling factor of 150%
> > - My center monitor is 3840x2160px with a scaling factor of 200%
> > - The artifact can be seen on the center monitor as screenshotted in a
> > duplicate bug report of me: https://bugs.kde.org/show_bug.cgi?id=468912
> 
> I can't test your exact configuration since one of my screens only goes up
> to 1920x1080. Can you try setting the left screen to 1920x1080 at 150%? I
> was unable to reproduce the bug using 1920x1080 at 150% and 3840x2160 at
> 200%.

Unfortunately Plasma does not let me set my monitor to 1920x1080. Although xrandr lists it as a supported option. On Windows I can set the monitor to 1920x1080. There seems to be a EDID problem. But I tried other combinations:

- Middle monitor always 3840x2160 at 200%
- Left monitor at 2560x1440 at 100% --> ok
- Left monitor at 2560x1440 at 125% --> ok
- Left monitor at 2560x1440 at 150%, 175% and 200% --> all of them problematic
- Left monitor at 1280x720 at 100%, 125%, 150%, 175% and 200% --> all of them problematic
- Left monitor at 800x600 at 100%, 125%, 150%, 175% and 200% --> all of them problematic
- Left monitor at 640x480 at 100%, 125%, 150%, 175% and 200% --> all of them problematic

So right now it seems almost all combinations are broken and only some are working.
Comment 31 Noah Davis 2023-05-16 16:32:19 UTC
(In reply to Hexagon from comment #30)
> (In reply to Noah Davis from comment #28)
> > (In reply to Hexagon from comment #25)
> > > Thanks for the fix. Unfortunately the fix seems to not work for my monitor
> > > configuration. In my case the problem is still identical.
> > > - I am using spectacle 23.04.1-1 from the Archlinux repository. 
> > > - My left monitor is 2560x1440px with a scaling factor of 150%
> > > - My center monitor is 3840x2160px with a scaling factor of 200%
> > > - The artifact can be seen on the center monitor as screenshotted in a
> > > duplicate bug report of me: https://bugs.kde.org/show_bug.cgi?id=468912
> > 
> > I can't test your exact configuration since one of my screens only goes up
> > to 1920x1080. Can you try setting the left screen to 1920x1080 at 150%? I
> > was unable to reproduce the bug using 1920x1080 at 150% and 3840x2160 at
> > 200%.
> 
> Unfortunately Plasma does not let me set my monitor to 1920x1080. Although
> xrandr lists it as a supported option. On Windows I can set the monitor to
> 1920x1080. There seems to be a EDID problem. But I tried other combinations:
> 
> - Middle monitor always 3840x2160 at 200%
> - Left monitor at 2560x1440 at 100% --> ok
> - Left monitor at 2560x1440 at 125% --> ok
> - Left monitor at 2560x1440 at 150%, 175% and 200% --> all of them
> problematic
> - Left monitor at 1280x720 at 100%, 125%, 150%, 175% and 200% --> all of
> them problematic
> - Left monitor at 800x600 at 100%, 125%, 150%, 175% and 200% --> all of them
> problematic
> - Left monitor at 640x480 at 100%, 125%, 150%, 175% and 200% --> all of them
> problematic
> 
> So right now it seems almost all combinations are broken and only some are
> working.

I was not able to test 1280x720 (screen just went black until the reset timer put the resolution back at the previous setting), but I could not reproduce the bug with 800x600 or 640x480 on my left screen. My right screen was still at 3840x2160 at 200%.
Comment 32 Hexagon 2023-05-16 16:45:10 UTC
Created attachment 159006 [details]
Spectacle scaling problem 800x600 at 150%

I just took this picture. Spectacle version "spectacle 23.04.1-1" in the Arch repository. Left monitor with 800x600 at 150%. Right with 3840x2160 at 200%. As one can see the overlap of the screen differs with different resolutions and scaling factors.
Comment 33 Noah Davis 2023-05-16 17:03:29 UTC
Created attachment 159008 [details]
800x600@150%, 3840x2160@200% for ndavis

This is how the same settings look for me.
Comment 34 Hexagon 2023-05-16 17:39:27 UTC
Hmm. Weird. I have no idea why it is working on your machine. Some more info: I am using an AMD GPU. Connected via Display Port. Using the Mesa driver.
Comment 35 Noah Davis 2023-05-16 19:56:21 UTC
(In reply to Hexagon from comment #34)
> Hmm. Weird. I have no idea why it is working on your machine. Some more
> info: I am using an AMD GPU. Connected via Display Port. Using the Mesa
> driver.

I am also using an AMD GPU (integrated Renoir) with the Mesa driver, but I am using HDMI for the right screen. I don't have a way to test DisplayPort with my laptop.
Comment 36 jesus 2023-06-20 08:00:06 UTC
I have the same issue still with 23.04.2 on Arch Linux. Display is 4k skaled to 150% connected via Display Port. I am using wayland.
Comment 37 Chema 2023-06-21 18:04:39 UTC
I have the same problem. I have the latest version of KDE and Spectacle:

Operating System: Manjaro Linux
KDE Plasma Version: 5.27.6
KDE Frameworks Version: 5.107.0
Qt Version: 5.15.10
Kernel Version: 6.3.8-4-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 8 × AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx
Memory: 29.3 GiB of RAM
Graphics Processor: AMD Radeon Vega 8 Graphics
Manufacturer: BESSTAR TECH LIMITED
Product Name: UM350

Spectacle: 23.04.2

I have recorded a video to my Google Drive so that the problem can be seen. You can see it at the following link, it will be available until this bug is resolved:

https://drive.google.com/file/d/1oNMH3jLnxXK7ePg8glF6iXBGb4vmYca-/view?usp=sharing

The display is using a resolution of 2560x1440 with a 90% of scaling. Observe how when Spectacle is going to capture a region of the screen, it is automatically rescaled producing a strange effect, and also what is captured is not what is seen on the rescaled screen, it is captured over 90%, not over the one that shown rescaled. Observe how the image captured in Spectacle does not correspond to the one that appears selected in the rescaled region on the screen.

On the other hand, when you add annotations to the image, they are also added incorrectly, when you copy the image with the annotations and paste it somewhere else, it looks like the frame I added doesn't appear in the same position as it does in Spectacle .
Comment 38 Rongrong 2023-06-28 16:40:25 UTC
Created attachment 159960 [details]
2880x1800@200%,2560x1440@115%

Same issue on Intel GPU. Spectacle 22.12.3 works totally fine in the same conditions.

Operating System: Debian GNU/Linux trixie/sid
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.107.0
Qt Version: 5.15.8
Kernel Version: 6.3.9-1-liquorix-amd64 (64-bit)
Graphics Platform: Wayland
Processors: 20 × 13th Gen Intel® Core™ i7-13700H
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® Graphics
Manufacturer: LENOVO
Product Name: 21HW
System Version: ThinkBook 14 G5+ IRH
Spectacle: 23.04.2

Output: 1 eDP-1 enabled connected priority 2 Panel Modes: 0:2880x1800@90*! ...... Geometry: 0,208 1440x900 Scale: 2 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: Full

Reproducible with below output 2 configurations.
Output: 2 DP-6 enabled connected priority 1 DisplayPort Modes: 0:2560x1440@75! 1:2560x1440@60* ...... Geometry: 1440,0 2226x1252 Scale: 1.15 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: Automatic (connected via a USB-C dock with integrated DP-alt-mode-to-HDMI converter)
Output: 2 HDMI-A-1 enabled connected priority 1 HDMI Modes: 0:2560x1440@75! 1:2560x1440@60* ...... Geometry: 1440,0 2226x1252 Scale: 1.15 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: Full (directly connected to the HDMI port on the laptop)
Output: 2 DP-3 enabled connected priority 1 DisplayPort Modes: 0:2560x1440@60! 1:2560x1440@75* ...... Geometry: 1440,0 2226x1252 Scale: 1.15 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: Automatic (connected via a passive USB-C-to-DP adaptor)
Comment 39 Chema 2023-07-07 00:00:14 UTC
I'm just writing to say that this bug continues to happen with Spectacle version 23.04.3.
Comment 40 Ilya Bizyaev 2023-07-10 19:50:12 UTC
*** Bug 470506 has been marked as a duplicate of this bug. ***
Comment 41 Ilya Bizyaev 2023-07-10 19:57:24 UTC
*** Bug 469518 has been marked as a duplicate of this bug. ***
Comment 42 Matthew Henry 2023-07-13 00:58:33 UTC
Not sure if it's any help, but I'm also encountering this issue.  It happens in any situation where the monitors are not in a multiple of 100% (ie 100, 200 are fine but 125% is not) for scaling.  I have 2 monitors: 1 4k 60 Hz and 1 4k 120 Hz.

Plasma version (wayland) is 5.27.6
Spectacle version is 23.04.3-1 (from arch repository)
Nvidia gpu (driver version: 535.54.03-1 3080 Ti)

Not sure what information would be useful to track down something like this.
Comment 43 Chema 2023-08-27 16:47:47 UTC
I just installed the new version of Spectacle, 23.0.8, and although in the release notes it says that this bug is resolved, the same thing is still happening (I just tried with 95% scaling and the exact same error is still happening ). The bug is certainly not fixed.
Comment 44 Chema 2023-08-27 23:31:19 UTC
I've been doing more testing on this bug, and I see that it occurs when the scaling percentage is less than 100%. If it's higher than 100%, it seems that Spectacle captures well, but if it's lower than 100% it produces the effect that you can see in the following video that I re-recorded with the latest version of Spectacle (23.08.0) , where you can see again the bug that I mention:

https://drive.google.com/file/d/1FJ2aGCJcmKC8p7RMaKtD0md6IxRHQl6d/view?usp=drivesdk
Comment 45 Ilya Bizyaev 2023-08-27 23:35:17 UTC
> it occurs when the scaling percentage is less than 100%. If it's higher than 100%, it seems that Spectacle captures well

FWIW I have this bug with both monitors set to 125% scaling.
Comment 46 Chema 2023-08-28 08:29:17 UTC
(In reply to Ilya Bizyaev from comment #45)
> FWIW I have this bug with both monitors set to 125% scaling.

I just tested with 125% and for me, with the new version 23.08.0, it works fine. As I say, the problem happens to me when the scaling percentage is less than 100%.
Comment 47 Altamush Nayyer Khan 2023-08-28 11:13:54 UTC
The bug appears to be gone for me.

I have my leftmost monitor at 110%, middle at 150%, and the rightmost at 125%.

I haven't marked this solved as some people are still having this bug.
Comment 48 Chema 2023-08-28 13:48:20 UTC
(In reply to Altamush Nayyer Khan from comment #47)
> The bug appears to be gone for me.
> 
> I have my leftmost monitor at 110%, middle at 150%, and the rightmost at
> 125%.
> 
> I haven't marked this solved as some people are still having this bug.

Altamush, please, can you try with a scaling less than 100%, for example 95% or 90% and let me know if it works for you? Please note if capturing the screen gives you a strange scaling effect (it happens as if part of the screen is automatically rescaled with another percentage).
Comment 49 Nate Graham 2023-08-28 19:26:30 UTC
Let's get a new bug report to track the issue with < 100% scaling, since that will have a different root cause.
Comment 50 Chema 2023-08-29 10:19:20 UTC
OK, if anyone is interested, the new bug that has been created for when using Spectacle with fractional scaling less than 100% is 473888.
Comment 51 ryu.ketsueki 2023-09-01 11:09:12 UTC
(In reply to Chema from comment #50)
> OK, if anyone is interested, the new bug that has been created for when
> using Spectacle with fractional scaling less than 100% is 473888.

That is strange. It's the bug I originally reported here because I'm having issues when scaling is less than 100%, not more. I set it to less because my current laptop top resolution is 1366x768, so things wind up too large.
Comment 52 Chema 2023-09-02 22:29:35 UTC
> That is strange. It's the bug I originally reported here because I'm having
> issues when scaling is less than 100%, not more. I set it to less because my
> current laptop top resolution is 1366x768, so things wind up too large.

The truth is that, indeed, the example that you mentioned and that opened this bug, was with a percentage less than 100%. Therefore, effectively, to be concise, this bug was not solved in the last update, therefore it should be reopened indicating that it has failed and the one that I opened a few days ago at Nate's indication should be closed since it would be duplicated with this one.

But whatever Nage says, whatever he thinks is best for this bug to be solved once and for all, because we've been dealing with it for I don't know how many months...

What I think has happened is that the developers have made a bit of a mess with the bug because many other people wrote in it that they had problems when the scaling was greater than 100%.

I think that as seen in the comments of the bug, it affected both percentages lower and higher than 100%. So effectively with version 23.08.0 it has been solved for percentages greater than 100%, but it remains for the lower ones...
Comment 53 Lynn 2023-09-09 02:23:12 UTC
Can confirm this issue still exists as of 23.04.3  
I have two 1920x1080p screens to the LEFT of my main 4k monitor and this issue persists.
If I put my 4K monitor at position 0,0, the visual bug disappears, but now it is out of sync with the physical location of my displays.
Comment 54 Noah Davis 2023-09-09 13:19:46 UTC
Greater than 100% fractional scaling should now be fixed on git master. Less than 100% fractional scaling currently still has issues.
Comment 55 Bug Janitor Service 2023-09-14 04:57:11 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/spectacle/-/merge_requests/264
Comment 56 Noah Davis 2023-09-14 22:20:35 UTC
Git commit 8df6051d8df630ee45c8c1f0e97124c518bec51f by Noah Davis.
Committed on 14/09/2023 at 06:59.
Pushed by ndavis into branch 'master'.

Fix rectangle screenshots with less than 100% UI scale

Fixes it by just doing a normal all screens grab instead of trying to
get an image for each screen and then trying to position and scale them
all correctly for the given platform. This should also be a bit more
efficient.

Also lays some of the ground work for rectangle video recording by
making SelectionEditor send a rectangle and export actions instead of an
image and export actions.
Related: bug 473888
FIXED-IN: 23.12.0

D  +0    -68   src/CanvasImage.h
M  +31   -72   src/Gui/Annotations/AnnotationDocument.cpp
M  +4    -13   src/Gui/Annotations/AnnotationDocument.h
M  +1    -7    src/Gui/SelectionEditor.cpp
M  +2    -0    src/Gui/SelectionEditor.h
M  +2    -3    src/Platforms/Platform.h
M  +9    -100  src/Platforms/PlatformKWin.cpp
M  +3    -26   src/Platforms/PlatformKWin.h
M  +6    -13   src/Platforms/PlatformXcb.cpp
M  +1    -1    src/Platforms/PlatformXcb.h
M  +9    -16   src/SpectacleCore.cpp
M  +0    -1    src/SpectacleCore.h

https://invent.kde.org/graphics/spectacle/-/commit/8df6051d8df630ee45c8c1f0e97124c518bec51f
Comment 57 Sandro Sauer 2023-09-18 07:57:40 UTC
Hi, I'm still facing this issue on 23.08.1 with X11 and scaling set to 125%.
I have two 2560x1440 monitors and one 3840x2160.

Setting the scaling to 100% fixes the issue, but is not an option for me, since text is too small.
Comment 58 Nate Graham 2023-09-18 13:36:03 UTC
As the "Version Fixed In" field says, this will be fixed in version 24.02.0.
Comment 59 Marco G 2023-09-26 09:26:31 UTC
23.08.1-0xneon+22.04+jammy+release+build21

Happens to me on all scales >100%.
Dual Monitor Setup:

```
➤ xrdb -query
*customization: -color
Xcursor.size:   36
Xcursor.theme:  Sweet-cursors
Xft.antialias:  1
Xft.dpi:        144
Xft.hinting:    1
Xft.hintstyle:  hintslight
Xft.rgba:       none

➤ xdpyinfo | grep dots
resolution:    144x144 dots per inch

➤ xrandr | grep -w connected
eDP-1 connected 2880x1800+0+180 (normal left inverted right x axis y axis) 302mm x 188mm
DP-1-1 connected primary 3840x2160+2880+0 (normal left inverted right x axis y axis) 697mm x 392mm
```
Comment 60 Nate Graham 2023-09-29 17:31:10 UTC
*** Bug 474954 has been marked as a duplicate of this bug. ***
Comment 61 Peter Szabo 2023-11-30 09:54:11 UTC
Apparently Kubuntu 23.10 still ships spectacle 23.08.1 :/


$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=23.10
DISTRIB_CODENAME=mantic
DISTRIB_DESCRIPTION="Ubuntu 23.10"

$ spectacle --version
spectacle 23.08.1
Comment 62 Nate Graham 2023-11-30 15:40:01 UTC
That's the latest released version. This bug is fixed in the upcoming but not released yet version.
Comment 63 Noah Davis 2023-12-21 21:02:32 UTC
*** Bug 474464 has been marked as a duplicate of this bug. ***