Bug 420158

Summary: When i use a pointer for a presentation brokens app
Product: kdeconnect Reporter: Quimey Marquez <qmarquez>
Component: commonAssignee: Albert Vaca <albertvaka>
Status: RESOLVED DUPLICATE    
Severity: crash CC: nicolas.fella
Priority: NOR Keywords: drkonqi
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Quimey Marquez 2020-04-16 14:02:19 UTC
Application: kdeconnectd (1.4.0)

Qt Version: 5.14.1
Frameworks Version: 5.69.0
Operating System: Linux 5.3.0-46-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.18

-- Information about the crash:
- What I was doing when the application crashed:

Just push the pointer button of the hadle presentation feature

The crash can be reproduced every time.

-- Backtrace:
Application: Demonio de KDE Connect (kdeconnectd), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7effa2252c80 (LWP 3822))]

Thread 5 (Thread 0x7eff4db84700 (LWP 13487)):
#0  0x00007eff9928406f in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007eff99284570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007eff992846dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007eff9f5a40db in QEventDispatcherGlib::processEvents (this=0x7eff48000ef0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007eff9f54363a in QEventLoop::exec (this=this@entry=0x7eff4db83d80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007eff9f354317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007eff8db4f605 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007eff9f3557ec in QThreadPrivate::start (arg=0x55c70a4e86d0) at thread/qthread_unix.cpp:342
#8  0x00007eff9b4226db in start_thread (arg=0x7eff4db84700) at pthread_create.c:463
#9  0x00007eff9ec4a88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7eff6272e700 (LWP 9424)):
#0  0x00007eff7df7d480 in pa_mutex_lock () from /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-11.1.so
#1  0x00007eff7e3e148b in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007eff7e3d2e40 in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007eff7e3d34d0 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007eff7e3d3560 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007eff7e3e13c9 in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007eff7df7e318 in ?? () from /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-11.1.so
#7  0x00007eff9b4226db in start_thread (arg=0x7eff6272e700) at pthread_create.c:463
#8  0x00007eff9ec4a88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7eff86346700 (LWP 3872)):
#0  0x00007eff9ec3dbf9 in __GI___poll (fds=0x7eff780029e0, nfds=1, timeout=10145) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007eff992845c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007eff992846dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007eff9f5a40db in QEventDispatcherGlib::processEvents (this=0x7eff78000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007eff9f54363a in QEventLoop::exec (this=this@entry=0x7eff86345da0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007eff9f354317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007eff9f3557ec in QThreadPrivate::start (arg=0x55c70a42a520) at thread/qthread_unix.cpp:342
#7  0x00007eff9b4226db in start_thread (arg=0x7eff86346700) at pthread_create.c:463
#8  0x00007eff9ec4a88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7eff87557700 (LWP 3868)):
#0  0x00007eff9ec390b4 in __GI___libc_read (fd=7, buf=0x7eff87556b60, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007eff992c92b0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007eff992840b7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007eff99284570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007eff992846dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007eff9f5a40db in QEventDispatcherGlib::processEvents (this=0x7eff80000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007eff9f54363a in QEventLoop::exec (this=this@entry=0x7eff87556d70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007eff9f354317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007eff9fa30555 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007eff9f3557ec in QThreadPrivate::start (arg=0x7eff9fca8da0) at thread/qthread_unix.cpp:342
#10 0x00007eff9b4226db in start_thread (arg=0x7eff87557700) at pthread_create.c:463
#11 0x00007eff9ec4a88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7effa2252c80 (LWP 3822)):
[KCrash Handler]
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
#7  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > > (ptr=...) at global/qglobal.h:1133
#8  QObject::d_func (this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:132
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7eff77dfbf82 "xPos", value=...) at kernel/qobject.cpp:4014
#10 0x00007eff77dfb3f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007effa1e504d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007eff9f57ffe7 in QtPrivate::QSlotObjectBase::call (a=0x7fff773c55e0, r=0x55c70a52fef0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#13 doActivate<false> (sender=0x55c70a52eeb0, signal_index=7, argv=0x7fff773c55e0) at kernel/qobject.cpp:3870
#14 0x00007eff9f57a8a2 in QMetaObject::activate (sender=sender@entry=0x55c70a52eeb0, m=m@entry=0x7effa206ea60 <DeviceLink::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff773c55e0) at kernel/qobject.cpp:3930
#15 0x00007effa1e59185 in DeviceLink::receivedPacket (this=this@entry=0x55c70a52eeb0, _t1=...) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/CSWKE6ESUK/moc_devicelink.cpp:225
#16 0x00007effa1e27318 in LanDeviceLink::dataReceived (this=0x55c70a52eeb0) at ./core/backends/lan/landevicelink.cpp:149
#17 0x00007eff9f57ffe7 in QtPrivate::QSlotObjectBase::call (a=0x7fff773c57a0, r=0x55c70a52eeb0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#18 doActivate<false> (sender=0x55c70a94df80, signal_index=3, argv=0x7fff773c57a0) at kernel/qobject.cpp:3870
#19 0x00007eff9f57a8a2 in QMetaObject::activate (sender=sender@entry=0x55c70a94df80, m=m@entry=0x7effa206e920 <SocketLineReader::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#20 0x00007effa1e58d80 in SocketLineReader::readyRead (this=this@entry=0x55c70a94df80) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/T4CFMAPE73/moc_socketlinereader.cpp:139
#21 0x00007effa1e34316 in SocketLineReader::dataReceived (this=0x55c70a94df80) at ./core/backends/lan/socketlinereader.cpp:51
#22 0x00007eff9f57ffe7 in QtPrivate::QSlotObjectBase::call (a=0x7fff773c58b0, r=0x55c70a94df80, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#23 doActivate<false> (sender=0x55c70a640ed0, signal_index=3, argv=0x7fff773c58b0) at kernel/qobject.cpp:3870
#24 0x00007eff9f57a8a2 in QMetaObject::activate (sender=sender@entry=0x55c70a640ed0, m=m@entry=0x7eff9fa0f380 <QIODevice::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#25 0x00007eff9f46ebf0 in QIODevice::readyRead (this=this@entry=0x55c70a640ed0) at .moc/moc_qiodevice.cpp:190
#26 0x00007eff9e5bf86d in QSslSocketBackendPrivate::transmit (this=0x55c70a53e940) at ssl/qsslsocket_openssl.cpp:1058
#27 0x00007eff9e59b761 in QSslSocket::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qsslsocket.cpp:181
#28 0x00007eff9f57fdc9 in doActivate<false> (sender=0x55c70a44afd0, signal_index=3, argv=0x7fff773c6a70) at kernel/qobject.cpp:3882
#29 0x00007eff9f57a8a2 in QMetaObject::activate (sender=sender@entry=0x55c70a44afd0, m=m@entry=0x7eff9fa0f380 <QIODevice::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#30 0x00007eff9f46ebf0 in QIODevice::readyRead (this=this@entry=0x55c70a44afd0) at .moc/moc_qiodevice.cpp:190
#31 0x00007eff9e565ff3 in QAbstractSocketPrivate::emitReadyRead (this=this@entry=0x55c70acbfc30, channel=channel@entry=0) at socket/qabstractsocket.cpp:1307
#32 0x00007eff9e56609c in QAbstractSocketPrivate::canReadNotification (this=0x55c70acbfc30) at socket/qabstractsocket.cpp:734
#33 0x00007eff9e5796b1 in QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1274
#34 0x00007effa095f8bc in QApplicationPrivate::notify_helper (this=this@entry=0x55c70a39bd10, receiver=receiver@entry=0x55c70a9b3ab0, e=e@entry=0x7fff773c6d90) at kernel/qapplication.cpp:3684
#35 0x00007effa0966ac0 in QApplication::notify (this=0x7fff773c7070, receiver=0x55c70a9b3ab0, e=0x7fff773c6d90) at kernel/qapplication.cpp:3430
#36 0x00007eff9f544db8 in QCoreApplication::notifyInternal2 (receiver=0x55c70a9b3ab0, event=0x7fff773c6d90) at kernel/qcoreapplication.cpp:1092
#37 0x00007eff9f544f8e in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7fff773c6d90) at kernel/qcoreapplication.cpp:1487
#38 0x00007eff9f5a4c88 in socketNotifierSourceDispatch (source=0x55c70a3f5f80) at kernel/qeventdispatcher_glib.cpp:107
#39 0x00007eff99284417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007eff99284650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007eff992846dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007eff9f5a40bc in QEventDispatcherGlib::processEvents (this=0x55c70a404b10, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#43 0x00007eff9f54363a in QEventLoop::exec (this=this@entry=0x7fff773c6fb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#44 0x00007eff9f54cdb0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1400
#45 0x000055c708a7258d in main (argc=<optimized out>, argv=<optimized out>) at ./daemon/kdeconnectd.cpp:180

Possible duplicates by query: bug 418844, bug 418595, bug 418076, bug 415425, bug 414913.

Reported using DrKonqi
Comment 1 Nicolas Fella 2020-04-18 09:48:19 UTC

*** This bug has been marked as a duplicate of bug 418076 ***