Bug 419784

Summary: KSysGuard crashes when try to close.
Product: [Applications] ksysguard Reporter: Francisco <francisco.mosquera>
Component: generalAssignee: KSysGuard Developers <ksysguard-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: jpalecek, plasma-bugs
Priority: NOR Keywords: drkonqi
Version: 5.18.4   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Francisco 2020-04-07 10:09:41 UTC
Application: ksysguard (5.18.4)

Qt Version: 5.14.1
Frameworks Version: 5.68.0
Operating System: Linux 5.3.0-45-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.18

-- Information about the crash:
- What I was doing when the application crashed:

Closing it.
Extra applications opened: 
	- Mail Client
	- Mozilla Firefox
	- WhatsDesk

The crash can be reproduced sometimes.

-- Backtrace:
Application: Monitor del sistema (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f91ab64fc00 (LWP 14448))]

Thread 3 (Thread 0x7f916ffff700 (LWP 14452)):
#0  0x00007f91aaf2bbf9 in __GI___poll (fds=0x7f9168002de0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f919896c5c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f919896c6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f91a67930db in QEventDispatcherGlib::processEvents (this=0x7f9168000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f91a673263a in QEventLoop::exec (this=this@entry=0x7f916fffe970, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f91a6543317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007f91a6ec0555 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f91a65447ec in QThreadPrivate::start (arg=0x7f91a7138da0) at thread/qthread_unix.cpp:342
#8  0x00007f919a8ed6db in start_thread (arg=0x7f916ffff700) at pthread_create.c:463
#9  0x00007f91aaf3888f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f9176304700 (LWP 14451)):
#0  0x00007f919a8f39f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x56452bab3928) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x56452bab38d8, cond=0x56452bab3900) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x56452bab3900, mutex=0x56452bab38d8) at pthread_cond_wait.c:655
#3  0x00007f917763decb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f917763dac7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f919a8ed6db in start_thread (arg=0x7f9176304700) at pthread_create.c:463
#6  0x00007f91aaf3888f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f91ab64fc00 (LWP 14448)):
[KCrash Handler]
#6  0x00007f91a65ccd4a in operator== (s1=..., s2=...) at text/qstring.cpp:3383
#7  0x00007f91a7c82205 in QLabel::setText (this=0x56452bf01970, text=...) at widgets/qlabel.cpp:287
#8  0x00007f91ab27b170 in TopLevel::answerReceived (this=0x56452be3c750, id=<optimized out>, answerList=...) at ./gui/ksysguard.cpp:466
#9  0x00007f91aa2c6b8a in KSGRD::SensorAgent::processAnswer(char const*, int) () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007f91aa2cde24 in ?? () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007f91a676efe7 in QtPrivate::QSlotObjectBase::call (a=0x7ffe78decc30, r=0x56452bee0bf0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#12 doActivate<false> (sender=0x56452be98400, signal_index=15, argv=0x7ffe78decc30) at kernel/qobject.cpp:3870
#13 0x00007f91a67698a2 in QMetaObject::activate (sender=sender@entry=0x56452be98400, m=m@entry=0x7f91a6bff7e0 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7ffe78decc30) at kernel/qobject.cpp:3930
#14 0x00007f91a66a22ba in QProcess::readyReadStandardOutput (this=this@entry=0x56452be98400, _t1=...) at .moc/moc_qprocess.cpp:367
#15 0x00007f91a66a8b11 in QProcessPrivate::tryReadFromChannel (this=0x56452bee36c0, channel=0x56452bee37d0) at io/qprocess.cpp:1073
#16 0x00007f91a66a8fe0 in QProcessPrivate::_q_canReadStandardOutput (this=<optimized out>) at io/qprocess.cpp:1084
#17 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffe78decde0) at .moc/moc_qprocess.cpp:208
#18 0x00007f91a676edc9 in doActivate<false> (sender=0x56452beb5bd0, signal_index=3, argv=0x7ffe78decde0) at kernel/qobject.cpp:3882
#19 0x00007f91a67698a2 in QMetaObject::activate (sender=sender@entry=0x56452beb5bd0, m=m@entry=0x7f91a6c01bc0 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe78decde0) at kernel/qobject.cpp:3930
#20 0x00007f91a67725c8 in QSocketNotifier::activated (this=this@entry=0x56452beb5bd0, _t1=<optimized out>, _t2=...) at .moc/moc_qsocketnotifier.cpp:141
#21 0x00007f91a6772982 in QSocketNotifier::event (this=0x56452beb5bd0, e=0x7ffe78ded0b0) at kernel/qsocketnotifier.cpp:266
#22 0x00007f91a7b4e8bc in QApplicationPrivate::notify_helper (this=this@entry=0x56452ba55fc0, receiver=receiver@entry=0x56452beb5bd0, e=e@entry=0x7ffe78ded0b0) at kernel/qapplication.cpp:3684
#23 0x00007f91a7b55ac0 in QApplication::notify (this=0x7ffe78ded3a0, receiver=0x56452beb5bd0, e=0x7ffe78ded0b0) at kernel/qapplication.cpp:3430
#24 0x00007f91a6733db8 in QCoreApplication::notifyInternal2 (receiver=0x56452beb5bd0, event=0x7ffe78ded0b0) at kernel/qcoreapplication.cpp:1092
#25 0x00007f91a6733f8e in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7ffe78ded0b0) at kernel/qcoreapplication.cpp:1487
#26 0x00007f91a6793c88 in socketNotifierSourceDispatch (source=0x56452baa36a0) at kernel/qeventdispatcher_glib.cpp:107
#27 0x00007f919896c417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f919896c650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f919896c6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f91a67930bc in QEventDispatcherGlib::processEvents (this=0x56452bab1a20, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#31 0x00007f91a673263a in QEventLoop::exec (this=this@entry=0x7ffe78ded2d0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#32 0x00007f91a673bdb0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1400
#33 0x00007f91ab27d07a in kdemain (argc=<optimized out>, argv=<optimized out>) at ./gui/ksysguard.cpp:627
#34 0x00007f91aae38b97 in __libc_start_main (main=0x564529c95720 <main>, argc=1, argv=0x7ffe78ded4e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe78ded4d8) at ../csu/libc-start.c:310
#35 0x0000564529c9575a in _start ()

Possible duplicates by query: bug 419229, bug 418491, bug 418449, bug 416379, bug 415503.

Reported using DrKonqi
Comment 1 Jiri Palecek 2020-04-26 21:22:38 UTC

*** This bug has been marked as a duplicate of bug 350140 ***