Bug 395937

Summary: Discard error messages ending with the string ".knsrc: All categories missing"
Product: Discover Reporter: Nate Graham <nate>
Component: discoverAssignee: Aleix Pol <aleixpol>
Status: RESOLVED FIXED    
Severity: normal CC: bugseforuns, karl, oysteins.omsetting, rdieter
Priority: NOR Keywords: usability
Version: 5.13.2   
Target Milestone: ---   
Platform: Other   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=390922
Latest Commit: Version Fixed In: 5.15.0

Description Nate Graham 2018-06-27 21:22:55 UTC
Because of Bug 395718, .knsrc files that are removed or renamed, often don't get properly deleted from users' systems by their distro's packaging. This eventually leads to errors from invalid links in those files that Discover dutifully passes along.

We've gotten a *ton* of bug reports about this that are benign but annoying for our users, and aren't actionable for us. I'd like to propose discarding any error message ending with the string ".knsrc: All categories missing" so that we can stop this cycle of madness! :)
Comment 1 Nate Graham 2018-06-27 21:23:24 UTC

*** This bug has been marked as a duplicate of bug 395934 ***
Comment 2 Nate Graham 2018-06-27 21:25:45 UTC
*** Bug 395934 has been marked as a duplicate of this bug. ***
Comment 3 Aleix Pol 2018-10-11 23:09:59 UTC
This is already the case.
Comment 4 Karl Ove Hufthammer 2018-10-13 08:56:01 UTC
Reopening. I still observe this bug in Plasma 5.14.0 and in the latest Git version of Discover (‘master’ branch).
Comment 5 Aleix Pol 2018-10-16 11:30:12 UTC
knewstuff now translates the error message so we can't compare to it. Will have to find an alternative fix.
Comment 6 Nate Graham 2018-11-13 11:05:37 UTC
author	Dan Leinir Turthra Jensen <admin@leinir.dk>	2018-11-13 09:07:53 (GMT)
committer	Dan Leinir Turthra Jensen <admin@leinir.dk>	2018-11-13 09:07:53 (GMT)
commit	7f6caf385809ce8c8087d8e56e9f3c6bd8c9170a (patch)
tree	074d756135914d65ef5993b133ee53a2ae2f4a0a
parent	d783ebd003c9ffc66a0fdd5aca28045f10bf9937 (diff)
Better error handling in KNewStuff backendHEADmaster
Previously error handling was done using a string matching method,
as that was all KNewStuffCore offered. A newly modified
KNewStuffCore error signal (found in D16665) gives much better
opportunities to handle error conditions, and this patch modifies
the old functionality in Discover's KNewStuff backend to take
advantage of this.

Differential Revision: https://phabricator.kde.org/D16776
BUG: 395937