Bug 389469

Summary: Grouped tasks have an extra thumbnail in the tooltip after plasmashell has been restarted at least once
Product: plasmashell Reporter: Antonio Rojas <arojas>
Component: Task Manager and Icons-Only Task ManagerAssignee: Eike Hein <hein>
Status: RESOLVED FIXED    
Severity: normal CC: bugseforuns, david.cortes.rivera, nate, noahadvs, plasma-bugs, rlkron2, yves.brungard_mageia
Priority: NOR    
Version: 5.12.0   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Screenshot

Description Antonio Rojas 2018-01-26 16:45:26 UTC
For grouped tasks (several instances of the same application) one of the thumbnails in the tooltip is duplicated.
Comment 1 Antonio Rojas 2018-01-26 17:42:05 UTC
Broken in b40c0de099fc951dbe3423b99310e7c7f799c8c4
Comment 2 Antonio Rojas 2018-02-08 19:32:35 UTC
More info: this only happen after killing and restarting plasmashell. In a new session it works fine (until you restart plasmashell).
Comment 3 Patrick Silva 2018-02-14 10:32:50 UTC
related
https://bugs.kde.org/show_bug.cgi?id=390412
Comment 4 Antonio Rojas 2018-02-14 10:37:28 UTC
*** Bug 390412 has been marked as a duplicate of this bug. ***
Comment 5 Randy Kron 2018-02-19 01:29:01 UTC
Created attachment 110799 [details]
Screenshot

I see this also. New sessions are OK, but it's there after you kill and restart plasmashell. Also, if you click the close button on the phantom item, all the windows close.
Comment 6 Antonio Rojas 2018-02-28 23:02:48 UTC
*** Bug 391247 has been marked as a duplicate of this bug. ***
Comment 7 Eike Hein 2018-03-06 09:57:35 UTC
*** Bug 391455 has been marked as a duplicate of this bug. ***
Comment 8 David 2018-03-06 12:31:03 UTC
Small comment: sometimes it also happens without plasmashell crashing beforehand, and also happens sometimes after kwin crashes rather than plasmashell.
Comment 9 Papoteur 2018-04-21 20:10:01 UTC
I'm also affected by the problem.
The duplicated thumbnail has no title, no effect. It's not always the same and can be an icon or the thumbnail of another application.
With Plasma 5.12.2
Comment 10 Papoteur 2018-04-25 09:36:11 UTC
The problem is also reported here:
https://bugs.mageia.org/show_bug.cgi?id=22715

For me, I don't observe any scrash. This behavior occurs since the start of the session.
I don't understand why the status is still unconfirmed.
Comment 11 Antonio Rojas 2018-05-14 20:59:37 UTC
I can no longer reproduce this in 5.12.5 (Frameworks 5.46)
Comment 12 Nate Graham 2018-05-14 21:58:57 UTC
Me neither, nor with Plasma 5.13 and Frameworks 5.47 (both built from source). Let's call this fixed and re-open it if we get any other reports from later versions.
Comment 13 Eike Hein 2018-06-19 11:23:18 UTC
Git commit 24803dc9dc4000e06edb60a3a8afe5925f0d72d7 by Eike Hein.
Committed on 19/06/2018 at 11:22.
Pushed by hein into branch 'Plasma/5.12'.

Fix tooltip woes

Summary:
Users have reported a number of bugs against TM tooltips, e.g. initially
coming up with crazy sizes, or showing window duplicates. This all comes
down to a race conditions causing stale data and ugly code that's using
visible props to swap between two alternate UI implementations instead
of doing clean conditional loading.

With this cleanup patch the problems should be gone, as well as various
ReferenceErrors spewed onto the tty.
Related: bug 382571, bug 385947, bug 388749

Reviewers: broulik, davidedmundson, romangg

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D13602

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +27   -11   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/24803dc9dc4000e06edb60a3a8afe5925f0d72d7
Comment 14 David Edmundson 2018-06-20 07:26:02 UTC
Git commit 1ab6ae9a8a36068294c487896dd512c693332b08 by David Edmundson.
Committed on 20/06/2018 at 07:16.
Pushed by davidedmundson into branch 'Plasma/5.12'.

Revert "Fix tooltip woes"

This reverts commit 24803dc9dc4000e06edb60a3a8afe5925f0d72d7.

Even though this commit is perfectly sensible it seems to introduce a
crash on startup for Qt 5.10.

Will revert for now, we can revisit later
Related: bug 382571, bug 385947, bug 388749

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +11   -27   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/1ab6ae9a8a36068294c487896dd512c693332b08
Comment 15 Eike Hein 2018-06-22 21:06:46 UTC
Git commit 1e218b405bee4d75a5d26a4c28da2724d967953a by Eike Hein.
Committed on 22/06/2018 at 21:05.
Pushed by hein into branch 'Plasma/5.12'.

Fix tooltip woes

Summary:
Users have reported a number of bugs against TM tooltips, e.g. initially
coming up with crazy sizes, or showing window duplicates. This all comes
down to a race conditions causing stale data and ugly code that's using
visible props to swap between two alternate UI implementations instead
of doing clean conditional loading.

With this cleanup patch the problems should be gone, as well as various
ReferenceErrors spewed onto the tty.
Related: bug 382571, bug 385947, bug 388749

Reviewers: broulik, davidedmundson, romangg

Reviewed By: davidedmundson

Subscribers: rikmills, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D13602

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +33   -18   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/1e218b405bee4d75a5d26a4c28da2724d967953a