Bug 391247 - When multiple instances of an app are running, tooltip shows one extra window
Summary: When multiple instances of an app are running, tooltip shows one extra window
Status: RESOLVED DUPLICATE of bug 389469
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Icons-only Task Manager (show other bugs)
Version: 5.12.2
Platform: Ubuntu Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-28 22:42 UTC by Nate Graham
Modified: 2018-02-28 23:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Two Dolphin instances, three windows in the tooltip (476.04 KB, image/png)
2018-02-28 22:42 UTC, Nate Graham
Details
Two Kate instances, three windows in the tooltip (376.25 KB, image/png)
2018-02-28 22:43 UTC, Nate Graham
Details
Four Firefox instances, five windows in the tooltip (718.88 KB, image/png)
2018-02-28 22:43 UTC, Nate Graham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2018-02-28 22:42:36 UTC
Created attachment 111099 [details]
Two Dolphin instances, three windows in the tooltip

Plasma 5.12.2

Steps to reproduce:
1. Use an Icons-Only Task Manager
2. Open any non-running app
4. Start a new instance using any method
5. Mouse over the app's icon in your Icons-Only Task Manager

The tooltip shows three windows, not two. See attached screenshot. One of the windows in the tooltip doesn't do anything (the other two correctly switch bwteeen Dolphin windows).

If you open a third instance, then the tooltip shows four windows, and so on. It's quite reproducible.

I can reproduce this with Dolphin, Kate, Firefox, Konsole, and any other app that supports having multiple instances running at the same time.
Comment 1 Nate Graham 2018-02-28 22:43:02 UTC
Created attachment 111100 [details]
Two Kate instances, three windows in the tooltip
Comment 2 Nate Graham 2018-02-28 22:43:25 UTC
Created attachment 111101 [details]
Four Firefox instances, five windows in the tooltip
Comment 3 Antonio Rojas 2018-02-28 23:02:48 UTC

*** This bug has been marked as a duplicate of bug 389469 ***