Bug 382571

Summary: Icon pinned to task manager shows wide tooltip in just started plasma session
Product: plasmashell Reporter: Patrick Silva <bugseforuns>
Component: Task Manager and Icons-Only Task ManagerAssignee: Eike Hein <hein>
Status: RESOLVED FIXED    
Severity: normal CC: kde, nate, petr.nehez, plasma-bugs, rootlexx, subdiff
Priority: NOR    
Version: 5.13.0   
Target Milestone: 1.0   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: wide tooltip

Description Patrick Silva 2017-07-21 15:51:30 UTC
Created attachment 106782 [details]
wide tooltip

pin any icon to your task manager
restart your plasma session
mouseover your pinned icon
See my screenshot
Comment 1 Eike Hein 2017-07-21 16:00:37 UTC

*** This bug has been marked as a duplicate of bug 380432 ***
Comment 2 Patrick Silva 2017-07-21 16:56:39 UTC
this report is not a duplicate or 380432 is not fixed in plasma 5.10.4.
The problem reported here happens on Arch running plasma 5.10.4.
Comment 3 Eike Hein 2017-07-21 17:06:45 UTC
True, thanks for catching.

Kai?
Comment 4 Eike Hein 2017-07-21 17:07:10 UTC
I guess the icon's now right but the dialog sizing code wasn't adjusted.
Comment 5 Kai Uwe Broulik 2017-07-25 20:38:45 UTC
I've occasionally seen this happening with Plasma tooltips in general but I cannot reproduce it as consistently as this bug describes. (I don't know how up to date this system here is, so I might not have the patch here that I added in Bug 380432, need to check again)
Comment 6 David Edmundson 2017-09-12 06:03:47 UTC
*** Bug 384600 has been marked as a duplicate of this bug. ***
Comment 7 Roman Gilg 2017-09-12 09:00:48 UTC
Potential fix: https://phabricator.kde.org/D7769

Maybe you can test it out Dr. Chapatin?
Comment 8 Patrick Silva 2017-09-12 12:31:06 UTC
(In reply to Roman Gilg from comment #7)
> Potential fix: https://phabricator.kde.org/D7769
> 
> Maybe you can test it out Dr. Chapatin?

Sorry, I have no technical knowledge to test patches.
Comment 9 Patrick Silva 2017-10-14 20:07:03 UTC
It's not happening anymore on Arch, plasma 5.11, frameworks 5.39.
Comment 10 Patrick Silva 2017-10-14 21:18:47 UTC
My mistake, just happened. It's not so easy reproduce it.
Comment 11 Nate Graham 2017-12-13 20:24:19 UTC
*** Bug 385947 has been marked as a duplicate of this bug. ***
Comment 12 Patrick Silva 2018-01-18 16:51:34 UTC
reproducible in plasma 5.12 beta, Arch Linux.
Comment 13 Nate Graham 2018-05-01 19:12:22 UTC
*** Bug 393717 has been marked as a duplicate of this bug. ***
Comment 14 Patrick Silva 2018-06-12 18:38:07 UTC
Reproducible on Arch Linux ruuning plasma 5.13 when I have two or more icons pinned to my plasma panel. Tooltip width increases according amount of pinned icons.
Comment 15 Eike Hein 2018-06-13 08:11:06 UTC
That last bit of information was critical. I can reproduce now.
Comment 16 Eike Hein 2018-06-19 11:23:19 UTC
Git commit 24803dc9dc4000e06edb60a3a8afe5925f0d72d7 by Eike Hein.
Committed on 19/06/2018 at 11:22.
Pushed by hein into branch 'Plasma/5.12'.

Fix tooltip woes

Summary:
Users have reported a number of bugs against TM tooltips, e.g. initially
coming up with crazy sizes, or showing window duplicates. This all comes
down to a race conditions causing stale data and ugly code that's using
visible props to swap between two alternate UI implementations instead
of doing clean conditional loading.

With this cleanup patch the problems should be gone, as well as various
ReferenceErrors spewed onto the tty.
Related: bug 385947, bug 389469, bug 388749

Reviewers: broulik, davidedmundson, romangg

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D13602

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +27   -11   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/24803dc9dc4000e06edb60a3a8afe5925f0d72d7
Comment 17 David Edmundson 2018-06-20 07:26:02 UTC
Git commit 1ab6ae9a8a36068294c487896dd512c693332b08 by David Edmundson.
Committed on 20/06/2018 at 07:16.
Pushed by davidedmundson into branch 'Plasma/5.12'.

Revert "Fix tooltip woes"

This reverts commit 24803dc9dc4000e06edb60a3a8afe5925f0d72d7.

Even though this commit is perfectly sensible it seems to introduce a
crash on startup for Qt 5.10.

Will revert for now, we can revisit later
Related: bug 385947, bug 389469, bug 388749

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +11   -27   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/1ab6ae9a8a36068294c487896dd512c693332b08
Comment 18 Eike Hein 2018-06-22 21:06:46 UTC
Git commit 1e218b405bee4d75a5d26a4c28da2724d967953a by Eike Hein.
Committed on 22/06/2018 at 21:05.
Pushed by hein into branch 'Plasma/5.12'.

Fix tooltip woes

Summary:
Users have reported a number of bugs against TM tooltips, e.g. initially
coming up with crazy sizes, or showing window duplicates. This all comes
down to a race conditions causing stale data and ugly code that's using
visible props to swap between two alternate UI implementations instead
of doing clean conditional loading.

With this cleanup patch the problems should be gone, as well as various
ReferenceErrors spewed onto the tty.
Related: bug 385947, bug 389469, bug 388749

Reviewers: broulik, davidedmundson, romangg

Reviewed By: davidedmundson

Subscribers: rikmills, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D13602

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +33   -18   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/1e218b405bee4d75a5d26a4c28da2724d967953a