Bug 380432 - Icons pinned to task manager have huge tooltip
Summary: Icons pinned to task manager have huge tooltip
Status: CLOSED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.10.0
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
: 380958 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-01 15:28 UTC by Patrick Silva
Modified: 2018-03-07 18:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.10.4


Attachments
screenshot (436.49 KB, image/png)
2017-06-01 15:28 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2017-06-01 15:28:08 UTC
Created attachment 105823 [details]
screenshot

See the screenshot please.
I'm running plasma 5.10 on Arch.
Comment 1 Eike Hein 2017-06-02 06:42:22 UTC
That's, well, interesting ... currently no idea.
Comment 2 Kai Uwe Broulik 2017-06-02 06:44:04 UTC
Might have been related to the implicit size thing in IconItem? What plasma-framework version is this?
Comment 3 Patrick Silva 2017-06-02 14:46:42 UTC
plasma-framework 5.34.
Comment 4 Eike Hein 2017-06-08 08:36:03 UTC
*** Bug 380958 has been marked as a duplicate of this bug. ***
Comment 5 Petr Nehez 2017-07-17 11:18:51 UTC
FYI I am using Ultra Flat Icons (https://store.kde.org/p/1171748/ - my [bug #380958](https://bugs.kde.org/show_bug.cgi?id=380958) ).
Comment 6 Kai Uwe Broulik 2017-07-17 11:48:33 UTC
I can confirm with Ultra-Flat-Icons
Comment 7 Kai Uwe Broulik 2017-07-17 11:52:06 UTC
Patch https://phabricator.kde.org/D6751
Comment 8 Kai Uwe Broulik 2017-07-17 14:17:46 UTC
Git commit d28deb6f4ab2f9e03b90f8e257145ffd793cb15d by Kai Uwe Broulik.
Committed on 17/07/2017 at 14:15.
Pushed by broulik into branch 'Plasma/5.10'.

[Task Manager] Fix icon size in launcher tooltips

Depending on icon theme the implicit size of the icon may be huge.
FIXED-IN: 5.10.4

Differential Revision: https://phabricator.kde.org/D6751

M  +2    -0    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/d28deb6f4ab2f9e03b90f8e257145ffd793cb15d
Comment 9 Eike Hein 2017-07-21 16:00:37 UTC
*** Bug 382571 has been marked as a duplicate of this bug. ***
Comment 10 Petr Nehez 2017-07-25 04:50:05 UTC
I can confirm that this is not happening anymore.
Comment 11 Petr Nehez 2017-07-25 04:50:23 UTC
I can confirm that this is not happening anymore.