Bug 374002

Summary: kwin_x11 crash every time I login
Product: kwin Reporter: Staffan Palmroos <spalmroos>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 5.8.3   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Staffan Palmroos 2016-12-21 20:32:15 UTC
Application: kwin_x11 (5.8.3)
 (Compiled from sources)
Qt Version: 5.6.2
Frameworks Version: 5.26.0
Operating System: Linux 4.8.15-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

Logging in to KDE crashes kwin_x11 every time. I think this is related to bug #361236 but DrKonqi doesn't seem to allow me to add to that report. I just wanted to upload my backtrace in case it's helpful.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
84	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f3de80e1800 (LWP 3882))]

Thread 5 (Thread 0x7f3dd0b7b700 (LWP 3923)):
#0  0x00007f3de79d7243 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f3de58bb246 in qt_safe_select (nfds=8, fdread=fdread@entry=0x7f3dc4000a78, fdwrite=fdwrite@entry=0x7f3dc4000d08, fdexcept=fdexcept@entry=0x7f3dc4000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:65
#2  0x00007f3de58bc9f2 in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f3dc4000f98, writefds=0x7f3dc4000d08, readfds=0x7f3dc4000a78, nfds=<optimized out>, this=0x7f3dc40008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f3dc40008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f3de58bcfa4 in QEventDispatcherUNIX::processEvents (this=0x7f3dc40008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f3de586f53a in QEventLoop::exec (this=this@entry=0x7f3dd0b7ad70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:206
#6  0x00007f3de56bd9bd in QThread::exec (this=this@entry=0x7f3de8268580 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#7  0x00007f3de81fa276 in QDBusConnectionManager::run (this=0x7f3de8268580 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:189
#8  0x00007f3de56c2323 in QThreadPrivate::start (arg=0x7f3de8268580 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:365
#9  0x00007f3de7c974e0 in start_thread (arg=0x7f3dd0b7b700) at pthread_create.c:334
#10 0x00007f3de79de82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f3dc9ea5700 (LWP 3947)):
#0  0x00007f3de79d7243 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f3de58bb246 in qt_safe_select (nfds=13, fdread=fdread@entry=0x7f3db8000a78, fdwrite=fdwrite@entry=0x7f3db8000d08, fdexcept=fdexcept@entry=0x7f3db8000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:65
#2  0x00007f3de58bc9f2 in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f3db8000f98, writefds=0x7f3db8000d08, readfds=0x7f3db8000a78, nfds=<optimized out>, this=0x7f3db80008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f3db80008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f3de58bcfa4 in QEventDispatcherUNIX::processEvents (this=0x7f3db80008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f3de586f53a in QEventLoop::exec (this=this@entry=0x7f3dc9ea4d80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:206
#6  0x00007f3de56bd9bd in QThread::exec (this=this@entry=0x1e34090) at thread/qthread.cpp:500
#7  0x00007f3de0878ca6 in QQmlThreadPrivate::run (this=0x1e34090) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f3de56c2323 in QThreadPrivate::start (arg=0x1e34090) at thread/qthread_unix.cpp:365
#9  0x00007f3de7c974e0 in start_thread (arg=0x7f3dc9ea5700) at pthread_create.c:334
#10 0x00007f3de79de82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f3dc8dec700 (LWP 3995)):
#0  pthread_cond_wait () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f3de4a77f65 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f3de4b61e40 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f3de4a77fa9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f3de7c974e0 in start_thread (arg=0x7f3dc8dec700) at pthread_create.c:334
#4  0x00007f3de79de82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f3dbffbe700 (LWP 4390)):
#0  0x00007f3de79d7243 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f3de58bb246 in qt_safe_select (nfds=15, fdread=fdread@entry=0x7f3d34000a58, fdwrite=fdwrite@entry=0x7f3d34000ce8, fdexcept=fdexcept@entry=0x7f3d34000f78, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:65
#2  0x00007f3de58bc9f2 in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f3d34000f78, writefds=0x7f3d34000ce8, readfds=0x7f3d34000a58, nfds=<optimized out>, this=0x7f3d340ce270) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f3d340008c0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f3de58bcfa4 in QEventDispatcherUNIX::processEvents (this=0x7f3d340ce270, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f3de586f53a in QEventLoop::exec (this=this@entry=0x7f3dbffbdd80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:206
#6  0x00007f3de56bd9bd in QThread::exec (this=this@entry=0x1bff310) at thread/qthread.cpp:500
#7  0x00007f3de0878ca6 in QQmlThreadPrivate::run (this=0x1bff310) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f3de56c2323 in QThreadPrivate::start (arg=0x1bff310) at thread/qthread_unix.cpp:365
#9  0x00007f3de7c974e0 in start_thread (arg=0x7f3dbffbe700) at pthread_create.c:334
#10 0x00007f3de79de82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f3de80e1800 (LWP 3882)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f3dbefbf320) at ../../src/qml/jsruntime/qv4value_p.h:372
#7  QQmlBinding::write (this=this@entry=0x2b23830, core=..., result=..., isUndefined=<optimized out>, flags=...) at qml/qqmlbinding.cpp:257
#8  0x00007f3de086482d in QQmlBinding::update (this=0x2b23830, flags=...) at qml/qqmlbinding.cpp:191
#9  0x00007f3de086e61f in QQmlObjectCreator::finalize (this=0x2b15f00, interrupt=...) at qml/qqmlobjectcreator.cpp:1219
#10 0x00007f3de07f3548 in QQmlComponentPrivate::complete (enginePriv=0x1efbde0, state=0x1ebd500) at qml/qqmlcomponent.cpp:922
#11 0x00007f3de07f3617 in QQmlComponentPrivate::completeCreate (this=0x1ebd460) at qml/qqmlcomponent.cpp:958
#12 0x00007f3de07f6331 in QQmlComponent::completeCreate (this=0x1ecf0a0) at qml/qqmlcomponent.cpp:951
#13 QQmlComponent::create (this=0x1ecf0a0, context=0x2951f30) at qml/qqmlcomponent.cpp:784
#14 0x00007f3dca0e3589 in Aurorae::Decoration::init (this=0x295ae00) at /usr/src/debug/kde-plasma/kwin-5.8.3/kwin-5.8.3/plugins/kdecorations/aurorae/src/aurorae.cpp:316
#15 0x00007f3de75f89d8 in KWin::Decoration::DecorationBridge::createDecoration (this=<optimized out>, client=client@entry=0x29507b0) at /usr/src/debug/kde-plasma/kwin-5.8.3/kwin-5.8.3/decorations/decorationbridge.cpp:260
#16 0x00007f3de74c9e06 in KWin::Client::createDecoration (this=this@entry=0x29507b0, oldgeom=...) at /usr/src/debug/kde-plasma/kwin-5.8.3/kwin-5.8.3/client.cpp:393
#17 0x00007f3de74caa4c in KWin::Client::updateDecoration (this=0x29507b0, check_workspace_pos=<optimized out>, force=<optimized out>) at /usr/src/debug/kde-plasma/kwin-5.8.3/kwin-5.8.3/client.cpp:380
#18 0x00007f3de752fb24 in KWin::Client::manage (this=this@entry=0x29507b0, w=w@entry=46137363, isMapped=isMapped@entry=false) at /usr/src/debug/kde-plasma/kwin-5.8.3/kwin-5.8.3/manage.cpp:390
#19 0x00007f3de74a97dd in KWin::Workspace::createClient (this=this@entry=0x1d2f9f0, w=46137363, is_mapped=is_mapped@entry=false) at /usr/src/debug/kde-plasma/kwin-5.8.3/kwin-5.8.3/workspace.cpp:517
#20 0x00007f3de751c622 in KWin::Workspace::workspaceEvent (this=0x1d2f9f0, e=0x7f3dcc005fd0) at /usr/src/debug/kde-plasma/kwin-5.8.3/kwin-5.8.3/events.cpp:421
#21 0x00007f3de586e634 in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f3dcc005fd0, result=result@entry=0x7ffd3dc0ebe8) at kernel/qabstracteventdispatcher.cpp:460
#22 0x00007f3dd3563985 in QXcbConnection::handleXcbEvent (this=this@entry=0x1c17e30, event=event@entry=0x7f3dcc005fd0) at qxcbconnection.cpp:1094
#23 0x00007f3dd3565ce3 in QXcbConnection::processXcbEvents (this=0x1c17e30) at qxcbconnection.cpp:1729
#24 0x00007f3de589a5ca in QObject::event (this=0x1c17e30, e=<optimized out>) at kernel/qobject.cpp:1256
#25 0x00007f3de6104fbc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x1c17e30, e=0x7f3dcc0012f0) at kernel/qapplication.cpp:3804
#26 0x00007f3de6109946 in QApplication::notify (this=0x7ffd3dc0f250, receiver=0x1c17e30, e=0x7f3dcc0012f0) at kernel/qapplication.cpp:3561
#27 0x00007f3de58709e8 in QCoreApplication::notifyInternal2 (receiver=0x1c17e30, event=event@entry=0x7f3dcc0012f0) at kernel/qcoreapplication.cpp:1015
#28 0x00007f3de5872d77 in QCoreApplication::sendEvent (event=0x7f3dcc0012f0, receiver=<optimized out>) at kernel/qcoreapplication.h:225
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1bff790) at kernel/qcoreapplication.cpp:1650
#30 0x00007f3de58bce49 in QEventDispatcherUNIX::processEvents (this=0x1c500a0, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#31 0x00007f3dd35ce72f in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#32 0x00007f3de586f53a in QEventLoop::exec (this=this@entry=0x7ffd3dc0f130, flags=..., flags@entry=...) at kernel/qeventloop.cpp:206
#33 0x00007f3de58773e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#34 0x00007f3de5b95379 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1607
#35 0x00007f3de6101afa in QApplication::exec () at kernel/qapplication.cpp:2979
#36 0x00007f3de7eb637c in kdemain (argc=1, argv=0x7ffd3dc0f3e8) at /usr/src/debug/kde-plasma/kwin-5.8.3/kwin-5.8.3/main_x11.cpp:466
#37 0x00007f3de7910668 in __libc_start_main (main=0x4007d0 <main(int, char**)>, argc=1, argv=0x7ffd3dc0f3e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd3dc0f3d8) at libc-start.c:289
#38 0x0000000000400809 in _start ()

Possible duplicates by query: bug 372015, bug 370614, bug 368993, bug 367951, bug 367862.

Reported using DrKonqi
Comment 1 Christoph Feck 2016-12-21 20:35:24 UTC
Please use Breeze decoration as a workaround.

*** This bug has been marked as a duplicate of bug 361236 ***