Bug 356415

Summary: Multiple clicks are necessary in order to activate panel elements
Product: [Plasma] plasmashell Reporter: Robby Engelmann <robby.engelmann>
Component: PanelAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: anakin.cs, apcomptec, arojas, bjoern, bluelightning, cbars.andrew, eseifert, germano.massullo, hrvoje.senjan, ianseeks, johannespfrang+kde, karl, kde, mklapetek, pip.kde, pprzemal, rdieter, robby.engelmann, slartibart70, tromzy
Priority: NOR    
Version: 5.5.0   
Target Milestone: 1.0   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Robby Engelmann 2015-12-09 10:00:34 UTC
Sometimes multiple clicks are necessary in order to activate panel elements and tray icons.

Reproducible: Sometimes

Steps to Reproduce:
1. start 3-4 applications and having some application shown in panel also when not started
2. work with these application and switch between them multiple times
3. try to click on some tray icons

Actual Results:  
sometimes the applications get not activated or hidden. Sometimes applications get not launched. Sometimes tray icons get not activated by only one click. With the tray I am not absolutely sure. But working 5 minutes switching between different applications will for sure trigger the bug (at least for me)

Expected Results:  
one click is enough

using plasma 5.5, Frameworks 5.16 and Qt 5.5.1
Comment 1 Eike Hein 2015-12-09 17:53:18 UTC
*** Bug 356441 has been marked as a duplicate of this bug. ***
Comment 2 Paul 2015-12-09 18:47:10 UTC
This is also now being reported by a couple of people on the openSUSE factory mailing list. 

See the following thread: http://lists.opensuse.org/opensuse-factory/2015-12/msg00190.html
Comment 3 Colin J Thomson 2015-12-09 19:13:37 UTC
Also seeing this with Fedora 23 Plasma 5.5, frameworks 5.16
Comment 4 slartibart70 2015-12-10 08:35:58 UTC
Hi Guys,

if we start using it in fc23 running in virtualbox 5.0.10 with the virtualbox tools installed, it is more or less always happening .
Same install of fc23 in vmware and it is more or less fine (had only once a situation where more than one click for reaction was needed)
In both cases (vbox and vmware) the previews in icon-only-taskmanager are not usable because they disappear before we have a chance clicking on them (e.g. running two konsole windows and trying to select on of them by acitvating the 'preview')

see also: https://bugs.kde.org/show_bug.cgi?id=356441
Comment 5 Antonio Rojas 2015-12-10 08:54:53 UTC
This makes it almost impossible to remove applets from the panel too. The popup with the close button disapperars as soon as the cursor is moved away from the applet.
Comment 6 Antonio Rojas 2015-12-10 09:39:03 UTC
This is caused by commit 76cb47f1279ea012a9eda11c4ead7f28db4c1399 in plasma-workspace. Reverting it fixes the issue.
Comment 7 Robby Engelmann 2015-12-10 10:20:25 UTC
This commit was supposed to fix this bug: https://bugs.kde.org/show_bug.cgi?id=354651.
As X is still the standard I wonder why it was shipped as it was a known problem.
Comment 8 Ian 2015-12-10 11:04:57 UTC
Just a bit more info in case it helps.  The tool tip will show to indicate you have reached the icon okay even though the click doesn't work.  The panel also takes longer to appear on the screen after log in (i have it along the bottom of the screen)
Comment 9 AnAkkk 2015-12-10 11:56:31 UTC
Same issue after updating to Plasma 5.5 in Arch.
Antonio Rojas, could you please revert that commit in the arch package ?
Comment 10 Eike Hein 2015-12-11 14:03:04 UTC
*** Bug 356504 has been marked as a duplicate of this bug. ***
Comment 11 Björn Ruberg 2015-12-12 13:56:28 UTC
Seeing this on two systems on Fedora 23 Plasma 5.5.
Comment 12 Ian 2015-12-13 11:09:26 UTC
This seems solved on opensuse tumbleweed as of this mornings update.
Comment 13 Robby Engelmann 2015-12-13 11:54:31 UTC
Sumski reverted the commit causing this issue and added some other fixed from upstream as well. For me, all is working fine on plasma 5.5 now.
Comment 14 Rex Dieter 2015-12-13 12:45:35 UTC
*** Bug 356569 has been marked as a duplicate of this bug. ***
Comment 15 Colin J Thomson 2015-12-16 23:36:02 UTC
This seems to be fixed now on Fedora 23 with Plasma-workspace-5.5.0-4
Comment 16 Przemysław Palacz 2015-12-17 16:06:30 UTC
Works for me too on Fedora 22, thank you :)
Comment 17 Martin Klapetek 2015-12-17 16:25:12 UTC
Given the last three comments, closing as fixed.
Comment 18 Robby Engelmann 2015-12-18 10:00:39 UTC
If I understood correct, the bug was fixed downstream by the distros by reverting a specific commit, which was originally intended to fix another bug for wayland systems. Reverting is not really a fix for the problem, because the wayland bug may still occur?
Comment 19 Colin J Thomson 2015-12-18 17:02:37 UTC
Fixed upstream and this was applied to Plasma-workspace-5.5.0-4 on Fedora 23
https://git.reviewboard.kde.org/r/126331/