Bug 350769

Summary: Service menus require konqpopupmenuplugin.desktop
Product: [Frameworks and Libraries] frameworks-kio Reporter: Antonio Rojas <arojas>
Component: generalAssignee: David Faure <faure>
Status: RESOLVED FIXED    
Severity: normal CC: adem4ik, artghio, aspotashev, bugs, cyberbeat, frank78ac, futurepilot, germano.massullo, igor.poboiko, karaluh, kde, kdelibs-bugs, kevin.kofler, nierro92, post, rdieter, rthomsen6, sbasalaev, sonichedgehog_hyperblast00, virgolus, vmpereir
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:

Description Antonio Rojas 2015-07-29 18:36:07 UTC
The KF5 version of dolphin requires the konqpopupmenuplugin.desktop file from kde-baseapps to show service menus. Since dolphin will be KF5 based in 15.08 but kde-baseapps is still KDE4 based, this means that service menus provided by eg. ark or konsole won't work. Would it be possible to ship the konqpopupmenuplugin.desktop file with dolphin to fix this?

Reproducible: Always
Comment 1 Antonio Rojas 2015-07-29 18:38:03 UTC
*** Bug 350762 has been marked as a duplicate of this bug. ***
Comment 2 Frank Reininghaus 2015-07-31 16:40:54 UTC
(In reply to Antonio Rojas from comment #0)
> The KF5 version of dolphin requires the konqpopupmenuplugin.desktop file
> from kde-baseapps to show service menus. Since dolphin will be KF5 based in
> 15.08 but kde-baseapps is still KDE4 based, this means that service menus
> provided by eg. ark or konsole won't work. Would it be possible to ship the
> konqpopupmenuplugin.desktop file with dolphin to fix this?

From my point of view, this is not the correct solution because these service menus can also be used from the file dialog, FolderView, and probably other places. And they should also work there if Dolphin is not installed, so the service menus should better be put somewhere else. Maybe kio-extras?
Comment 3 Frank Reininghaus 2015-07-31 16:41:47 UTC
*** Bug 349654 has been marked as a duplicate of this bug. ***
Comment 4 Frank Reininghaus 2015-07-31 16:43:17 UTC
Just to be clear: bug 349654 is about the "Create New..." menu, but I think that both topics are closely related because they are both due to the lack of an installed lib/konq from kde-baseapps, and they should be resolved together.
Comment 5 Frank Reininghaus 2015-08-09 16:31:44 UTC
I just tried to have a look at the konqpopupmenuplugin.desktop issue. It's true that some service menus are not shown (like, e.g., the one of Konsole) if kde-baseapps is not installed. However, other service menus work just fine. So it seems that maybe the other service menus are just not ported correctly to KF5 yet (which is understandable, because probably all developers have the kde-baseapps package from git self-built and installed on their machine, so it works even if the service menu relies on konqpopupmenuplugin.desktop).

I don't know how to solve this issue best - maybe moving the konqpopupmenuplugin.desktop file to kio, kio-extras or some other common place would be the easiest way to make the service menus work again, but I'm not sure - I'm not really familiar with the internals of the service menu handling. I'll reassign to KIO and re-open bug 349654 because it seems that both issues are less related than I first thought.
Comment 6 Frank Reininghaus 2015-09-05 08:10:57 UTC
*** Bug 352188 has been marked as a duplicate of this bug. ***
Comment 7 Frank Reininghaus 2015-09-27 18:18:40 UTC
Proposed fix: https://git.reviewboard.kde.org/r/125425/
Comment 8 Frank Reininghaus 2015-10-06 08:30:28 UTC
Git commit 4b24b70c93523c5bc56c90c04a5a666331e96a1b by Frank Reininghaus.
Committed on 06/10/2015 at 08:11.
Pushed by freininghaus into branch 'master'.

Move konqpopupmenuplugin.desktop from kde-baseapps to kio

This ensures that service menu entries are shown if the unreleased
KF5-based version of lib/konq from kde-baseapps is not installed

It would be great if the translations from lib/konq in kde-baseapps
could be merged. Thanks!
Change-Id: Id2c9a73ce95a6c8b704f3a1000c0292d1864a352
REVIEW: 125425
CCMAIL: luigi.toscano@tiscali.it

M  +1    -0    src/widgets/CMakeLists.txt
A  +89   -0    src/widgets/konqpopupmenuplugin.desktop

http://commits.kde.org/kio/4b24b70c93523c5bc56c90c04a5a666331e96a1b
Comment 9 Frank Reininghaus 2015-11-08 19:13:51 UTC
*** Bug 354892 has been marked as a duplicate of this bug. ***