Bug 354892 - Dolphin doesn't show Ark service menus
Summary: Dolphin doesn't show Ark service menus
Status: RESOLVED DUPLICATE of bug 350769
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Other Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-05 11:55 UTC by Martin van Es
Modified: 2015-11-08 19:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin van Es 2015-11-05 11:55:57 UTC
Running both Dolphin and Ark 15.08.2 (Kubuntun Wily) I miss Ark service menus in Dolphin. They are not available in Settings -> Services. Ark package did write these files: ark_addtoservicemenu.desktop and ark_servicemenu.desktop into /usr/share/kservices5/ServiceMenus


Reproducible: Always

Steps to Reproduce:
1. Open Dolhin and right-click zip archive


Actual Results:  
No "Extract Here" context menu

Expected Results:  
"Extract Here" context menu

I can use "Open with Ark" and proceed, so there's a work-around.
Comment 1 Samuel Cordeiro 2015-11-07 11:01:53 UTC
I too have the same issue, I can see that the file /usr/share/kservices5/ServiceMenus/ark_servicemenu.desktop" exists but in Dolphin's services configuration, I don't see any entry regarding extractions.
Comment 2 Frank Reininghaus 2015-11-08 19:13:51 UTC
Thanks for the bug report. This is fixed in version 5.16 of the KIO framework, which will be released in a few days. Earlier versions of this framework lack the file konqpopupmenuplugin.desktop, which is required to make the context menu work properly. You might be able to work around this problem by installing this file manually, but the location where you have to put it can depend on the distro.

https://quickgit.kde.org/?p=kio.git&a=blob&h=be79174d920a18b7fef22f0740c02b7f1388ad0f&f=src%2Fwidgets%2Fkonqpopupmenuplugin.desktop&o=plain

*** This bug has been marked as a duplicate of bug 350769 ***