Bug 331167

Summary: Import images from folder create date based folders from images Exif
Product: digikam Reporter: Brylie Christopher Oxley <brylie>
Component: Import-PostProcessingAssignee: Digikam Developers <digikam-bugs-null>
Status: REPORTED ---    
Severity: wishlist CC: ae_rodriguez_, brylie, caulier.gilles, flo.hennig, imksn, karl.mistelberger, kde, lenharo
Priority: NOR    
Version: 4.0.0   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Brylie Christopher Oxley 2014-02-15 22:47:16 UTC
When importing images from my hard drive into digiKam, via the Import >> Add Images command, there is an option for Auto-creating albumbs based on date. The albums created seem to be based on the import date, rather than the date the image was taken.

How can I use this auto-creation feature to create albums based on the EXIF date?

Reproducible: Always

Steps to Reproduce:
1. Copy some images to a hard drive folder
2. Click Import >> Add Images (Ctrl-I)
3. Under "Auto-creation of Albums", select "Date-based sub-albums"
Actual Results:  
One sub album is created based on the date of import (i.e. 'today').

Expected Results:  
Sub-albums would be created based on the image creation date (from EXIF). This is how the import from camera feature works.

Having the ability to automatically create EXIF based sub albums would offer more efficiency than a single import date based sub-album. E.g. I can easily create a single folder and import all images into that folder. It is more time consuming to import, manually create sub-albums, and then sort the images into the sub-albums.
Comment 1 Brylie Christopher Oxley 2014-02-15 22:50:06 UTC
I am running digiKam 4.11.5, which isn't available in the "Version" select box.
Comment 2 caulier.gilles 2014-06-13 09:14:15 UTC
digiKam 4.11.5 do not exist. You talk about KDE version. Look in Help/About dialog for details.

Note : i use this option with digiKam 4.0.0 and all work fine here...

Gilles Caulier
Comment 3 Brylie Christopher Oxley 2014-06-13 10:07:48 UTC
OK, how can I install digiKam 4.0.0 on Ubuntu?
Comment 4 Brylie Christopher Oxley 2014-06-13 10:11:26 UTC
I am installing via the ppa:kubuntu-ppa/backports

https://launchpad.net/~kubuntu-ppa/+archive/backports
Comment 5 caulier.gilles 2014-09-01 07:56:47 UTC
Brylie,

This file still valid using last digiKam 4.2.0 ?

Gilles
Comment 6 Brylie Christopher Oxley 2014-09-02 07:51:59 UTC
I still have the problem on version 4.0.0. This may be related to Ubuntu packaging. I cannot figure out how to install 4.2.0 on Ubuntu. 

We may need to support people on Debian and Ubuntu who do not have the most up-to-date version of digiKam.
Comment 7 caulier.gilles 2014-09-02 07:59:59 UTC
Brylie,

Look this thread to see if this can help you :

https://www.digikam.org/node/715#comment-20815

Gilles Caulier
Comment 8 caulier.gilles 2016-11-25 06:55:12 UTC
This problem still reproducible using last DK 5.4.0 bundle ?

https://drive.google.com/drive/folders/0BzeiVr-byqt5Y0tIRWVWlRJenM

Gilles Caulier
Comment 9 Brylie Christopher Oxley 2016-11-25 07:01:18 UTC
The MediaWiki export is available inthe 5.3.x appimage. There is some issue with the Ubuntu packaging process since at least 2014, where the MediaWiki export plugin is not being installed. I have tried manually installing libmediawiki to no avail.
Comment 10 caulier.gilles 2016-11-25 07:46:31 UTC
There is no relation between MediaWiki and this entry...

Gilles Caulier
Comment 11 Maik Qualmann 2018-02-03 21:21:49 UTC
*** Bug 389814 has been marked as a duplicate of this bug. ***
Comment 12 Maik Qualmann 2018-02-03 21:24:20 UTC
*** Bug 381845 has been marked as a duplicate of this bug. ***
Comment 13 Maik Qualmann 2020-08-15 04:49:08 UTC
*** Bug 425369 has been marked as a duplicate of this bug. ***
Comment 14 Maik Qualmann 2021-08-13 06:40:53 UTC
*** Bug 425369 has been marked as a duplicate of this bug. ***
Comment 15 Maik Qualmann 2021-08-13 06:41:08 UTC
*** Bug 440909 has been marked as a duplicate of this bug. ***
Comment 16 Maik Qualmann 2021-12-07 18:33:01 UTC
*** Bug 446632 has been marked as a duplicate of this bug. ***