Bug 440909 - Import's "Auto-creation of Albums" using file modified date rather than date taken
Summary: Import's "Auto-creation of Albums" using file modified date rather than date ...
Status: RESOLVED DUPLICATE of bug 331167
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Albums (show other bugs)
Version: 7.3.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-12 21:36 UTC by Chris W
Modified: 2021-08-13 17:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot demonstrating the result (653.61 KB, image/png)
2021-08-12 21:50 UTC, Chris W
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris W 2021-08-12 21:36:53 UTC
SUMMARY
When I import images, I expect album folders to be generated based upon when photos are taken, but they seem to only be using the data the image file was last modified (in my case, the date the image was copied from my iPhone to my OneDrive cloud storage).

The file formats I'm able to recreate this issue are: heif (Apple iPhone) and NEF (Nikon Raw)

STEPS TO REPRODUCE
1. Open Digikam
2. Select Import > Add images
3. Navigate to a folder with photos (that contain EXIF data, including date captures)
4. Confirm "Date-based sub-albums" is enabled in the "Auto-creation of Albums" setting, with date format of Custom and "yyyy/yyyy-MM/yyyy-MM-dd"
4. Click Download
5. Note that the generated folders only use the file modified date, not the camera capture date in EXIF.

OBSERVED RESULT
(described above)

EXPECTED RESULT
(described above)

SOFTWARE/OS VERSIONS
Windows: Win 10 (19042.1165)

ADDITIONAL INFORMATION
Comment 1 Chris W 2021-08-12 21:50:29 UTC
Created attachment 140675 [details]
Screenshot demonstrating the result
Comment 2 Maik Qualmann 2021-08-13 06:37:05 UTC
Activate the use of file metadata under Behavior in the digiKam Camera settings. For speed reasons they are deactivated by default.

Maik
Comment 3 Maik Qualmann 2021-08-13 06:41:08 UTC

*** This bug has been marked as a duplicate of bug 331167 ***
Comment 4 Chris W 2021-08-13 17:39:02 UTC
(In reply to Maik Qualmann from comment #2)
> Activate the use of file metadata under Behavior in the digiKam Camera
> settings. For speed reasons they are deactivated by default.
> 
> Maik


That worked great, thanks Maik!  For the benefit of others who may see this, the setting is at: Settings > Configure DigiKam > Camera > Behavior > Use file metadata (enable)

Really appreciate the help, and it inspired me to Donate to the project :-)