Bug 446632 - New images imported with file creation instead of image creation date
Summary: New images imported with file creation instead of image creation date
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Settings (show other bugs)
Version: 7.3.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-07 18:13 UTC by ae_rodriguez_
Modified: 2021-12-08 06:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ae_rodriguez_ 2021-12-07 18:13:43 UTC
SUMMARY
Just updated digikam from 7.1.0 to 7.3.0. Try to import new images previously copied to hard drive. All images appear with "created" date corresponding to the file creation not the date the image was taken. However, the date appears correct in:
-Properties panel 
    -Photograph Properties
-Metadata panel
    -EXIF
        -Date and Time (digitized)
        -Date and Time (original)
    -XMP
        -Date and Time Original
    -ExifTool
        -CreateDate
        -DateTimeOriginal

AND not correct in:
-Metadata panel
    -ExifTool
        -FileCreateDate (it displays date file was copied to hard drive)
        -FileModifyDate (it displays date image was taken)
     

OBSERVED RESULT
Images are attributed a creation date that corresponds to the date the file was copied.

EXPECTED RESULT
Images are attributed the correct creation date, as it was happening just before upgrade.

SOFTWARE/OS VERSIONS
Windows: 10 Pro
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Comment 1 Maik Qualmann 2021-12-07 18:32:11 UTC
Activate reading of the file metadata in the digiKam settings under camera.

Maik
Comment 2 Maik Qualmann 2021-12-07 18:33:01 UTC

*** This bug has been marked as a duplicate of bug 331167 ***
Comment 3 ae_rodriguez_ 2021-12-07 18:47:40 UTC
Thanks Maik. That actually solves the problem (albeit way slower) however I wonder why it appeared. Never had that issue with digikam 7.1.0.
Comment 4 Maik Qualmann 2021-12-07 18:53:59 UTC
The problem was definitely there in digiKam-7.1.0, it's not a new one.

I plan to do the post-processing in a separate thread after importing the images into the DB. So that these and other problems in the import tool can be resolved. Let's see, maybe I'll find time for it over the holidays.

Maik
Comment 5 ae_rodriguez_ 2021-12-07 18:56:16 UTC
Alright, I will take your word of course. 
Then... my digikam configuration settings were changed due to the upgrade? Thats the reason?