Bug 329725

Summary: crash when update
Product: Discover Reporter: Rip2502 <rvystavnoy>
Component: Updates (interactive)Assignee: Jonathan Thomas <echidnaman>
Status: RESOLVED DUPLICATE    
Severity: crash CC: sitter
Priority: NOR Keywords: drkonqi
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Rip2502 2014-01-08 14:59:54 UTC
Application: muon-updater (2.1.2)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed: I changed sources for update from kazakhstan mirror to primary source plus include backports.

-- Backtrace:
Application: Модуль Muon для управления обновлениями (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb51f4740 (LWP 31910))]

Thread 3 (Thread 0xb2328b40 (LWP 31911)):
#0  0xb77c2424 in __kernel_vsyscall ()
#1  0xb6059a0b in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb58a3a4b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb5894b68 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5894ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63ba8df in QEventDispatcherGlib::processEvents (this=0xb1a00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63899f3 in QEventLoop::processEvents (this=this@entry=0xb2328228, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6389d19 in QEventLoop::exec (this=this@entry=0xb2328228, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6278e3d in QThread::exec (this=this@entry=0x83ca3d0) at thread/qthread.cpp:542
#9  0xb6369e14 in QInotifyFileSystemWatcherEngine::run (this=0x83ca3d0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb627b72f in QThreadPrivate::start (arg=0x83ca3d0) at thread/qthread_unix.cpp:338
#11 0xb5972d78 in start_thread (arg=0xb2328b40) at pthread_create.c:311
#12 0xb606901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 2 (Thread 0xaea24b40 (LWP 32001)):
#0  0xb77c2424 in __kernel_vsyscall ()
#1  0xb607c4d2 in clock_gettime (clock_id=1, tp=0xaea23fc8) at ../sysdeps/unix/clock_gettime.c:115
#2  0xb62d63ec in do_gettime (frac=0xaea23fc0, sec=0xaea23fb8) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0xb63bbfd2 in updateCurrentTime (this=0xae09114c) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0xae09114c, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0xb63ba67b in timerSourcePrepareHelper (src=<optimized out>, timeout=0xaea240bc) at kernel/qeventdispatcher_glib.cpp:136
#7  0xb63ba70d in timerSourcePrepare (source=0xae091118, timeout=0xaea240bc) at kernel/qeventdispatcher_glib.cpp:169
#8  0xb5894143 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb5894a5f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb5894ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb63ba8df in QEventDispatcherGlib::processEvents (this=0xad965e70, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0xb63899f3 in QEventLoop::processEvents (this=this@entry=0xaea24228, flags=...) at kernel/qeventloop.cpp:149
#13 0xb6389d19 in QEventLoop::exec (this=this@entry=0xaea24228, flags=...) at kernel/qeventloop.cpp:204
#14 0xb6278e3d in QThread::exec (this=this@entry=0x850a100) at thread/qthread.cpp:542
#15 0xb6369e14 in QInotifyFileSystemWatcherEngine::run (this=0x850a100) at io/qfilesystemwatcher_inotify.cpp:265
#16 0xb627b72f in QThreadPrivate::start (arg=0x850a100) at thread/qthread_unix.cpp:338
#17 0xb5972d78 in start_thread (arg=0xaea24b40) at pthread_create.c:311
#18 0xb606901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 1 (Thread 0xb51f4740 (LWP 31910)):
[KCrash Handler]
#7  UpdateModel::setResources (this=0x83a5050, resources=...) at /build/buildd/muon-2.1.2/updater/UpdateModel/UpdateModel.cpp:248
#8  0x08056e6d in UpdaterWidget::populateUpdateModel (this=this@entry=0x83f73f0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:163
#9  0x08056f61 in UpdaterWidget::activityChanged (this=0x83f73f0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:148
#10 0x08052658 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#11 0xb639ffc7 in QMetaObject::activate (sender=sender@entry=0x833b650, m=m@entry=0xb77999f8 <ResourcesUpdatesModel::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#12 0xb7770775 in ResourcesUpdatesModel::progressingChanged (this=0x833b650) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/moc_ResourcesUpdatesModel.cpp:198
#13 0xb77708a8 in ResourcesUpdatesModel::qt_static_metacall (_o=0x0, _id=1, _a=0xbfc63868, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/moc_ResourcesUpdatesModel.cpp:92
#14 0xb639ffc7 in QMetaObject::activate (sender=sender@entry=0x8642978, m=m@entry=0xb7799a70 <AbstractBackendUpdater::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0xbfc63868) at kernel/qobject.cpp:3539
#15 0xb776fced in AbstractBackendUpdater::progressingChanged (this=this@entry=0x8642978, _t1=false) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/moc_AbstractBackendUpdater.cpp:190
#16 0xb0e53351 in ApplicationUpdates::setProgressing (this=0x8642978, progressing=false) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:371
#17 0xb0e54a58 in ApplicationUpdates::fetchingChanged (this=0x8642978) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:442
#18 0xb0e43f08 in ApplicationUpdates::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbfc63968, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/backends/ApplicationBackend/moc_ApplicationUpdates.cpp:83
#19 0xb639ffc7 in QMetaObject::activate (sender=sender@entry=0x82b8470, m=m@entry=0xb7799938 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#20 0xb7770da5 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x82b8470) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#21 0xb0e45598 in ApplicationBackend::setFetching (this=0x82b8470, f=false) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:642
#22 0xb0e47ccb in ApplicationBackend::reload (this=0x82b8470) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#23 0xb0e53436 in ApplicationUpdates::transactionFinished (this=0x8642978) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#24 0xb0e43dd9 in ApplicationUpdates::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbfc63b18, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/backends/ApplicationBackend/moc_ApplicationUpdates.cpp:85
#25 0xb639ffc7 in QMetaObject::activate (sender=sender@entry=0x87953b8, m=m@entry=0xb0cddd18 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0xbfc63b18) at kernel/qobject.cpp:3539
#26 0xb0cc8235 in QApt::Transaction::finished (this=this@entry=0x87953b8, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transaction.cxx:338
#27 0xb0cba317 in QApt::Transaction::updateProperty (this=this@entry=0x87953b8, type=11, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#28 0xb0cc88d4 in QApt::Transaction::qt_static_metacall (_o=_o@entry=0x87953b8, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=24, _a=0xbfc63c94) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transaction.cxx:164
#29 0xb639ffc7 in QMetaObject::activate (sender=sender@entry=0x8a263e0, m=m@entry=0xb0cddd78 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0xbfc63c94) at kernel/qobject.cpp:3539
#30 0xb0cc95bd in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x8a263e0, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:246
#31 0xb0cc99e9 in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x8a263e0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0xbfc63e3c) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:111
#32 0xb0cca456 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x8a263e0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfc63e3c) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:164
#33 0xb5e68ebe in QDBusConnectionPrivate::deliverCall (this=0x83d23e0, object=object@entry=0x8a263e0, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#34 0xb5e71f3d in QDBusCallDeliveryEvent::placeMetaCall (this=0x8b28158, object=0x8a263e0) at qdbusintegrator_p.h:103
#35 0xb63a458b in QObject::event (this=0x8a263e0, e=0x8b28158) at kernel/qobject.cpp:1194
#36 0xb68e5744 in QApplicationPrivate::notify_helper (this=0x825e930, receiver=0x8a263e0, e=0x8b28158) at kernel/qapplication.cpp:4567
#37 0xb68ec223 in QApplication::notify (this=0xbfc644c0, receiver=receiver@entry=0x8a263e0, e=e@entry=0x8b28158) at kernel/qapplication.cpp:4353
#38 0xb7432ff4 in KApplication::notify (this=0xbfc644c0, receiver=0x8a263e0, event=0x8b28158) at ../../kdeui/kernel/kapplication.cpp:311
#39 0xb638aeda in QCoreApplication::notifyInternal (this=0xbfc644c0, receiver=receiver@entry=0x8a263e0, event=event@entry=0x8b28158) at kernel/qcoreapplication.cpp:946
#40 0xb638e6ad in sendEvent (event=0x8b28158, receiver=0x8a263e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x82371d8) at kernel/qcoreapplication.cpp:1570
#42 0xb638ebbc in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#43 0xb63baf6e in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#44 postEventSourceDispatch (s=0x825f200) at kernel/qeventdispatcher_glib.cpp:279
#45 0xb589483e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0xb5894be8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0xb5894ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0xb63ba8bf in QEventDispatcherGlib::processEvents (this=this@entry=0x8237f50, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#49 0xb699a32e in QGuiEventDispatcherGlib::processEvents (this=0x8237f50, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0xb63899f3 in QEventLoop::processEvents (this=this@entry=0xbfc64408, flags=...) at kernel/qeventloop.cpp:149
#51 0xb6389d19 in QEventLoop::exec (this=this@entry=0xbfc64408, flags=...) at kernel/qeventloop.cpp:204
#52 0xb638f89e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#53 0xb68e3974 in QApplication::exec () at kernel/qapplication.cpp:3828
#54 0x080520f4 in main (argc=5, argv=0xbfc64594) at /build/buildd/muon-2.1.2/updater/main.cpp:59

Possible duplicates by query: bug 329614, bug 328931, bug 328875, bug 328633, bug 328536.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-09 00:36:00 UTC

*** This bug has been marked as a duplicate of bug 327544 ***