Bug 329614

Summary: Muon updater crashed
Product: Discover Reporter: ARVIND RATHORE <arvindgrathore>
Component: Updates (interactive)Assignee: Jonathan Thomas <echidnaman>
Status: RESOLVED DUPLICATE    
Severity: crash CC: sitter
Priority: NOR Keywords: drkonqi
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description ARVIND RATHORE 2014-01-05 10:56:11 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-14-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
Simply clicked on muon update manager to launch it, it checked for updates and indicated some updates in the tray. Before it could finish checking, it crashed!!

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6eb0d8c7c0 (LWP 2779))]

Thread 3 (Thread 0x7f6e9deb6700 (LWP 2780)):
#0  0x00007f6eabc56055 in __GI___pthread_mutex_lock (mutex=0x7f6e98000a60) at pthread_mutex_lock.c:95
#1  0x00007f6eab7bb3a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6eab77a7f0 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6eab77b565 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6eab77b7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6eaeb76a76 in QEventDispatcherGlib::processEvents (this=0x7f6e980008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f6eaeb485ef in QEventLoop::processEvents (this=this@entry=0x7f6e9deb5d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f6eaeb488e5 in QEventLoop::exec (this=this@entry=0x7f6e9deb5d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f6eaea4788f in QThread::exec (this=this@entry=0x2469330) at thread/qthread.cpp:542
#9  0x00007f6eaeb29d13 in QInotifyFileSystemWatcherEngine::run (this=0x2469330) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f6eaea49f2f in QThreadPrivate::start (arg=0x2469330) at thread/qthread_unix.cpp:338
#11 0x00007f6eabc53f6e in start_thread (arg=0x7f6e9deb6700) at pthread_create.c:311
#12 0x00007f6eae3fd9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f6e94e96700 (LWP 2963)):
#0  0x00007f6eab7bb0ea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6eab7bb3c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6eab77ad40 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6eab77b5c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6eab77b7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6eaeb76a76 in QEventDispatcherGlib::processEvents (this=0x7f6e88b4f040, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f6eaeb485ef in QEventLoop::processEvents (this=this@entry=0x7f6e94e95d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f6eaeb488e5 in QEventLoop::exec (this=this@entry=0x7f6e94e95d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f6eaea4788f in QThread::exec (this=this@entry=0x4096700) at thread/qthread.cpp:542
#9  0x00007f6eaeb29d13 in QInotifyFileSystemWatcherEngine::run (this=0x4096700) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f6eaea49f2f in QThreadPrivate::start (arg=0x4096700) at thread/qthread_unix.cpp:338
#11 0x00007f6eabc53f6e in start_thread (arg=0x7f6e94e96700) at pthread_create.c:311
#12 0x00007f6eae3fd9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f6eb0d8c7c0 (LWP 2779)):
[KCrash Handler]
#6  UpdateModel::setResources (this=0x2485e60, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x24a7350) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0x24a7350) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#10 0x00007f6eaeb5da58 in QMetaObject::activate (sender=0x23f3930, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007f6eaeb5da58 in QMetaObject::activate (sender=sender@entry=0x27f7a40, m=m@entry=0x7f6eb0bad380 <AbstractBackendUpdater::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff7d8bc040) at kernel/qobject.cpp:3539
#12 0x00007f6eb0986a72 in AbstractBackendUpdater::progressingChanged (this=this@entry=0x27f7a40, _t1=false) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractBackendUpdater.cpp:190
#13 0x00007f6e9c12609c in ApplicationUpdates::setProgressing (this=0x27f7a40, progressing=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:371
#14 0x00007f6eaeb5da58 in QMetaObject::activate (sender=sender@entry=0x27f5390, m=m@entry=0x7f6eb0bad3c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#15 0x00007f6eb0986940 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x27f5390) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#16 0x00007f6e9c118e93 in ApplicationBackend::setFetching (this=0x27f5390, f=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:643
#17 0x00007f6e9c11b4c3 in ApplicationBackend::reload (this=0x27f5390) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#18 0x00007f6e9c126154 in ApplicationUpdates::transactionFinished (this=0x27f7a40) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#19 0x00007f6eaeb5da58 in QMetaObject::activate (sender=0x36d3c00, m=m@entry=0x7f6e979ad9c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff7d8bc300) at kernel/qobject.cpp:3539
#20 0x00007f6e97798441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#21 0x00007f6e9778b1af in QApt::Transaction::updateProperty (this=0x36d3c00, type=0, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#22 0x00007f6e97798974 in QApt::Transaction::qt_static_metacall (_o=0x36d3c00, _c=<optimized out>, _id=<optimized out>, _a=0x7fff7d8bc520) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#23 0x00007f6eaeb5da58 in QMetaObject::activate (sender=sender@entry=0x27fa810, m=m@entry=0x7f6e979adaa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff7d8bc520) at kernel/qobject.cpp:3539
#24 0x00007f6e977993d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x27fa810, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#25 0x00007f6e9779977c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x27fa810, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff7d8bc7e0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#26 0x00007f6e9779a0f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x27fa810, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff7d8bc7e0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#27 0x00007f6eadbf8e36 in QDBusConnectionPrivate::deliverCall (this=0x246d1e0, object=0x27fa810, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#28 0x00007f6eaeb61dce in QObject::event (this=0x27fa810, e=<optimized out>) at kernel/qobject.cpp:1194
#29 0x00007f6eaf53adfc in QApplicationPrivate::notify_helper (this=this@entry=0x22ad720, receiver=receiver@entry=0x27fa810, e=e@entry=0x3fac1a0) at kernel/qapplication.cpp:4567
#30 0x00007f6eaf541470 in QApplication::notify (this=this@entry=0x7fff7d8bcf90, receiver=receiver@entry=0x27fa810, e=e@entry=0x3fac1a0) at kernel/qapplication.cpp:4353
#31 0x00007f6eb0244a6a in KApplication::notify (this=0x7fff7d8bcf90, receiver=0x27fa810, event=0x3fac1a0) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007f6eaeb498bd in QCoreApplication::notifyInternal (this=0x7fff7d8bcf90, receiver=receiver@entry=0x27fa810, event=event@entry=0x3fac1a0) at kernel/qcoreapplication.cpp:946
#33 0x00007f6eaeb4ce1f in sendEvent (event=0x3fac1a0, receiver=0x27fa810) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x2283500) at kernel/qcoreapplication.cpp:1570
#35 0x00007f6eaeb4d2c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#36 0x00007f6eaeb77073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#37 postEventSourceDispatch (s=0x22b6a20) at kernel/qeventdispatcher_glib.cpp:279
#38 0x00007f6eab77b3b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f6eab77b708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f6eab77b7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f6eaeb76a55 in QEventDispatcherGlib::processEvents (this=0x2284de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#42 0x00007f6eaf5dc9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f6eaeb485ef in QEventLoop::processEvents (this=this@entry=0x7fff7d8bce90, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f6eaeb488e5 in QEventLoop::exec (this=this@entry=0x7fff7d8bce90, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f6eaeb4de5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#46 0x00007f6eaf53934c in QApplication::exec () at kernel/qapplication.cpp:3828
#47 0x000000000040ce11 in main (argc=5, argv=0x7fff7d8bd0c8) at /build/buildd/muon-2.1.1/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 328875.

Possible duplicates by query: bug 328931, bug 328875, bug 328633, bug 328536, bug 328475.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-06 02:55:43 UTC

*** This bug has been marked as a duplicate of bug 327544 ***