Bug 321383

Summary: KPatience crashed while resizing the application window
Product: [Applications] kpat Reporter: Alexander Nolting <a.nolting>
Component: generalAssignee: Stephan Kulow <coolo>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kde-games-bugs
Priority: NOR    
Version: 3.6   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alexander Nolting 2013-06-19 13:28:30 UTC
Application: kpat (3.6)
KDE Platform Version: 4.10.4 "release 569"
Qt Version: 4.8.4
Operating System: Linux 3.9.5-12.g08531e3-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I grabbed the lower right corner to resize the window in height and width. Application crashed while moving the mouse.

The crash does not seem to be reproducible.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f3c63aa83bd in lock (this=<optimized out>) at /usr/src/debug/kdelibs-4.10.4/kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff1731b720) at /usr/src/debug/kdelibs-4.10.4/kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f3c63aa8a10 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff1731b720, _d=<optimized out>) at /usr/src/debug/kdelibs-4.10.4/kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f3c63aa0a5e in KSharedDataCache::find (this=0xc77730, key=..., destination=0x7fff1731b790) at /usr/src/debug/kdelibs-4.10.4/kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f3c63fe29a2 in KImageCache::findPixmap (this=0xc77730, key=..., destination=0xad5c58) at /usr/src/debug/kdelibs-4.10.4/kdeui/util/kimagecache.cpp:150
#11 0x00007f3c64d1b88a in KAbstractCardDeckPrivate::requestPixmap (this=0xce8a20, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kpat-4.10.4/libkcardgame/kabstractcarddeck.cpp:205
#12 0x00007f3c64d1baa0 in KAbstractCardDeck::cardPixmap (this=<optimized out>, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kpat-4.10.4/libkcardgame/kabstractcarddeck.cpp:506
#13 0x00007f3c64d1e0e7 in KCard::paint (this=0xc59260, painter=0x7fff1731bfb0, option=<optimized out>, widget=<optimized out>) at /usr/src/debug/kpat-4.10.4/libkcardgame/kcard.cpp:319
#14 0x00007f3c62eb7f05 in QGraphicsScenePrivate::draw (this=this@entry=0xb9ea70, item=item@entry=0xc59270, painter=painter@entry=0x7fff1731bfb0, viewTransform=viewTransform@entry=0x7fff1731c140, transformPtr=transformPtr@entry=0x7fff1731bc50, exposedRegion=exposedRegion@entry=0xb324e8, widget=0xb36e30, opacity=opacity@entry=1, effectTransform=effectTransform@entry=0x0, wasDirtyParentSceneTransform=wasDirtyParentSceneTransform@entry=true, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
#15 0x00007f3c62eb8c85 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0xb9ea70, item=0xc59270, painter=painter@entry=0x7fff1731bfb0, viewTransform=viewTransform@entry=0x7fff1731c140, exposedRegion=exposedRegion@entry=0xb324e8, widget=widget@entry=0xb36e30, parentOpacity=parentOpacity@entry=1, effectTransform=effectTransform@entry=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x00007f3c62eb976e in QGraphicsScenePrivate::drawItems (this=0xb9ea70, painter=0x7fff1731bfb0, viewTransform=0x7fff1731c140, exposedRegion=0xb324e8, widget=0xb36e30) at graphicsview/qgraphicsscene.cpp:4739
#17 0x00007f3c62ed5a68 in QGraphicsView::paintEvent (this=0xb32000, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x00007f3c629140fe in QWidget::event (this=0xb32000, event=0x7fff1731cc00) at kernel/qwidget.cpp:8532
#19 0x00007f3c62cbef26 in QFrame::event (this=0xb32000, e=0x7fff1731cc00) at widgets/qframe.cpp:557
#20 0x00007f3c62ed6bbb in QGraphicsView::viewportEvent (this=0xb32000, event=0x7fff1731cc00) at graphicsview/qgraphicsview.cpp:2866
#21 0x00007f3c6351aef6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0xb36e30, event=0x7fff1731cc00) at kernel/qcoreapplication.cpp:1056
#22 0x00007f3c628c483c in QApplicationPrivate::notify_helper (this=this@entry=0x962d40, receiver=receiver@entry=0xb36e30, e=e@entry=0x7fff1731cc00) at kernel/qapplication.cpp:4558
#23 0x00007f3c628c8ceb in QApplication::notify (this=0x7fff1731ec10, receiver=0xb36e30, e=0x7fff1731cc00) at kernel/qapplication.cpp:4423
#24 0x00007f3c63f81146 in KApplication::notify (this=0x7fff1731ec10, receiver=0xb36e30, event=0x7fff1731cc00) at /usr/src/debug/kdelibs-4.10.4/kdeui/kernel/kapplication.cpp:311
#25 0x00007f3c6351ad8e in QCoreApplication::notifyInternal (this=0x7fff1731ec10, receiver=0xb36e30, event=0x7fff1731cc00) at kernel/qcoreapplication.cpp:946
#26 0x00007f3c6290fcc4 in sendSpontaneousEvent (event=0x7fff1731cc00, receiver=0xb36e30) at ../../src/corelib/kernel/qcoreapplication.h:234
#27 QWidgetPrivate::drawWidget (this=this@entry=0xb36fb0, pdev=pdev@entry=0xace170, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xa810e0) at kernel/qwidget.cpp:5598
#28 0x00007f3c629107bf in QWidgetPrivate::paintSiblingsRecursive (this=0xb32060, pdev=0xace170, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa810e0) at kernel/qwidget.cpp:5807
#29 0x00007f3c6290f855 in QWidgetPrivate::drawWidget (this=this@entry=0xb32060, pdev=pdev@entry=0xace170, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xa810e0) at kernel/qwidget.cpp:5651
#30 0x00007f3c629107bf in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0xaf68e0, pdev=pdev@entry=0xace170, siblings=..., index=<optimized out>, index@entry=10, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xa810e0) at kernel/qwidget.cpp:5807
#31 0x00007f3c62910604 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0xaf68e0, pdev=pdev@entry=0xace170, siblings=..., index=10, index@entry=12, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xa810e0) at kernel/qwidget.cpp:5794
#32 0x00007f3c62910604 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0xaf68e0, pdev=pdev@entry=0xace170, siblings=..., index=12, index@entry=18, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xa810e0) at kernel/qwidget.cpp:5794
#33 0x00007f3c62910604 in QWidgetPrivate::paintSiblingsRecursive (this=0xaf68e0, pdev=0xace170, siblings=..., index=18, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa810e0) at kernel/qwidget.cpp:5794
#34 0x00007f3c6290f855 in QWidgetPrivate::drawWidget (this=0xaf68e0, pdev=0xace170, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0xa810e0) at kernel/qwidget.cpp:5651
#35 0x00007f3c62ada168 in QWidgetBackingStore::sync (this=0xa810e0) at painting/qbackingstore.cpp:1373
#36 0x00007f3c62904960 in QWidgetPrivate::syncBackingStore (this=0xaf68e0) at kernel/qwidget.cpp:1896
#37 0x00007f3c62931370 in QETWidget::translateConfigEvent (this=this@entry=0xaf6790, event=event@entry=0x7fff1731e5b0) at kernel/qapplication_x11.cpp:5418
#38 0x00007f3c6293f013 in QApplication::x11ProcessEvent (this=0x7fff1731ec10, event=0x7fff1731e5b0) at kernel/qapplication_x11.cpp:3555
#39 0x00007f3c62964fa2 in x11EventSourceDispatch (s=0x954ae0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#40 0x00007f3c5d9bebf5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f3c5d9bef38 in ?? () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f3c5d9beff4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f3c635492c6 in QEventDispatcherGlib::processEvents (this=0x92aae0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007f3c62964c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f3c63519adf in QEventLoop::processEvents (this=this@entry=0x7fff1731e980, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f3c63519d68 in QEventLoop::exec (this=0x7fff1731e980, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007f3c6351ea08 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#48 0x000000000041989a in main (argc=3, argv=0x7fff1731edc8) at /usr/src/debug/kpat-4.10.4/main.cpp:325

Possible duplicates by query: bug 315929, bug 313924, bug 313545, bug 311966, bug 310421.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-06-20 09:46:08 UTC

*** This bug has been marked as a duplicate of bug 309824 ***