Bug 313678

Summary: Digikam fails to know which images in my camera is new
Product: digikam Reporter: Anders Lund <anders>
Component: Import-Gphoto2Assignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: benv-kde.org, caulier.gilles, dmpop, falolaf, kde, kde, kde, kdebugger, kmiller2794, lachlan, lenharo, nicofo, p1037905, robert.nurnberg, sbstnschmtt, spielmops, suseuser, wazery, wooolfy, xcsnake
Priority: NOR Flags: wazery: Junior_Jobs+
Version: 3.5.0   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In: 4.0.0

Description Anders Lund 2013-01-22 11:09:19 UTC
This is digikam 3.0rc3.

The problem is with the import dialog, downloading from my canon eos 30d camera. Before 3.0 series, "download new" worked,  but not anymore.

Reproducible: Always

Steps to Reproduce:
1. connect camera 
2. activate the import dialog
3. select "download new"
Actual Results:  
nothing happens

Expected Results:  
photos not yet in the digikam database imported
Comment 1 icon 2013-02-26 00:10:08 UTC
I can confirm that the same things happens to me.  I even tried deleting the digikam database and starting over.  It still does the same thing .
Comment 2 Nicofo 2013-03-07 19:03:12 UTC
Same problem for me with digikam-3.0.0-1.fc18.1.i686

Additional info:
- in the 'import window', every pictures  has a "info logo (i)" -> "The item download status is unknown"
- if I "Mark as downloaded" -> the "info logo" becomes a "V logo" (which indicates "item already downloaded") ; BUT if I close then reopen the import window => I get again "The item download status is unknown"
- the table "DownloadHistory" (from digikam4.db) is not modified after that operation or after a download.
Comment 3 falolaf 2013-03-08 09:46:36 UTC
Same thing happens to me. 

Manually built on openSUSE 12.2.
Comment 4 Nicofo 2013-03-20 21:27:27 UTC
Bug still present with digikam 3.1.0
Comment 5 falolaf 2013-03-22 11:23:06 UTC
Should add that I use a usb card reader with this behaviour.
Comment 6 caulier.gilles 2013-03-22 11:29:00 UTC
*** Bug 317179 has been marked as a duplicate of this bug. ***
Comment 7 Sebastian Schmitt 2013-04-13 11:05:20 UTC
Some problem. Absolute showstopper.
Comment 8 rick 2013-04-21 19:55:04 UTC
Same here 3.1.0 -- used to work.  Vote for this problem! Maybe it'll help move up its priority.
Comment 9 suseuser 2013-04-27 08:09:02 UTC
I have the same issue here on opensuse 12.3, digikam 3.1.0
Really annoying because this is (or was ...) a great feature! Hope you are able to solve it soon!
Thanks in advance.
Comment 10 Wouter de Geus 2013-05-03 15:42:28 UTC
Same problem here on Slackware 14, tried digikam 3.1.0 and 3.2.0-beta1.
I'm using libgphoto 2.5.1.1., my camera is a Canon EOS 600D.
Comment 11 Lachlan 2013-05-10 19:32:29 UTC
I have the same problem.  Every time I reconnect my card reader the Digikam import box shows all the files on the card, and every one has the (i) "This item download status is unknown" info mark.

This is a major issue for me.

Digikam 3.0.0 on Gentoo.
Comment 12 MickaëlG 2013-06-03 19:53:57 UTC
Same for me, with digikam 3.2.0 on archlinux, with a Nikon D60 camera and libgphoto 2.5.1.
Comment 13 Anders Lund 2013-06-30 17:27:10 UTC
Just a confirmation that this is still present in 3.2.0, along with the disfunctional renaming during import from camera (there is probably a separate bug report for that)
Comment 14 caulier.gilles 2013-06-30 17:31:02 UTC
yes, it is.

Simply code is commented on special place in Import UI. Look my comment here :

https://bugs.kde.org/show_bug.cgi?id=314441#c53

Gilles Caulier
Comment 15 Anders Lund 2013-06-30 17:33:15 UTC
Søndag den 30. juni 2013 17:31:02 skrev du:
> https://bugs.kde.org/show_bug.cgi?id=313678
> 
> --- Comment #14 from Gilles Caulier <caulier.gilles@gmail.com> ---
> yes, it is.

Wonderful :-)

> 
> Simply code is commented on special place in Import UI. Look my comment here
> :
> 
> https://bugs.kde.org/show_bug.cgi?id=314441#c53
> 
> Gilles Caulier
Comment 16 Nicofo 2013-08-22 20:53:07 UTC
Bug still present in version 3.3.0
Comment 17 falolaf 2013-08-23 06:44:48 UTC
Can this "easy" fix be considered for 3.4.0 maybe?
Comment 18 caulier.gilles 2013-08-23 06:58:15 UTC
Easy fix ???

Un-comment code is not enough to fix the problem. It miss code in new Qt4 model view implementation to handle download status and show an annotation in icon-view.

Gilles Caulier
Comment 19 falolaf 2013-08-23 07:26:46 UTC
Sorry Gilles! I just read "I think it can be fixed easily."...
Comment 20 Hartmut 2013-09-12 13:54:32 UTC
Still the same in digikam 3.4.0 on KDE 4.10

Hartmut
Comment 21 Robert Nurnberg 2013-09-29 20:37:03 UTC
Just to confirm that the same happens to me with digikam 3.1.0 in kde 4.10.5 under kubuntu 13.04.

Is there a quickfix or workaround? If not, any alternative program I can use in the meantime to download my photos from the camera?
Comment 22 caulier.gilles 2013-11-23 12:28:20 UTC
*** Bug 327969 has been marked as a duplicate of this bug. ***
Comment 23 Teemu Rytilahti 2013-12-05 21:20:43 UTC
*** Bug 281758 has been marked as a duplicate of this bug. ***
Comment 24 Teemu Rytilahti 2013-12-29 16:02:14 UTC
Git commit 3255a77ead05270ccef2f00627f76e9a324c3f3d by Teemu Rytilahti.
Committed on 22/12/2013 at 18:43.
Pushed by rytilahti into branch 'master'.

- Use KUrl and make sure that the folder has a trailing slash. Otherwise call to setFileName() causes the end of the path to be removed and breaking the URLs for history.
- When listing files, request the status from history database for the current state.
- Also use only model and path information for PTP cameras, as port number changes on the fly, therefore breaking the hashes. Unfortunately this means that the old download history for PTP devices is lost.
- Use DownloadedNo to indicate "new" photos for the time being.
FIXED-IN:4.0.0

M  +1    -0    libs/database/core/databasecorebackend.cpp
M  +4    -3    libs/database/downloadhistory.h
M  +5    -0    utilities/importui/backend/cameracontroller.cpp
M  +1    -0    utilities/importui/backend/camiteminfo.cpp
M  +2    -1    utilities/importui/backend/gpcamera.cpp
M  +1    -1    utilities/importui/items/importoverlays.cpp
M  +1    -1    utilities/importui/items/itemviewimportdelegate.cpp
M  +2    -0    utilities/importui/main/importui.cpp
M  +8    -2    utilities/importui/views/importiconview.cpp

http://commits.kde.org/digikam/3255a77ead05270ccef2f00627f76e9a324c3f3d