Bug 311661

Summary: folder view settings
Product: plasma4 Reporter: troy R <troyrileys8709>
Component: widget-folderviewAssignee: Ignat Semenov <i.semenov.kde>
Status: RESOLVED DUPLICATE    
Severity: crash CC: plasma-bugs
Priority: NOR    
Version: 4.9.3   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description troy R 2012-12-13 23:50:10 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.3
Qt Version: 4.8.3
Operating System: Linux 3.5.0-20-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
i was changing the layout of my destop to folder view. then the screen blinked and my computer said application crashed. now i have a blury folder on my destop.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1f11605780 (LWP 2033))]

Thread 4 (Thread 0x7f1f098ae700 (LWP 2035)):
#0  0x00007f1f24990303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1f1862fd84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1f1862fea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1f2163ec16 in QEventDispatcherGlib::processEvents (this=0x7f1f040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f1f2160f2bf in QEventLoop::processEvents (this=this@entry=0x7f1f098addd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1f2160f548 in QEventLoop::exec (this=0x7f1f098addd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f1f21510b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f1f215ef9af in QInotifyFileSystemWatcherEngine::run (this=0x226da00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1f21513aec in QThreadPrivate::start (arg=0x226da00) at thread/qthread_unix.cpp:338
#9  0x00007f1f18d2ee9a in start_thread (arg=0x7f1f098ae700) at pthread_create.c:308
#10 0x00007f1f2499bcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1f03fff700 (LWP 2036)):
#0  0x00007f1f2498e8bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f1f1866c15f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1f1862f914 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1f1862fd22 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1f1862fea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1f2163ec16 in QEventDispatcherGlib::processEvents (this=0x7f1efc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f1f2160f2bf in QEventLoop::processEvents (this=this@entry=0x7f1f03ffedd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f1f2160f548 in QEventLoop::exec (this=0x7f1f03ffedd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f1f21510b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f1f215ef9af in QInotifyFileSystemWatcherEngine::run (this=0x2418870) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f1f21513aec in QThreadPrivate::start (arg=0x2418870) at thread/qthread_unix.cpp:338
#11 0x00007f1f18d2ee9a in start_thread (arg=0x7f1f03fff700) at pthread_create.c:308
#12 0x00007f1f2499bcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1f00aab700 (LWP 2037)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1f1e695cd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f1f1e695d09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f1f18d2ee9a in start_thread (arg=0x7f1f00aab700) at pthread_create.c:308
#4  0x00007f1f2499bcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1f11605780 (LWP 2033)):
[KCrash Handler]
#6  0x00007f1f09d960b4 in ListView::updateSizeHint (this=0x247d890) at ../../../../plasma/applets/folderview/listview.cpp:209
#7  0x00007f1f21625f5f in QMetaObject::activate (sender=0x246a990, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#8  0x00007f1f24551c1f in themeChanged (this=0x247c5d0) at ../../plasma/svg.cpp:618
#9  Plasma::SvgPrivate::themeChanged (this=0x247c5d0) at ../../plasma/svg.cpp:601
#10 0x00007f1f24551e79 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./svg.moc:114
#11 Plasma::Svg::qt_static_metacall (_o=0x0, _c=1306161744, _id=-158160, _a=0x7fff4dda73e0) at ./svg.moc:106
#12 0x00007f1f21625f5f in QMetaObject::activate (sender=0x2058fd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#13 0x00007f1f2455a78b in Plasma::ThemePrivate::notifyOfChanged (this=0x2152920) at ../../plasma/theme.cpp:366
#14 0x00007f1f2455a969 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./theme.moc:102
#15 Plasma::Theme::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./theme.moc:88
#16 0x00007f1f21625f5f in QMetaObject::activate (sender=0x216aee0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#17 0x00007f1f2162526c in QObject::event (this=0x216aee0, e=<optimized out>) at kernel/qobject.cpp:1157
#18 0x00007f1f209b7e9c in QApplicationPrivate::notify_helper (this=this@entry=0x1fa5020, receiver=receiver@entry=0x216aee0, e=e@entry=0x7fff4dda7e90) at kernel/qapplication.cpp:4562
#19 0x00007f1f209bc30a in QApplication::notify (this=0x1f94740, receiver=0x216aee0, e=0x7fff4dda7e90) at kernel/qapplication.cpp:4423
#20 0x00007f1f222c91d6 in KApplication::notify (this=0x1f94740, receiver=0x216aee0, event=0x7fff4dda7e90) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007f1f2161056e in QCoreApplication::notifyInternal (this=0x1f94740, receiver=0x216aee0, event=0x7fff4dda7e90) at kernel/qcoreapplication.cpp:915
#22 0x00007f1f21641462 in sendEvent (event=0x7fff4dda7e90, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 QTimerInfoList::activateTimers (this=0x1fa7860) at kernel/qeventdispatcher_unix.cpp:611
#24 0x00007f1f2163e584 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#25 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#26 0x00007f1f2163e5a1 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#27 0x00007f1f1862fab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f1f1862fde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f1f1862fea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f1f2163ebf6 in QEventDispatcherGlib::processEvents (this=0x1f1fad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0x00007f1f20a5cc1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f1f2160f2bf in QEventLoop::processEvents (this=this@entry=0x7fff4dda8110, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f1f2160f548 in QEventLoop::exec (this=0x7fff4dda8110, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007f1f21614708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#35 0x00007f1f24ca2035 in kdemain (argc=1, argv=0x7fff4dda8408) at ../../../../plasma/desktop/shell/main.cpp:120
#36 0x00007f1f248c976d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7fff4dda8408, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff4dda83f8) at libc-start.c:226
#37 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 303770, bug 303681, bug 303123, bug 302011, bug 299531.

Reported using DrKonqi
Comment 1 Ignat Semenov 2012-12-23 11:01:55 UTC

*** This bug has been marked as a duplicate of bug 299077 ***