Bug 309372

Summary: contacts and their birthdays appears twice using carddav/owncloud
Product: Akonadi Reporter: Anders Lund <anders>
Component: DAV ResourceAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: greg
Priority: NOR    
Version: 4.9   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In: 4.10.2

Description Anders Lund 2012-11-01 14:36:42 UTC
Since KDE 4.9.2, the "default" addressbook in my owncloud resource misbehaves the following two ways:

* If I check bothe the root owncloud resource and the "default" subresource, contacts appears twice
* The "birthdays and anniversaries" resource doubles birthdays (and likely anniversaries) of contacts stored in my owncloud/default resource.

Reproducible: Always
Comment 1 Grégory Oestreicher 2012-11-21 21:26:30 UTC
I can't reproduce this with 4.9.3, do you still have the issue?
Comment 2 Anders Lund 2012-11-21 21:35:02 UTC
Sometimes. Most often, restarting akonadi fixes it.

I think this happens during updating trouble. I believe that my webdav resources are still not kept in any stable manner by akonadi, they loose their akonadi ids along with each item in them, leading to cpu abuse and breakage for example wrt contact groups.
Comment 3 Grégory Oestreicher 2012-11-23 20:33:52 UTC
*** Bug 305180 has been marked as a duplicate of this bug. ***
Comment 4 Grégory Oestreicher 2013-03-17 18:39:45 UTC
Git commit 7876766c7e65dfc515ad92467b2287a6c63af5a6 by Grégory Oestreicher.
Committed on 17/03/2013 at 19:37.
Pushed by goestreicher into branch 'KDE/4.10'.

Don't add mime types to the root collection

This seem to have many side effects, and the issue
that this was meant to address seems to have been
fixed since.
Related: bug 311240, bug 308835
FIXED-IN: 4.10.2

M  +0    -9    resources/dav/resource/davgroupwareresource.cpp

http://commits.kde.org/kdepim-runtime/7876766c7e65dfc515ad92467b2287a6c63af5a6