Bug 311240 - CalDAV calendar resource shows duplicate calendar
Summary: CalDAV calendar resource shows duplicate calendar
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: DAV Resource (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: 4.10
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-06 07:00 UTC by Sander van Grieken
Modified: 2013-03-17 18:39 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sander van Grieken 2012-12-06 07:00:12 UTC
On a SOGo server I have 2 calendars, Personal and Calendar2

Since upgrading from 4.9.3 to 4.9.4, in Kontact/Korganizer the 'Personal' calender shows up twice under the ScalableOGo resource. The Calender2 calender is shown only once, correctly.

When (un)checking one of the duplicated calendar entries, the other duplicate gets (un)checked too.

This happened both on the existing resource right after upgrading to 4.9.4, but also on a newly created SOGo resource.

Reproducible: Always

Steps to Reproduce:
1. Have at least 1 Calender on a CalDAV server
2. Add DAV Groupware resource in akonadi
3. Go to Korganizer
4. compare calendars  under DAV resource with server
Actual Results:  
Duplicate calendar entry

Expected Results:  
1 calendar entry for each calendar defined on server
Comment 1 Grégory Oestreicher 2012-12-08 08:30:00 UTC
Strange. Could you check in Akonadi console how many calendars are present (look in the 'Browser' tab)? If you could also look at the mime-types reported for those calendars that are duplicated and the mime-types of those that aren't that'll help.

Thanks,
Grégory
Comment 2 Sander van Grieken 2012-12-08 11:12:29 UTC
In the browser tab there's only one entry for the calendar. 
The Internals tab shows invalid/invalid for the mimetype, just like all other resources 

When rightclick and open its properties, then Internals tab there's the following mimetypes:

application/x-vnd.akonadi.calendar.event
application/x-vnd.akonadi.calendar.todo

But those are also present for the non-duplicated calendar
Comment 3 Matija Šuklje 2013-01-22 08:36:20 UTC
Happens to me on 4.9.3 as well in connection with ownCloud (any version so far).

Oddly enough it doesn’t happen to me with Baïkal, which is just as ownCloud (using SabreDAV 1.6.4) a SabreDAV-based (1.8.0, so newer) CalDAV and CardDAV server.

I don’t know if it’s related, but I did notice (due to some other bug I found) that in both WebDAV instances I tried, Akonadi at some point wrongly changes todo items’ mimetypes to application/x-vnd.akonadi.calendar.event.
Comment 4 Alexander Maret-Huskinson 2013-02-14 19:03:59 UTC
I got the same problem with Zarafa 7.1.x and KDE 4.10.0.

There is only one Akonadi resource configured but KOrganizer displays two entries below the "Zarafa" tree item in the lower left section of the KOrganizer window where you can enable/disable each calendar.

Clicking on one of the calendar entries will also enable/disable the other one. They seem to be linked together.
Comment 5 Grégory Oestreicher 2013-03-17 18:39:45 UTC
Git commit 7876766c7e65dfc515ad92467b2287a6c63af5a6 by Grégory Oestreicher.
Committed on 17/03/2013 at 19:37.
Pushed by goestreicher into branch 'KDE/4.10'.

Don't add mime types to the root collection

This seem to have many side effects, and the issue
that this was meant to address seems to have been
fixed since.
Related: bug 308835, bug 309372
FIXED-IN: 4.10.2

M  +0    -9    resources/dav/resource/davgroupwareresource.cpp

http://commits.kde.org/kdepim-runtime/7876766c7e65dfc515ad92467b2287a6c63af5a6