Bug 308835 - double instances of carddav contacts
Summary: double instances of carddav contacts
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: DAV Resource (show other bugs)
Version: 4.9
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-22 21:18 UTC by Anders Lund
Modified: 2013-03-17 18:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Lund 2012-10-22 21:18:47 UTC
Since updating to KDE 4.9.2, KAddressbook have the following weird behavior with my owncloud resource, which contain two addressbooks - "default" and "Sejlere":

* The resource is represented by a tree in the resrouce view:
  [x] Owncloud
      [ ] default
      [ ] Sejlere
  
  Note that it is now enabled when I open KAddressbook, which is good, but
* If I check the checkbox for "default", all contacts in that addressbook will appear twice in kaddressbook
* It is not possible to display "Sejlere", but not "default"


Reproducible: Always
Comment 1 Grégory Oestreicher 2013-03-17 18:39:45 UTC
Git commit 7876766c7e65dfc515ad92467b2287a6c63af5a6 by Grégory Oestreicher.
Committed on 17/03/2013 at 19:37.
Pushed by goestreicher into branch 'KDE/4.10'.

Don't add mime types to the root collection

This seem to have many side effects, and the issue
that this was meant to address seems to have been
fixed since.
Related: bug 311240, bug 309372
FIXED-IN: 4.10.2

M  +0    -9    resources/dav/resource/davgroupwareresource.cpp

http://commits.kde.org/kdepim-runtime/7876766c7e65dfc515ad92467b2287a6c63af5a6