Bug 304451

Summary: Gwenview error while watching photos.
Product: gwenview Reporter: porszak17
Component: generalAssignee: Gwenview Bugs <gwenview-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: aldobelus.fake, andreas, benni, dsgoncalez, franz666es, jarekj83, pvelasco82
Priority: NOR    
Version: 2.8.4   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 2.9.5
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi

Description porszak17 2012-08-02 17:25:44 UTC
Application: gwenview (2.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic i686
Distribution: Linux Mint 13 Maya

-- Information about the crash:
Application was working well, until i've wanted to rotate one photo.
Always crashes on the same photos, but not on all of them.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Floating point exception
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb7753740 (LWP 6815))]

Thread 3 (Thread 0xb4f90b40 (LWP 6816)):
#0  0x0133bb7e in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x0133c042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0133c201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00d838e7 in QEventDispatcherGlib::processEvents (this=0xb4600468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00d4f50d in QEventLoop::processEvents (this=0xb4f90240, flags=...) at kernel/qeventloop.cpp:149
#5  0x00d4f7a9 in QEventLoop::exec (this=0xb4f90240, flags=...) at kernel/qeventloop.cpp:204
#6  0x00c3894c in QThread::exec (this=0x9dbc9d0) at thread/qthread.cpp:501
#7  0x00d2cb5d in QInotifyFileSystemWatcherEngine::run (this=0x9dbc9d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00c3bde0 in QThreadPrivate::start (arg=0x9dbc9d0) at thread/qthread_unix.cpp:298
#9  0x00b81d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00a22ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb45ffb40 (LWP 6817)):
#0  0x00937416 in __kernel_vsyscall ()
#1  0x00a14380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x01349a7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0133c0ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0133c201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00d838e7 in QEventDispatcherGlib::processEvents (this=0xb3c00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00d4f50d in QEventLoop::processEvents (this=0xb45ff240, flags=...) at kernel/qeventloop.cpp:149
#7  0x00d4f7a9 in QEventLoop::exec (this=0xb45ff240, flags=...) at kernel/qeventloop.cpp:204
#8  0x00c3894c in QThread::exec (this=0xa01ed88) at thread/qthread.cpp:501
#9  0x00d2cb5d in QInotifyFileSystemWatcherEngine::run (this=0xa01ed88) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00c3bde0 in QThreadPrivate::start (arg=0xa01ed88) at thread/qthread_unix.cpp:298
#11 0x00b81d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00a22ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7753740 (LWP 6815)):
[KCrash Handler]
#7  0x00179352 in Gwenview::LoadingIndicator::showNextFrame (this=0xa2675f8) at ../../lib/documentview/loadingindicator.cpp:78
#8  0x00d676b1 in QMetaObject::activate (sender=0xa29f270, m=0xeae4d8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#9  0x00dba625 in QTimer::timeout (this=0xa29f270) at .moc/release-shared/moc_qtimer.cpp:148
#10 0x00d70566 in QTimer::timerEvent (this=0xa29f270, e=0xbff0170c) at kernel/qtimer.cpp:280
#11 0x00d6bac4 in QObject::event (this=0xa29f270, e=0xbff0170c) at kernel/qobject.cpp:1157
#12 0x01ce4ed4 in notify_helper (e=0xbff0170c, receiver=0xa29f270, this=0x9c60320) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0x9c60320, receiver=0xa29f270, e=0xbff0170c) at kernel/qapplication.cpp:4531
#14 0x01cea30d in QApplication::notify (this=0xbff0170c, receiver=0xa29f270, e=0xbff0170c) at kernel/qapplication.cpp:4288
#15 0x0109e401 in KApplication::notify (this=0xbff01a28, receiver=0xa29f270, event=0xbff0170c) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00d5097e in QCoreApplication::notifyInternal (this=0xbff01a28, receiver=0xa29f270, event=0xbff0170c) at kernel/qcoreapplication.cpp:876
#17 0x00d85990 in sendEvent (event=0xbff0170c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QTimerInfoList::activateTimers (this=0x9c5ebe4) at kernel/qeventdispatcher_unix.cpp:611
#19 0x00d830f8 in timerSourceDispatch (source=0x9c5ebb0) at kernel/qeventdispatcher_glib.cpp:186
#20 timerSourceDispatch (source=0x9c5ebb0) at kernel/qeventdispatcher_glib.cpp:180
#21 0x0133bd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0x0133c125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0x0133c201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0x00d83887 in QEventDispatcherGlib::processEvents (this=0x9c3c5d8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x01d9daaa in QGuiEventDispatcherGlib::processEvents (this=0x9c3c5d8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00d4f50d in QEventLoop::processEvents (this=0xbff01974, flags=...) at kernel/qeventloop.cpp:149
#27 0x00d4f7a9 in QEventLoop::exec (this=0xbff01974, flags=...) at kernel/qeventloop.cpp:204
#28 0x00d54eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x01ce2a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#30 0x080661fd in main (argc=<error reading variable: Cannot access memory at address 0x0>, argv=<error reading variable: Cannot access memory at address 0x4>) at ../../app/main.cpp:142

Reported using DrKonqi
Comment 1 Aurelien Gateau 2012-08-06 15:05:09 UTC
This could happen if the icon used to show progress cannot be loaded. Are you by chance using an icon theme which is not Oxygen?
Comment 2 Jekyll Wu 2012-10-15 21:20:19 UTC
*** Bug 308458 has been marked as a duplicate of this bug. ***
Comment 3 aldobel 2012-11-11 02:34:55 UTC
Created attachment 75170 [details]
New crash information added by DrKonqi

gwenview (2.8.5) on KDE Platform 4.8.5 (4.8.5) "release 2" using Qt 4.8.1

- What I was doing when the application crashed:


I had opened multiple applications. If you ask me I give you the list of what were. When was organizing folders with Dolphin I opened an image file, a .jpg, and Gneview managed it. Wanting to rotate it to see it better, it did crash, shutting down the application, of course...Responding to the question that you had made to the person who start this notification, about what icons set we were using at the time of the failure, I can tell you that the mine one is Nitrux. Ask for more info when you need...

-- Backtrace (Reduced):
#7  0xb765c5d2 in Gwenview::LoadingIndicator::showNextFrame (this=0xa680738) at /usr/src/debug/gwenview-4.8.5/lib/documentview/loadingindicator.cpp:78
[...]
#9  0xb7212375 in QTimer::timeout (this=0xa61e608) at .moc/release-shared/moc_qtimer.cpp:148
#10 0xb71c8016 in QTimer::timerEvent (this=0xa61e608, e=0xbff2e040) at kernel/qtimer.cpp:280
#11 0xb71bed24 in QObject::event (this=0xa61e608, e=0xbff2e040) at kernel/qobject.cpp:1166
#12 0xb5e7daec in QApplicationPrivate::notify_helper (this=0xa0247a8, receiver=0xa61e608, e=0xbff2e040) at kernel/qapplication.cpp:4554
Comment 4 timeknows 2012-11-26 04:08:31 UTC
Created attachment 75483 [details]
New crash information added by DrKonqi

gwenview (2.9.1) on KDE Platform 4.9.2 using Qt 4.8.3

- What I was doing when the application crashed:
zooming a picture (.jpg) : happens all the time, but not with all pics.
- Custom settings of the application:
history disabled

-- Backtrace (Reduced):
#6  Gwenview::LoadingIndicator::showNextFrame (this=0x18bbcc0) at ../../lib/documentview/loadingindicator.cpp:78
[...]
#8  0x00007f6f7650726c in QObject::event (this=0x2b0d4d0, e=<optimized out>) at kernel/qobject.cpp:1157
#9  0x00007f6f74d63e9c in QApplicationPrivate::notify_helper (this=this@entry=0x15b0300, receiver=receiver@entry=0x2b0d4d0, e=e@entry=0x7fff4fe5e570) at kernel/qapplication.cpp:4562
#10 0x00007f6f74d6830a in QApplication::notify (this=0x7fff4fe5e910, receiver=0x2b0d4d0, e=0x7fff4fe5e570) at kernel/qapplication.cpp:4423
#11 0x00007f6f75a6c1d6 in KApplication::notify (this=0x7fff4fe5e910, receiver=0x2b0d4d0, event=0x7fff4fe5e570) at ../../kdeui/kernel/kapplication.cpp:311
Comment 5 Andreas 2012-11-29 09:16:50 UTC
(In reply to comment #3)
> Created attachment 75170 [details]
> New crash information added by DrKonqi
> 
> gwenview (2.8.5) on KDE Platform 4.8.5 (4.8.5) "release 2" using Qt 4.8.1
> 
> - What I was doing when the application crashed:
> 
> 
> I had opened multiple applications. If you ask me I give you the list of
> what were. When was organizing folders with Dolphin I opened an image file,
> a .jpg, and Gneview managed it. Wanting to rotate it to see it better, it
> did crash, shutting down the application, of course...Responding to the
> question that you had made to the person who start this notification, about
> what icons set we were using at the time of the failure, I can tell you that
> the mine one is Nitrux. Ask for more info when you need...
> 
> -- Backtrace (Reduced):
> #7  0xb765c5d2 in Gwenview::LoadingIndicator::showNextFrame (this=0xa680738)
> at /usr/src/debug/gwenview-4.8.5/lib/documentview/loadingindicator.cpp:78
> [...]
> #9  0xb7212375 in QTimer::timeout (this=0xa61e608) at
> .moc/release-shared/moc_qtimer.cpp:148
> #10 0xb71c8016 in QTimer::timerEvent (this=0xa61e608, e=0xbff2e040) at
> kernel/qtimer.cpp:280
> #11 0xb71bed24 in QObject::event (this=0xa61e608, e=0xbff2e040) at
> kernel/qobject.cpp:1166
> #12 0xb5e7daec in QApplicationPrivate::notify_helper (this=0xa0247a8,
> receiver=0xa61e608, e=0xbff2e040) at kernel/qapplication.cpp:4554

Same here, the icon-theme is nitrux, when i change to oxygen no crashes
Comment 6 Benni Hill 2012-12-13 19:10:34 UTC
(In reply to comment #5)
> Same here, the icon-theme is nitrux, when i change to oxygen no crashes
Comment 7 Benni Hill 2012-12-13 21:27:28 UTC
I could reproduce this with the nitrux icon-theme in current git master (fe4b195 Fix for Bug 282235 - Gwenview crashes after rotating picture).
Comment 8 Andreas 2012-12-14 06:14:50 UTC
You can stop the crashes, when you copy the process-idle-kde.png and the process-working-kde.png to NITRUX/animations/16, 22, 32 and 48.
Comment 9 Benni Hill 2012-12-27 02:04:12 UTC
*** Bug 310000 has been marked as a duplicate of this bug. ***
Comment 10 Benni Hill 2012-12-27 02:06:30 UTC
*** Bug 295942 has been marked as a duplicate of this bug. ***
Comment 11 Benni Hill 2012-12-27 02:52:02 UTC
https://git.reviewboard.kde.org/r/107932/
Comment 12 Benni Hill 2012-12-27 11:26:14 UTC
Git commit 5083170e83edeabe91b35a27626c51e4086452fb by Benjamin Löwe.
Committed on 27/12/2012 at 03:46.
Pushed by bennihill into branch 'KDE/4.9'.

Fix for bug 304451 - Gwenview error while watching photos:
Don't show next frame when there are none.
REVIEW: 107932
FIXED-IN: 2.9.5

M  +4    -2    lib/documentview/loadingindicator.cpp

http://commits.kde.org/gwenview/5083170e83edeabe91b35a27626c51e4086452fb