Bug 295942 - Crash on load aplication [Gwenview::LoadingIndicator::showNextFrame]
Summary: Crash on load aplication [Gwenview::LoadingIndicator::showNextFrame]
Status: RESOLVED DUPLICATE of bug 304451
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.8.1
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
: 305754 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-13 16:47 UTC by franz666es
Modified: 2012-12-27 02:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description franz666es 2012-03-13 16:47:06 UTC
Application: akregator (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.2.0-18-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
Downloading several archives with Synaptic and ipfilter.dat

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Floating point exception
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4524f117c0 (LWP 7548))]

Thread 2 (Thread 0x7f44fb294700 (LWP 7560)):
#0  timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f44fb293c2c) at kernel/qeventdispatcher_glib.cpp:142
#1  0x00007f4522691075 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#2  0x00007f451cb5985e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f451cb5a05b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f451cb5a264 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4522691a76 in QEventDispatcherGlib::processEvents (this=0x7f44f40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f45226612d2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4522661527 in QEventLoop::exec (this=0x7f44fb293d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4522560f97 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f452264106f in QInotifyFileSystemWatcherEngine::run (this=0x12d1600) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f4522563fbb in QThreadPrivate::start (arg=0x12d1600) at thread/qthread_unix.cpp:298
#11 0x00007f451d026e9a in start_thread (arg=0x7f44fb294700) at pthread_create.c:308
#12 0x00007f4521a8a74d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4524f117c0 (LWP 7548)):
[KCrash Handler]
#6  0x00007f450013d8cd in Gwenview::LoadingIndicator::showNextFrame (this=0x142c640) at ../../lib/documentview/loadingindicator.cpp:78
#7  0x00007f45226768d1 in QMetaObject::activate (sender=0x142c2e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#8  0x00007f452267b7c9 in QObject::event (this=0x142c2e0, e=<optimized out>) at kernel/qobject.cpp:1157
#9  0x00007f45230576b4 in notify_helper (e=0x7fffe5e141a0, receiver=0x142c2e0, this=0xa33080) at kernel/qapplication.cpp:4555
#10 QApplicationPrivate::notify_helper (this=0xa33080, receiver=0x142c2e0, e=0x7fffe5e141a0) at kernel/qapplication.cpp:4527
#11 0x00007f452305c533 in QApplication::notify (this=0x7fffe5e14450, receiver=0x142c2e0, e=0x7fffe5e141a0) at kernel/qapplication.cpp:4416
#12 0x00007f4523d90906 in KApplication::notify (this=0x7fffe5e14450, receiver=0x142c2e0, event=0x7fffe5e141a0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f45226624ec in QCoreApplication::notifyInternal (this=0x7fffe5e14450, receiver=0x142c2e0, event=0x7fffe5e141a0) at kernel/qcoreapplication.cpp:876
#14 0x00007f4522693842 in sendEvent (event=0x7fffe5e141a0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QTimerInfoList::activateTimers (this=0xa37960) at kernel/qeventdispatcher_unix.cpp:611
#16 0x00007f452269125d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#17 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#18 0x00007f451cb59dda in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f451cb5a1a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f451cb5a264 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f4522691a0f in QEventDispatcherGlib::processEvents (this=0x9f9e60, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f45230ffaae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f45226612d2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f4522661527 in QEventLoop::exec (this=0x7fffe5e14400, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f45226665b7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000407d9c in ?? ()
#27 0x00007f45219bb76d in __libc_start_main (main=0x4078b0, argc=1, ubp_av=0x7fffe5e14728, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffe5e14718) at libc-start.c:226
#28 0x000000000040805d in _start ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-26 05:10:00 UTC
*** Bug 305754 has been marked as a duplicate of this bug. ***
Comment 2 Benni Hill 2012-12-27 02:06:30 UTC

*** This bug has been marked as a duplicate of bug 304451 ***