Bug 310000 - Gwenview closes when working with images
Summary: Gwenview closes when working with images
Status: RESOLVED DUPLICATE of bug 304451
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.9.1
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-13 01:41 UTC by Daniel Gonçalez
Modified: 2012-12-27 02:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Message of error (54.36 KB, image/png)
2012-11-17 20:45 UTC, Daniel Gonçalez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Gonçalez 2012-11-13 01:41:05 UTC
Application: gwenview (2.9.1)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.5.0-18-generic i686
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
Resizing an image

- Unusual behavior I noticed:
Application closes when dealing with high resolution images, or when trying to edit any image.

-- Backtrace:
Application: Gwenview (gwenview), signal: Floating point exception
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb776a740 (LWP 10624))]

Thread 3 (Thread 0xb5150b40 (LWP 10625)):
#0  0x4204bc64 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x4213acc0 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x420f8f26 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x420f9ba8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x420f9e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x42a93eff in QEventDispatcherGlib::processEvents (this=0xb4800468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x42a607cc in QEventLoop::processEvents (this=this@entry=0xb5150228, flags=...) at kernel/qeventloop.cpp:149
#7  0x42a60ac1 in QEventLoop::exec (this=0xb5150228, flags=...) at kernel/qeventloop.cpp:204
#8  0x4294bbcc in QThread::exec (this=0x9acd800) at thread/qthread.cpp:501
#9  0x42a3ed1d in QInotifyFileSystemWatcherEngine::run (this=0x9acd800) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x4294efb8 in QThreadPrivate::start (arg=0x9acd800) at thread/qthread_unix.cpp:338
#11 0x42048d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x41f7dd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb440cb40 (LWP 10626)):
#0  0x4204adc8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x4213ac80 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x420f97cd in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x420f9c92 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x420f9e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x42a93eff in QEventDispatcherGlib::processEvents (this=0xb3b00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x42a607cc in QEventLoop::processEvents (this=this@entry=0xb440c228, flags=...) at kernel/qeventloop.cpp:149
#7  0x42a60ac1 in QEventLoop::exec (this=0xb440c228, flags=...) at kernel/qeventloop.cpp:204
#8  0x4294bbcc in QThread::exec (this=0x9d24d50) at thread/qthread.cpp:501
#9  0x42a3ed1d in QInotifyFileSystemWatcherEngine::run (this=0x9d24d50) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x4294efb8 in QThreadPrivate::start (arg=0x9d24d50) at thread/qthread_unix.cpp:338
#11 0x42048d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x41f7dd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb776a740 (LWP 10624)):
[KCrash Handler]
#7  0x4917cd42 in Gwenview::LoadingIndicator::showNextFrame (this=0x9dc9630) at ../../lib/documentview/loadingindicator.cpp:78
#8  0x42a7a436 in QMetaObject::activate (sender=0x9d954f8, m=0x42bc6a18 <QTimer::staticMetaObject>, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#9  0x42acafb5 in QTimer::timeout (this=0x9d954f8) at .moc/release-shared/moc_qtimer.cpp:148
#10 0x42a81436 in QTimer::timerEvent (this=0x9d954f8, e=0xbfd0d9d0) at kernel/qtimer.cpp:280
#11 0x42a78294 in QObject::event (this=0x9d954f8, e=0xbfd0d9d0) at kernel/qobject.cpp:1157
#12 0x42debb3c in QApplicationPrivate::notify_helper (this=0x9944af8, receiver=0x9d954f8, e=0xbfd0d9d0) at kernel/qapplication.cpp:4562
#13 0x42df054f in QApplication::notify (this=0xbfd0d9d0, receiver=0x9d954f8, e=0xbfd0d9d0) at kernel/qapplication.cpp:3944
#14 0x440bd8f1 in KApplication::notify (this=0xbfd0dd20, receiver=0x9d954f8, event=0xbfd0d9d0) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x42a61cee in QCoreApplication::notifyInternal (this=0xbfd0dd20, receiver=0x9d954f8, event=0xbfd0d9d0) at kernel/qcoreapplication.cpp:915
#16 0x42a967e0 in sendEvent (event=0xbfd0d9d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QTimerInfoList::activateTimers (this=0x993cf74) at kernel/qeventdispatcher_unix.cpp:611
#18 0x42a93868 in timerSourceDispatch (source=0x993cf40) at kernel/qeventdispatcher_glib.cpp:186
#19 timerSourceDispatch (source=0x993cf40) at kernel/qeventdispatcher_glib.cpp:180
#20 0x42a938a2 in idleTimerSourceDispatch (source=0x993ce18) at kernel/qeventdispatcher_glib.cpp:233
#21 0x420f99e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0x420f9d80 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0x420f9e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0x42a93ee1 in QEventDispatcherGlib::processEvents (this=0x991a5d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x42ea214a in QGuiEventDispatcherGlib::processEvents (this=0x991a5d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x42a607cc in QEventLoop::processEvents (this=this@entry=0xbfd0dc58, flags=...) at kernel/qeventloop.cpp:149
#27 0x42a60ac1 in QEventLoop::exec (this=0xbfd0dc58, flags=...) at kernel/qeventloop.cpp:204
#28 0x42a6621a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#29 0x42de9764 in QApplication::exec () at kernel/qapplication.cpp:3823
#30 0x080669a7 in main (argc=6, argv=0xbfd0de04) at ../../app/main.cpp:142

Possible duplicates by query: bug 308458, bug 304451.

Reported using DrKonqi
Comment 1 Daniel Gonçalez 2012-11-17 20:45:22 UTC
Created attachment 75318 [details]
Message of error
Comment 2 Benni Hill 2012-12-27 02:04:12 UTC

*** This bug has been marked as a duplicate of bug 304451 ***