Bug 308458 - crash when zoomin photos (always)
Summary: crash when zoomin photos (always)
Status: RESOLVED DUPLICATE of bug 304451
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.9.1
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-15 20:37 UTC by Jarek
Modified: 2012-10-19 13:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jarek 2012-10-15 20:37:13 UTC
Application: gwenview (2.9.1)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic i686
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

watchin my pictures, and everytime when i want to zoom them, gwenview is crashin (hand zoom, not 100% zoom)

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Floating point exception
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb43f2740 (LWP 3444))]

Thread 3 (Thread 0xb1c7eb40 (LWP 3446)):
#0  0xb50c9dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb7096fb5 in do_gettime (frac=0xb1c7df70, sec=0xb1c7df68) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb717e36e in QTimerInfoList::updateCurrentTime (this=0xb1302074) at kernel/qeventdispatcher_unix.cpp:343
#4  0x7fffffff in ?? ()
#5  0xb717e6fa in QTimerInfoList::timerWait (this=0xb1302074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x7fffffff in ?? ()

Thread 2 (Thread 0xb0f1db40 (LWP 3447)):
#0  0xb50c9dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb7096fb5 in do_gettime (frac=0xb0f1cf70, sec=0xb0f1cf68) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb717e36e in QTimerInfoList::updateCurrentTime (this=0xb0602074) at kernel/qeventdispatcher_unix.cpp:343
#4  0x7fffffff in ?? ()
#5  0xb717e6fa in QTimerInfoList::timerWait (this=0xb0602074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x7fffffff in ?? ()

Thread 1 (Thread 0xb43f2740 (LWP 3444)):
[KCrash Handler]
#7  0xb75f1ac2 in Gwenview::LoadingIndicator::showNextFrame (this=0x9c9e418) at ../../lib/documentview/loadingindicator.cpp:78
#8  0xb7163ed6 in QMetaObject::activate (sender=0x9c4c5c8, m=0xb72b04b8 <QTimer::staticMetaObject>, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#9  0xb71b4a55 in QTimer::timeout (this=0x9c4c5c8) at .moc/release-shared/moc_qtimer.cpp:148
#10 0xb716aed6 in QTimer::timerEvent (this=0x9c4c5c8, e=0xbfadb780) at kernel/qtimer.cpp:280
#11 0xb7161d34 in QObject::event (this=0x9c4c5c8, e=0xbfadb780) at kernel/qobject.cpp:1157
#12 0xb610939c in QApplicationPrivate::notify_helper (this=0x95cb050, receiver=0x9c4c5c8, e=0xbfadb780) at kernel/qapplication.cpp:4562
#13 0xb610ddaf in QApplication::notify (this=0xbfadb780, receiver=0x9c4c5c8, e=0xbfadb780) at kernel/qapplication.cpp:3944
#14 0xb6c7ce91 in KApplication::notify (this=0xbfadbad0, receiver=0x9c4c5c8, event=0xbfadb780) at ../../kdeui/kernel/kapplication.cpp:311
#15 0xb714b78e in QCoreApplication::notifyInternal (this=0xbfadbad0, receiver=0x9c4c5c8, event=0xbfadb780) at kernel/qcoreapplication.cpp:915
#16 0xb7180280 in sendEvent (event=0xbfadb780, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QTimerInfoList::activateTimers (this=0x95c5434) at kernel/qeventdispatcher_unix.cpp:611
#18 0xb717d308 in timerSourceDispatch (source=0x95c5400) at kernel/qeventdispatcher_glib.cpp:186
#19 timerSourceDispatch (source=0x95c5400) at kernel/qeventdispatcher_glib.cpp:180
#20 0xb717d342 in idleTimerSourceDispatch (source=0x95cbac0) at kernel/qeventdispatcher_glib.cpp:233
#21 0xb50119e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0xb5011d80 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb5011e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb717d981 in QEventDispatcherGlib::processEvents (this=0x95a05b8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0xb61bf9aa in QGuiEventDispatcherGlib::processEvents (this=0x95a05b8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0xb714a26c in QEventLoop::processEvents (this=this@entry=0xbfadba08, flags=...) at kernel/qeventloop.cpp:149
#27 0xb714a561 in QEventLoop::exec (this=0xbfadba08, flags=...) at kernel/qeventloop.cpp:204
#28 0xb714fcba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#29 0xb6106fc4 in QApplication::exec () at kernel/qapplication.cpp:3823
#30 0x080669a7 in main (argc=6, argv=0xbfadbbb4) at ../../app/main.cpp:142

Possible duplicates by query: bug 304451.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-10-15 21:20:19 UTC

*** This bug has been marked as a duplicate of bug 304451 ***