Bug 294798

Summary: Muon Software Center Crash
Product: kde Reporter: Eugene <echipizubov>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Eugene 2012-02-25 09:45:51 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was just starting it. an got The KDE Crash handler window. IT repeats every time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7748930 (LWP 2093))]

Thread 2 (Thread 0xb59b1b70 (LWP 2094)):
#0  0x00c2cd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x006237d5 in do_gettime (frac=0xb59b1020, sec=0xb59b1018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x006f64b6 in QTimerInfoList::updateCurrentTime (this=0x951d0ac) at kernel/qeventdispatcher_unix.cpp:339
#4  0x006f680a in QTimerInfoList::timerWait (this=0x951d0ac, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x006f5053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb59b112c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x006f50ed in timerSourcePrepare (source=0x951d078, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01c1688c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01c17637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01c17c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x006f5b37 in QEventDispatcherGlib::processEvents (this=0x9510720, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x006c61dd in QEventLoop::processEvents (this=0xb59b12b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x006c6421 in QEventLoop::exec (this=0xb59b12b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x005c990b in QThread::exec (this=0x94c2fa0) at thread/qthread.cpp:498
#14 0x006a6e2d in QInotifyFileSystemWatcherEngine::run (this=0x94c2fa0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x005cc7b3 in QThreadPrivate::start (arg=0x94c2fa0) at thread/qthread_unix.cpp:331
#16 0x008fcd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00aa40ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7748930 (LWP 2093)):
[KCrash Handler]
#7  0x00620e11 in QtPrivate::QStringList_contains (that=0xbf82cb24, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf82cb24) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x94ad0c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x94ad0c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf82cd44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x006cdb7d in metacall (argv=0xbf82cd44, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x94ad0c0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x94ad0c0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf82cd44) at kernel/qmetaobject.cpp:232
#13 0x006dca6a in QMetaObject::activate (sender=0x94f8670, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x94f8670) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x94f8670, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf82ce88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x006cdb7d in metacall (argv=0xbf82ce88, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x94f8670) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x94f8670, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf82ce88) at kernel/qmetaobject.cpp:232
#18 0x006dca6a in QMetaObject::activate (sender=0x94ad0c0, m=0x80950c0, local_signal_index=0, argv=0xbf82ce88) at kernel/qobject.cpp:3278
#19 0x00ca07c5 in MuonMainWindow::backendReady (this=0x94ad0c0, _t1=0x94c8560) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00ca0933 in MuonMainWindow::initObject (this=0x94ad0c0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x94ad0c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x94ad0c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf82cfb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x006cdb7d in metacall (argv=0xbf82cfb4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x94ad0c0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x94ad0c0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf82cfb4) at kernel/qmetaobject.cpp:232
#25 0x006dca6a in QMetaObject::activate (sender=0x952bbc0, m=0x7fd238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x006e4375 in QSingleShotTimer::timeout (this=0x952bbc0) at .moc/release-shared/qtimer.moc:82
#27 0x006e442c in QSingleShotTimer::timerEvent (this=0x952bbc0) at kernel/qtimer.cpp:308
#28 0x006df994 in QObject::event (this=0x952bbc0, e=0xbf82d3ac) at kernel/qobject.cpp:1181
#29 0x01265d84 in notify_helper (e=0xbf82d3ac, receiver=0x952bbc0, this=0x93b25b8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x93b25b8, receiver=0x952bbc0, e=0xbf82d3ac) at kernel/qapplication.cpp:4458
#31 0x0126b133 in QApplication::notify (this=0xbf82d3ac, receiver=0x952bbc0, e=0xbf82d3ac) at kernel/qapplication.cpp:3886
#32 0x00ebb971 in KApplication::notify (this=0xbf82d6c0, receiver=0x952bbc0, event=0xbf82d3ac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x006c719e in QCoreApplication::notifyInternal (this=0xbf82d6c0, receiver=0x952bbc0, event=0xbf82d3ac) at kernel/qcoreapplication.cpp:787
#34 0x006f7c10 in sendEvent (event=0xbf82d3ac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x93b307c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x006f5122 in timerSourceDispatch (source=0x93b3048) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01c1725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01c17990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01c17c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x006f5ada in QEventDispatcherGlib::processEvents (this=0x9395238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0131de7a in QGuiEventDispatcherGlib::processEvents (this=0x9395238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006c61dd in QEventLoop::processEvents (this=0xbf82d624, flags=...) at kernel/qeventloop.cpp:149
#43 0x006c6421 in QEventLoop::exec (this=0xbf82d624, flags=...) at kernel/qeventloop.cpp:201
#44 0x006cb19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01263924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 294788, bug 294767, bug 294731, bug 294696, bug 294662.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-25 09:58:40 UTC

*** This bug has been marked as a duplicate of bug 291262 ***