Bug 294181

Summary: Muon software center crash
Product: kde Reporter: edwinleroy <edwin.1515>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description edwinleroy 2012-02-15 19:50:30 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.1 (4.7.1) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Error when running "Muon software center", Muon software center does not work.
Please tell me I can do?
thank you very much
Greetings from Guatemala, Central America

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8d98d52780 (LWP 2591))]

Thread 2 (Thread 0x7f8d8450f700 (LWP 2592)):
#0  0x00007f8d95923773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8d92198f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8d92199429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8d97ae0ed6 in QEventDispatcherGlib::processEvents (this=0x1c6dd10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#4  0x00007f8d97ab4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8d97ab4ef7 in QEventLoop::exec (this=0x7f8d8450edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f8d979cc27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f8d97a97cbf in QInotifyFileSystemWatcherEngine::run (this=0x1b81380) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8d979ced05 in QThreadPrivate::start (arg=0x1b81380) at thread/qthread_unix.cpp:331
#9  0x00007f8d92c7aefc in start_thread (arg=0x7f8d8450f700) at pthread_create.c:304
#10 0x00007f8d9592f89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8d98d52780 (LWP 2591)):
[KCrash Handler]
#6  0x00007f8d97a1ca5e in QtPrivate::QStringList_contains (that=0x7fffdf396140, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffdf396140) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1c0b640) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1c0b640, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdf396710) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f8d97ac8eba in QMetaObject::activate (sender=0x1dde540, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1dde540, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdf396870) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f8d97ac8eba in QMetaObject::activate (sender=0x1c0b640, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffdf396870) at kernel/qobject.cpp:3278
#13 0x00007f8d98938e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1b2cc40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f8d98938f8e in MuonMainWindow::initObject (this=0x1c0b640) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1c0b640) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1c0b640, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdf396940) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f8d97ac8eba in QMetaObject::activate (sender=0x1ca9f50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f8d97ad0f7f in QSingleShotTimer::timerEvent (this=0x1ca9f50) at kernel/qtimer.cpp:308
#19 0x00007f8d97acc789 in QObject::event (this=0x1ca9f50, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f8d960f0424 in notify_helper (e=0x7fffdf396eb0, receiver=0x1ca9f50, this=0x1acfce0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1acfce0, receiver=0x1ca9f50, e=0x7fffdf396eb0) at kernel/qapplication.cpp:4458
#22 0x00007f8d960f5291 in QApplication::notify (this=0x7fffdf3971b0, receiver=0x1ca9f50, e=0x7fffdf396eb0) at kernel/qapplication.cpp:4365
#23 0x00007f8d972d41e6 in KApplication::notify (this=0x7fffdf3971b0, receiver=0x1ca9f50, event=0x7fffdf396eb0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f8d97ab5afc in QCoreApplication::notifyInternal (this=0x7fffdf3971b0, receiver=0x1ca9f50, event=0x7fffdf396eb0) at kernel/qcoreapplication.cpp:787
#25 0x00007f8d97ae2d62 in sendEvent (event=0x7fffdf396eb0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1ad4c30) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f8d97ae0514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f8d92198a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f8d92199258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f8d92199429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f8d97ae0ed6 in QEventDispatcherGlib::processEvents (this=0x1aab6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f8d9619807e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f8d97ab4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f8d97ab4ef7 in QEventLoop::exec (this=0x7fffdf397140, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f8d97ab9789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fffdf397428) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294180, bug 294179, bug 294155, bug 294153, bug 294150.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-15 19:55:28 UTC

*** This bug has been marked as a duplicate of bug 291262 ***