Bug 291592

Summary: Muon Crashs
Product: kde Reporter: Julio Zanardine <juliozanardine>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Julio Zanardine 2012-01-15 15:57:53 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I only open Muon and it's crashs, always. Since I installed the Kubuntu.
- Unusual behavior I noticed:
No one.

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7754930 (LWP 3283))]

Thread 2 (Thread 0xb566db70 (LWP 3284)):
#0  0x00a8fd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00b657d5 in do_gettime (frac=0xb566d020, sec=0xb566d018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00c384b6 in QTimerInfoList::updateCurrentTime (this=0x97b903c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00c3880a in QTimerInfoList::timerWait (this=0x97b903c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00c37053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb566d12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00c370ed in timerSourcePrepare (source=0x97b9008, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x082f088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x082f1637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x082f1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00c37b37 in QEventDispatcherGlib::processEvents (this=0x976e270, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00c081dd in QEventLoop::processEvents (this=0xb566d2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00c08421 in QEventLoop::exec (this=0xb566d2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00b0b90b in QThread::exec (this=0x974a780) at thread/qthread.cpp:498
#14 0x00be8e2d in QInotifyFileSystemWatcherEngine::run (this=0x974a780) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00b0e7b3 in QThreadPrivate::start (arg=0x974a780) at thread/qthread_unix.cpp:331
#16 0x00a5cd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0682d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7754930 (LWP 3283)):
[KCrash Handler]
#7  0x00b62e11 in QtPrivate::QStringList_contains (that=0xbf917fd4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf917fd4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x972c808) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x972c808, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9181f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00c0fb7d in metacall (argv=0xbf9181f4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x972c808) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x972c808, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9181f4) at kernel/qmetaobject.cpp:232
#13 0x00c1ea6a in QMetaObject::activate (sender=0x986f800, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x986f800) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x986f800, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf918338) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00c0fb7d in metacall (argv=0xbf918338, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x986f800) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x986f800, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf918338) at kernel/qmetaobject.cpp:232
#18 0x00c1ea6a in QMetaObject::activate (sender=0x972c808, m=0x80950c0, local_signal_index=0, argv=0xbf918338) at kernel/qobject.cpp:3278
#19 0x003637c5 in MuonMainWindow::backendReady (this=0x972c808, _t1=0x961f1b0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00363933 in MuonMainWindow::initObject (this=0x972c808) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x972c808) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x972c808, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf918464) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00c0fb7d in metacall (argv=0xbf918464, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x972c808) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x972c808, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf918464) at kernel/qmetaobject.cpp:232
#25 0x00c1ea6a in QMetaObject::activate (sender=0x9786258, m=0xd3f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00c26375 in QSingleShotTimer::timeout (this=0x9786258) at .moc/release-shared/qtimer.moc:82
#27 0x00c2642c in QSingleShotTimer::timerEvent (this=0x9786258) at kernel/qtimer.cpp:308
#28 0x00c21994 in QObject::event (this=0x9786258, e=0xbf91885c) at kernel/qobject.cpp:1181
#29 0x03491d54 in notify_helper (e=0xbf91885c, receiver=0x9786258, this=0x962b168) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x962b168, receiver=0x9786258, e=0xbf91885c) at kernel/qapplication.cpp:4458
#31 0x03497103 in QApplication::notify (this=0xbf91885c, receiver=0x9786258, e=0xbf91885c) at kernel/qapplication.cpp:3886
#32 0x01148681 in KApplication::notify (this=0xbf918b70, receiver=0x9786258, event=0xbf91885c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00c0919e in QCoreApplication::notifyInternal (this=0xbf918b70, receiver=0x9786258, event=0xbf91885c) at kernel/qcoreapplication.cpp:787
#34 0x00c39c10 in sendEvent (event=0xbf91885c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x962649c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00c37122 in timerSourceDispatch (source=0x9626468) at kernel/qeventdispatcher_glib.cpp:184
#37 0x082f125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x082f1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x082f1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00c37ada in QEventDispatcherGlib::processEvents (this=0x9608238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03549e3a in QGuiEventDispatcherGlib::processEvents (this=0x9608238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00c081dd in QEventLoop::processEvents (this=0xbf918ad4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00c08421 in QEventLoop::exec (this=0xbf918ad4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00c0d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0348f8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291590, bug 291588, bug 291581, bug 291580, bug 291572.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 16:07:43 UTC

*** This bug has been marked as a duplicate of bug 291262 ***