Bug 284308

Summary: Kwin crash while repainting/recompositing the desktop after setting up second display
Product: kwin Reporter: Hrvoje Senjan <hrvoje.senjan>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: bruno
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Xorg.0.log
kwinrc

Description Hrvoje Senjan 2011-10-17 21:53:57 UTC
Application: kwin (4.7.2 (4.7.2))
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-rc9-1-desktop x86_64
Distribution: "openSUSE 12.1 Beta 1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
As the title says - kwin crash in that situation. I'm using fglrx drivers (note that this deosn't happen with the same version of drivers and kwin on Arch and Kubuntu 11.10 so could be a packaging issue?).

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f714610c760 (LWP 1671))]

Thread 2 (Thread 0x7f712cbe2700 (LWP 1703)):
#0  0x00007f7141944e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f714476e6d2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f7144a66e80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f714476e709 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f7141940f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f714594a24d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f714610c760 (LWP 1671)):
[KCrash Handler]
#6  0x00007f7145990040 in __memcpy_ssse3 () from /lib64/libc.so.6
#7  0x00007f714318bd05 in __indirect_glProgramParameters4fvNV (target=1, index=9440612, num=1170190104, params=0xd1dca0) at /usr/include/bits/string3.h:52
#8  0x00007f712cd24dbf in KWin::ARBBlurShader::init (this=0x900d50) at /usr/src/debug/kde-workspace-4.7.2/kwin/effects/blur/blurshader.cpp:463
#9  0x00007f712cd21c05 in KWin::BlurEffect::reconfigure (this=0x8f88c0, flags=<optimized out>) at /usr/src/debug/kde-workspace-4.7.2/kwin/effects/blur/blur.cpp:83
#10 0x00007f712cd21d9c in KWin::BlurEffect::BlurEffect (this=0x8f88c0) at /usr/src/debug/kde-workspace-4.7.2/kwin/effects/blur/blur.cpp:53
#11 0x00007f712cd21e86 in KWin::effect_create_kwin4_effect_blur () at /usr/src/debug/kde-workspace-4.7.2/kwin/effects/blur/blur.cpp:33
#12 0x00007f7145ce88e2 in KWin::EffectsHandlerImpl::loadEffect (this=0x97fac0, name=..., checkDefault=false) at /usr/src/debug/kde-workspace-4.7.2/kwin/effects.cpp:1125
#13 0x00007f7145ce9c3a in KWin::EffectsHandlerImpl::reconfigure (this=0x97fac0) at /usr/src/debug/kde-workspace-4.7.2/kwin/effects.cpp:189
#14 0x00007f7145cea148 in KWin::EffectsHandlerImpl::EffectsHandlerImpl (this=0x97fac0, type=<optimized out>) at /usr/src/debug/kde-workspace-4.7.2/kwin/effects.cpp:121
#15 0x00007f7145cbf3dd in KWin::Workspace::setupCompositing (this=0x8157a0) at /usr/src/debug/kde-workspace-4.7.2/kwin/composite.cpp:180
#16 0x00007f7145cbfe65 in KWin::Workspace::setupCompositing (this=<optimized out>) at /usr/src/debug/kde-workspace-4.7.2/kwin/composite.cpp:94
#17 0x00007f7145c3fcdb in KWin::Workspace::qt_metacall (this=0x8157a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x99f070) at /usr/src/debug/kde-workspace-4.7.2/build/kwin/workspace.moc:499
#18 0x00007f7141ccdfaa in QObject::event (this=0x8157a0, e=<optimized out>) at kernel/qobject.cpp:1226
#19 0x00007f7140e69be4 in notify_helper (e=0x99b100, receiver=0x8157a0, this=0x6496a0) at kernel/qapplication.cpp:4481
#20 QApplicationPrivate::notify_helper (this=0x6496a0, receiver=0x8157a0, e=0x99b100) at kernel/qapplication.cpp:4453
#21 0x00007f7140e6ea71 in QApplication::notify (this=0x7fff1e97a550, receiver=0x8157a0, e=0x99b100) at kernel/qapplication.cpp:4360
#22 0x00007f714543ee36 in KApplication::notify (this=0x7fff1e97a550, receiver=0x8157a0, event=0x99b100) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#23 0x00007f7141cb767c in QCoreApplication::notifyInternal (this=0x7fff1e97a550, receiver=0x8157a0, event=0x99b100) at kernel/qcoreapplication.cpp:787
#24 0x00007f7141cbaa58 in sendEvent (event=0x99b100, receiver=0x8157a0) at kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6080f0) at kernel/qcoreapplication.cpp:1428
#26 0x00007f7140f0dafa in sendPostedEvents () at ../../src/corelib/kernel/qcoreapplication.h:220
#27 QEventDispatcherX11::processEvents (this=0x6078d0, flags=...) at kernel/qeventdispatcher_x11.cpp:75
#28 0x00007f7141cb6882 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f7141cb6a7f in QEventLoop::exec (this=0x7fff1e97a490, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007f7141cbac47 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#31 0x00007f7145c5d5f6 in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kde-workspace-4.7.2/kwin/main.cpp:517
#32 0x00007f714589223d in __libc_start_main () from /lib64/libc.so.6
#33 0x0000000000400681 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 281540, bug 280337, bug 280324, bug 277603, bug 275325.

Reported using DrKonqi
Comment 1 Hrvoje Senjan 2011-10-17 21:54:30 UTC
Created attachment 64651 [details]
Xorg.0.log
Comment 2 Hrvoje Senjan 2011-10-17 21:55:13 UTC
Created attachment 64653 [details]
kwinrc
Comment 3 Thomas Lübking 2011-10-17 22:25:10 UTC
see (your) bug #273697 - if fglrx now crashes for that (mesa?!) ARB shader bug and still(?) for it's glsl own one, you cannot use shaders at all (great...) ie. have to disable blurring and the lanczos filter ("accurate" scale method)

but first try /with/ direct rendering, in doubt force: "KWIN_DIRECT_GL=1"

*** This bug has been marked as a duplicate of bug 270818 ***
Comment 4 Hrvoje Senjan 2011-10-17 22:30:58 UTC
Lanczos filter is already disabled.
I did see drkonqi suggest that bug report but i thought they weren't releted cause i use fglrx, not mesa. As i said this does not happen on Kubuntu and Arch so i double checked that fglrx is used , and indeed it is. Will try with direct rendering
Comment 5 Thomas Lübking 2011-10-17 23:03:42 UTC
the __indirect_glProgramParameters4fvNV function is from the mesa glx implementation. it's because you're using indirect rendering and has no meaning about your driver.
Comment 6 Bruno Friedmann 2011-11-12 16:49:11 UTC
@Hrvoje how did you installed the fglrx drivers ? 
directly from the ati .run ?
Comment 7 Hrvoje Senjan 2011-11-13 08:39:05 UTC
I installed it from your repo :)