Bug 277603 - KWin crashes when visual effects switches on
Summary: KWin crashes when visual effects switches on
Status: RESOLVED DUPLICATE of bug 247430
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-12 07:42 UTC by Viktor Yu. Kovalskii
Modified: 2011-07-12 07:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor Yu. Kovalskii 2011-07-12 07:42:55 UTC
Application: kwin (4.6.5 (4.6.5))
KDE Platform Version: 4.6.5 (4.6.5) (Compiled from sources)
Qt Version: 4.7.3
Operating System: Linux 2.6.39-gentoo-r2 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
1) Start session
2) Try to switch on visual effects
3) KWin crashes

emerge -1 `qlist -I -C x11-drivers/*` x11-base/xorg-server x11-libs/libdrm kde-base/kwin media-libs/mesa x11-apps/mesa-progs -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-libs/libdrm-2.4.26  USE="libkms -static-libs" VIDEO_CARDS="intel -nouveau -radeon -vmware" 0 kB
[ebuild   R    ] media-libs/mesa-7.11_rc1-r1  USE="classic egl gallium llvm motif nptl shared-glapi -bindist -debug -gles -openvg -pic (-selinux) -shared-dricore" VIDEO_CARDS="intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -tdfx -via -vmware" 0 kB
[ebuild   R    ] x11-base/xorg-server-1.10.3  USE="nptl udev xorg -dmx -doc -ipv6 -kdrive -minimal -static-libs -tslib -xnest -xvfb" 0 kB
[ebuild   R    ] x11-drivers/xf86-input-evdev-2.6.0  0 kB
[ebuild   R    ] x11-drivers/xf86-video-intel-2.15.0-r1  USE="dri" 0 kB
[ebuild   R    ] kde-base/kwin-4.6.5  USE="debug opengl xcomposite (-aqua) (-kdeenablefinal) -xinerama" 0 kB
[ebuild   R    ] x11-apps/mesa-progs-8.0.1  0 kB

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f2a1b86db25 in ?? () from /lib64/libc.so.6
#7  0x00007f2a1906625a in __indirect_glProgramParameters4fvNV (target=1, index=9233364, num=9262208, params=<value optimized out>) at /usr/include/bits/string3.h:52
#8  0x00007f2a03be9049 in KWin::ARBBlurShader::init (this=0x8ce3c0) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/effects/blur/blurshader.cpp:473
#9  0x00007f2a03be8a21 in KWin::BlurShader::setRadius (this=0x8ce3c0, radius=12) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/effects/blur/blurshader.cpp:55
#10 0x00007f2a03be6e3f in KWin::BlurEffect::reconfigure (this=0x8cea00, flags=<value optimized out>) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/effects/blur/blur.cpp:76
#11 0x00007f2a03be6f67 in KWin::BlurEffect::BlurEffect (this=0x8cea00) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/effects/blur/blur.cpp:48
#12 0x00007f2a03be700f in KWin::effect_create_kwin4_effect_blur () at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/effects/blur/blur.cpp:29
#13 0x00007f2a1bbad8b4 in KWin::EffectsHandlerImpl::loadEffect (this=0x7ce980, name=...) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/effects.cpp:1128
#14 0x00007f2a1bbadf6a in KWin::EffectsHandlerImpl::reconfigure (this=<value optimized out>) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/effects.cpp:143
#15 0x00007f2a1bb8ed95 in KWin::Workspace::setupCompositing (this=0x7521a0) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/composite.cpp:216
#16 0x00007f2a1bb220e6 in KWin::Workspace::Workspace (this=0x7521a0, restore=false) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/workspace.cpp:222
#17 0x00007f2a1bb3b4bb in KWin::Application::Application (this=<value optimized out>) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/main.cpp:330
#18 0x00007f2a1bb3c16d in kdemain (argc=<value optimized out>, argv=0x7fff8e877ce8) at /var/tmp/portage/kde-base/kwin-4.6.5/work/kwin-4.6.5/kwin/main.cpp:516
#19 0x00007f2a1b77de60 in __libc_start_main () from /lib64/libc.so.6
#20 0x0000000000400781 in _start ()

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-07-12 07:58:30 UTC
Just the same as your bug #277598

Please notice that nouveau-dri is afaik NOT in shape for productive use.

*** This bug has been marked as a duplicate of bug 247430 ***